Panel Moves on Restart?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Panel Moves on Restart?

Postby curt_grymala on Sat Jul 11, 2009 12:03 am

I am currently using Linux Mint 7 x64, though this issue is also present in Linux Mint 6 x86 and Linux Mint 7 x86. I have tested this issue on multiple computers, including VirtualBox installations of Linux Mint 7 x64 and x86.

I keep my main Mint panel docked at the top of my screen with it set to auto-hide. I also created a new panel and docked it at the bottom of my screen (I use it sort of as a "quick launch" panel). If I keep it expanded, everything works just fine. However, if I uncheck the "Expand" checkbox in the properties for the bottom panel, it will appear at the top of my screen when I reboot.

I have tested this by docking the "quick launch" panel at the left side of the screen, and it stays where it is supposed to upon restart. However, any time I keep it docked at the bottom, with "Expand" disabled, it always repositions itself at the top of the screen on restart.

Does anyone know how to solve this issue? Is this a bug? Does anyone know if this is present in Ubuntu (I doubt it, since Ubuntu generally places the main panel at the top of the screen, rather than the bottom - as is the default in Mint)?

Any help or advice would be greatly appreciated. Thank you.
curt_grymala
Level 3
Level 3
 
Posts: 128
Joined: Fri Sep 12, 2008 10:16 pm

Linux Mint is funded by ads and donations.
 

Re: Panel Moves on Restart?

Postby clhodapp on Sat Jul 11, 2009 1:00 am

Open the gconf editor: mintMenu->Terminal->gconf-editor.
Navigate to /apps/panel/toplevels/<whichever panel is not expaned> and set the key "y_bottom" to 1.
clhodapp
Level 3
Level 3
 
Posts: 185
Joined: Wed Feb 04, 2009 3:57 am
Location: Tuscaloosa, AL

Re: Panel Moves on Restart?

Postby curt_grymala on Sat Jul 11, 2009 10:27 am

Thanks for the response. That fixed it. For some reason, the "y_bottom" value was set to -1 instead of 0. Changing it to 0 made it stop jumping back to the top of the screen on restart.
curt_grymala
Level 3
Level 3
 
Posts: 128
Joined: Fri Sep 12, 2008 10:16 pm

Re: Panel Moves on Restart?

Postby clhodapp on Sat Jul 11, 2009 11:35 am

glad that worked, but I think it really should be 1. Logic is supposed to be 1=true, -1=false.
clhodapp
Level 3
Level 3
 
Posts: 185
Joined: Wed Feb 04, 2009 3:57 am
Location: Tuscaloosa, AL

Re: Panel Moves on Restart?

Postby kandieyman on Sat Jul 11, 2009 6:00 pm

I agree, but you may want to be careful with that observation. In gconf, -1 also often means "last used" (case in point: mintMenu). When editing gconf, just try to be careful what you are changing from and changing to.
User avatar
kandieyman
Level 1
Level 1
 
Posts: 48
Joined: Mon Jun 15, 2009 1:24 pm


Return to Newbie Questions

Who is online

Users browsing this forum: MSN [Bot] and 24 guests