White screen when trying to activate Beryl!

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

White screen when trying to activate Beryl!

Postby faraaz on Sun Jun 03, 2007 10:30 pm

Hi Guys,

I installed Mint 3.0 and everything worked fine. Then I started off with configuring my system and the first thing I did was go to the Control Panel and enable desktop effects (window wobble etc). When I did, the screen went white and thats it!! Now everytime I log in, even with the failsafe mode, I only ever get a blank white screen. No menu, no taskbar nothing. Only my mouse cursor is seen.

Um, I formatted and re-installed my Mint install, so I can try this again now. I am using an Intel C2D 2.4 GHz, ATi Radeon X1650 256 MB with 2 GB RAM & 300 GB SATA. Can someone please give me a step by step walkthrough on enabling Beryl WITHOUT screwin up my system on a fresh install?
faraaz
Level 1
Level 1
 
Posts: 11
Joined: Tue May 29, 2007 10:00 am

Linux Mint is funded by ads and donations.
 

Postby Husse on Mon Jun 04, 2007 7:00 am

A white (or black) box or screen is known to happen with Beryl now and then.
To begin with - did you install new drivers for video?
The ones out of the box only supports 2D.
You will find Envy in the menu under "System tools"
When you've installed the drivers you should be able to use Beryl..
Some participants in the forum say you have to run Envy more than once - never happened to me....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby D1Wayne on Mon Jun 04, 2007 8:15 am

I would agreed with Husse. but if envy .93 fails to solve problem
try envy .94 from
http://www.albertomilone.com/nvidia_scripts1.html
I've run this on the Radeon and Nvidia machines (faster drivers)
if that solves your problem read on at my amusement:)

pls post what ever your results, the more feedbacks the better facts
can be delivered to others

Just discovered a few new facts.
am in the middle of some additional fact grabbing

but basically thar be 2 or 4 classes of compatibility with ATI cards
1) Do not suport Composite DRI, GLX or AIGLX
2) Those that support Composite DRI. AIGLX somewhat
3) Those that run well Composite AIGLX
4) And those that I think that require diableing both Composite and AIGlX

I do not have all the info yet (most likely never will) but tseliot Envy installs
the latest drivers true, but so far that I've seen always "fglrx" and Composite Disabled

my radeon 9550 (seen as a
ATI Technologies Inc RV350 AS [Radeon 9550]
and needs the slower "radeon" driver and composite enabled plus several other tweaks in xorg.conf.

the X1600 / R530 based cards are stated as not compatible for Composite
+AIGLX.
if the above is your card you need a different solution than me.
if you do a
lspci
and post the vedorID string for your card it will make it easier to find the proper course of action
D1Wayne
Level 3
Level 3
 
Posts: 198
Joined: Tue Apr 24, 2007 6:11 am
Location: Pacific North West

Postby D1Wayne on Mon Jun 04, 2007 8:25 am

Hi faraaz -
spotted a how-to for you \r card
you are one of the NO AIGLX cards
Howto link
[url]
http://ubuntuguide.org/wiki/Ubuntu:Feisty#Eye_Candy[/url]

hope this helps
D1Wayne
Level 3
Level 3
 
Posts: 198
Joined: Tue Apr 24, 2007 6:11 am
Location: Pacific North West

Postby Lolo Uila on Mon Jun 04, 2007 3:46 pm

The Radeon X1K series cards are not supported by the open-source ATI driver (yet), and the proprietary ATI driver does not support composite extensions.

In order to get Beryl/Compiz running with the ATI binary driver you need to use XGL. There are several guides to installing this if you google around. A good starting point is the Beryl wiki page.

http://wiki.beryl-project.org/wiki/Inst ... y_with_XGL

I have Beryl running on dual monitors using the open-souce driver with my X800 XT PE and it's pretty cool. I've been meaning to try it with XGL, but haven't done it yet.

Good luck.

Aloha, Tim
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 548
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], tdockery97, terlica and 41 guests