[SOLVED] Slow internet connection on Felicia !

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

[SOLVED] Slow internet connection on Felicia !

Postby NYDAz on Mon Aug 17, 2009 10:47 am

Hi everybody !

I've searched and researched the internet for technical details about why my linux mint is terrible slow on internet than windows xp !

I have a main computer connected to internet ! Has Windows XP installed and I've created a network !
This computer has the following IP : 192.168.0.1

Now ...

I have a laptop which runs two OS : LinuxMint and Windows XP

On the 2nd computer when I run Windows XP everything run smoothly, all pages are loading, streaming it's working !

But when I try with LinuxMint some websites are working others don't !

For example on Windows XP kronehit.at it's working ! On LinuxMint don't work (The cursor it's loading over and over and over) !

Some ideas on how to sort this thing out ?!

Thanks and any help is as always appreciated !

:)
Last edited by NYDAz on Wed Aug 19, 2009 11:09 am, edited 1 time in total.
Send my love to Felicia & Gloria !
User avatar
NYDAz
Level 1
Level 1
 
Posts: 35
Joined: Tue May 12, 2009 10:04 am
Location: Sin City

Linux Mint is funded by ads and donations.
 

Re: Slow internet connection on Felicia !

Postby lagagnon on Mon Aug 17, 2009 11:54 am

Are you using wireless or a wired connection to the Internet? Is the speed OK on other web pages or just that one you mentioned?
User avatar
lagagnon
Level 7
Level 7
 
Posts: 1888
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: Slow internet connection on Felicia !

Postby Kaye on Mon Aug 17, 2009 12:58 pm

kronehit.at runs perfectly for me. Does it appear that sites with flash are the ones loading slowly? If so, try
Code: Select all
apt remove --purge flashplugin-nonfree && apt install adobe-flashplugin
"In somnis veritas"
Antivirus or defragging?
Image
User avatar
Kaye
Level 5
Level 5
 
Posts: 942
Joined: Fri Feb 06, 2009 5:05 pm
Location: Boston College

Re: Slow internet connection on Felicia !

Postby NYDAz on Mon Aug 17, 2009 6:34 pm

lagagnon wrote:Are you using wireless or a wired connection to the Internet? Is the speed OK on other web pages or just that one you mentioned?

wired connection ... the speed is the same as in windows for some sites but for mostly .. it stucks on load

Kaye wrote:kronehit.at runs perfectly for me. Does it appear that sites with flash are the ones loading slowly?

youtube loads instantly so I don't think it's a flash bug
Send my love to Felicia & Gloria !
User avatar
NYDAz
Level 1
Level 1
 
Posts: 35
Joined: Tue May 12, 2009 10:04 am
Location: Sin City

Re: Slow internet connection on Felicia !

Postby moodywoody on Mon Aug 17, 2009 7:42 pm

Two things that helped me increase browsing speed on various linux distros:

1. Use opendns (opendns.org). Configuration basically boils down to

Code: Select all
   
    $ sudo cp /etc/resolv.conf /etc/resolv.conf.auto
    $ gksudo gedit /etc/dhcp3/dhclient.conf
    # append the following line to the document
    prepend domain-name-servers 208.67.222.222,208.67.220.220;
    # save and exit
    $ sudo ifdown eth0 && sudo ifup eth0


You may be required to change eth0 to your own network device's name if it uses a non-standard name. Sometimes you have to reboot after this. You can see that the changes are in effect by browsing to opendns.org. When they are actice the homepage says 'You are using OpenDNS'.

2. Set browser from system proxy settings to no proxy. For Firefox

Menu > Edit > Preferences > Advanced > (Connection) Settings > choose 'No Proxy'

If this doesn't help can you please post the terminal output of

ping kronehit.at
dig kronehit.at
wget kronehit.at

Cheers
moodywoody
Level 2
Level 2
 
Posts: 70
Joined: Fri Aug 07, 2009 5:27 am

Re: Slow internet connection on Felicia !

Postby NYDAz on Tue Aug 18, 2009 4:56 am

moodywoody wrote:Two things that helped me increase browsing speed on various linux distros:
1. Use opendns (opendns.org). ...

I've tried opendns ! But the problem is this ... the site is not loading slow .... the site is not loading at ALL :x

moodywoody wrote:2. Set browser from system proxy settings to no proxy. For Firefox

Menu > Edit > Preferences > Advanced > (Connection) Settings > choose 'No Proxy'

This is the way I had it on Firefox ! And it's not working !

moodywoody wrote:If this doesn't help can you please post the terminal output of

ping kronehit.at
dig kronehit.at
wget kronehit.at


ping kronehit.at
Image

dig kronehit.at
Image

wget kronehit.at
Image

I notice that wget is not working ! any suggestions !???
Send my love to Felicia & Gloria !
User avatar
NYDAz
Level 1
Level 1
 
Posts: 35
Joined: Tue May 12, 2009 10:04 am
Location: Sin City

Re: Slow internet connection on Felicia !

Postby moodywoody on Tue Aug 18, 2009 7:42 am

Please try

Code: Select all
$ telnet kronehit.at 80


following this command you should see

Code: Select all
Trying 85.126.166.10...
Connected to kronehit.at.
Escape character is '^]'.
and you will be prompted to the next line

type
Code: Select all
GET
and hit enter. If successful you should see a long listing of the source-html for the landing page of kronehit.at. If not - please post the results.
moodywoody
Level 2
Level 2
 
Posts: 70
Joined: Fri Aug 07, 2009 5:27 am

Re: Slow internet connection on Felicia !

Postby NYDAz on Tue Aug 18, 2009 10:18 am

moodywoody wrote:Please try

Code: Select all
$ telnet kronehit.at 80


following this command you should see

Code: Select all
Trying 85.126.166.10...
Connected to kronehit.at.
Escape character is '^]'.
and you will be prompted to the next line

type
Code: Select all
GET
and hit enter. If successful you should see a long listing of the source-html for the landing page of kronehit.at. If not - please post the results.


Thanks for your answers until now moody !

Trying with $ telnet kronehit.at 80

I got what you said
Code: Select all
Trying 85.126.166.10...
Connected to kronehit.at.
Escape character is '^]'.


Then I'm prompted to the next line where I write GET and it stucks there !
Send my love to Felicia & Gloria !
User avatar
NYDAz
Level 1
Level 1
 
Posts: 35
Joined: Tue May 12, 2009 10:04 am
Location: Sin City

Re: Slow internet connection on Felicia !

Postby moodywoody on Wed Aug 19, 2009 1:21 am

Meh, this all looks kind of strange. The server let's you connect on port 80 but then doesn't reply to the GET request ... pfff :?

Ok, I'd like to have another go at some more info. First, could you list about two more websites that do not and two that do work for you?

Second .. can you please install the w3c command line tool? You can get it from here

w3c command line tool

1. Download one of the 2002 tarballs
2. Extract and change into that directory
3. Run (as root) the holy trinity of
Code: Select all
$  ./configure
$  make
$  make install


and then please post the output of both

Code: Select all
w3c -vpsu http://kronehit.at
w3c -head -vpsu http://kronehit.at
moodywoody
Level 2
Level 2
 
Posts: 70
Joined: Fri Aug 07, 2009 5:27 am

Re: Slow internet connection on Felicia !

Postby NYDAz on Wed Aug 19, 2009 10:08 am

Meeehh ...

I've deleted Felicia and installed Gloria and until now everything it's working like it supposed

Thanks all for your help
Send my love to Felicia & Gloria !
User avatar
NYDAz
Level 1
Level 1
 
Posts: 35
Joined: Tue May 12, 2009 10:04 am
Location: Sin City

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 24 guests