How to Remote Desktop to a 'backgrounded' Gnome session

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

How to Remote Desktop to a 'backgrounded' Gnome session

Postby kmrdeva on Wed Aug 19, 2009 1:25 pm

Hey guys,

I have 2 user accounts set up in my Gloria x64 installation, let's say that they are 'user1' and 'user2'. I have 'Remote Desktop' sharing enabled under the user2's configuration and I've been wondering if it'd be possible to vnc to user2's Gnome desktop from another computer while user1's desktop session is active (i.e. my wife logs in to 'user1' to use the computer), essentially having both sessions active (one locally displayed, one remotely accessed).

I've been trying this out and I've noticed a few limitations/issues:

1. user2 has to be logged in for vnc to even work. If user1 is the only logged in session, the my vnc client fails to connect to the computer. I'm guessing that this is a feature and not a bug?

2. user2's session gets displayed in the remote vnc client only if user2's session is the active one being displayed on the local computer's screen. If I 'switch' to user1, my vnc client doesn't disconnect but blanks out at the remote site. Desktop display resumes when I switch the active session from user1 back to user2 on the local computer.

Should I forget VNC and go with FreeNX or xRDP instead? Will either of these fix issue (2)? Any advice or suggestion is greatly welcomed. Thanks.
Regards,
Kumar
- Mint7 x64 on a PC with Intel Q8400 CPU, Intel DG45ID M/Board, 8GB DDR2 RAM, Nvidia 9500GT, 320GB & 1TB SATA HDDs -
kmrdeva
Level 1
Level 1
 
Posts: 42
Joined: Wed Jun 03, 2009 12:48 am

Linux Mint is funded by ads and donations.
 

Re: How to Remote Desktop to a 'backgrounded' Gnome session

Postby meskarune on Wed Aug 19, 2009 3:45 pm

The option to remote login to your system is in user2's configuration, which doesn't get loaded unless user2 is logged in, thus you can only connect to the computer when user2 is logged in. You could change the settings of your computer to boot the vnc server with the system.

I think that FreeNX would be the best option. Its based on ssh, which is the most secure and useful protocol for connecting to a linux machine. Its more complicated to set up though. This site might help:
https://help.ubuntu.com/community/FreeNX
The only limiting factor of the Linux operating system, is its user. -Linus Torvalds
User avatar
meskarune
Level 2
Level 2
 
Posts: 88
Joined: Tue Aug 18, 2009 5:06 pm
Location: USA

Re: How to Remote Desktop to a 'backgrounded' Gnome session

Postby kmrdeva on Wed Aug 19, 2009 8:37 pm

Thanks for the info, meskarune. I managed to set up FreeNX on my computer a couple of hours after my post. It was fairly easy, the steps listed on this page really helped a lot - http://alandoyle.com/tutorials/setup-freenx-under-ubuntu/.

FreeNX starts as a service/daemon automatically, which is really convenient as it fixes issue 1 (automatic startup) so I don't need to locally login as user2 before being able to do remote control/access. Instead, it creates a totally new Gnome (GDM?) session for user2 which I can even leave running when I close the remote client's window.

Unfortunately, I found no way of accessing this session locally back on my computer..
kmrdeva
Level 1
Level 1
 
Posts: 42
Joined: Wed Jun 03, 2009 12:48 am


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 31 guests