Slow Internet Coonection in Mint 7 Gloria

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Re: Slow Internet Coonection in Mint 7 Gloria

Postby emorrp1 on Fri Sep 11, 2009 7:04 am

This is the tutorial recommended for ipv6 change (installs a newer kernel): http://www.ubuntu-inside.me/2009/04/how ... aunty.html
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Linux Mint is funded by ads and donations.
 

Re: Slow Internet Coonection in Mint 7 Gloria

Postby exploder on Fri Sep 11, 2009 9:08 am

Just throwing in a few tweaks I have found. I turn off two settings in Firefox to improve speed. I turn off:

Tell me if the site I am visiting is a suspected attack site.

Tell me if the site I am visiting is a suspected forgery.

This tip seems to help too.

http://www.pclinuxos.com/index.php?opti ... ic=61626.0

I think the problems people are experiencing are related to Firefox and how it is built for Linux.
exploder
Level 15
Level 15
 
Posts: 5872
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA

Re: Slow Internet Coonection in Mint 7 Gloria

Postby phil on Fri Sep 11, 2009 9:23 am

More info: I am using ethernet. The problem with slowness effects both Thunderbird and Firefox. Downloads, once they are started do not seem to be effected. There were some slow DNS look-ups this morning, but Windows timed out very soon and Mint did not, just bogged down and locked up access to my gateway.

I am using Windows this morning because Mint is all but out of service. I will try disabling IPV6. Maybe that is the problem.

I am using the 2.6.28-15 generic kernel and it seems from what I read that it is necessary to have the 2.6.31 kernel to be able to effectively disable ipv6.

This afternoon I had some time and tried some of the above suggestions. They may help a little. Another I found suggested on other forums was lowering the default timeout of DNS in resolv.conf. I changed it from the default of 5 seconds to 1 second and that did help, but the problem still exists. Something is causing a blocking of my access to my gateway still. By going to WICD and disconnecting and then reconnecting the problem goes away for a short while.
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: Slow Internet Coonection in Mint 7 Gloria

Postby theevilone6620 on Fri Sep 11, 2009 7:03 pm

Exploder,
The problem is not with Firefox, and I am almost certain about this as I've used every browser possible while running Mint and they are all effected the same with terribly slow speeds.

Miket,
When I first read your post about the software that some ISP's are installing on you Windows box to utilize compression techniques I thought to myself that this indeed may be the culprit. However, after thinkning about this for awhile, I realized that the software you are referring to was only installed on one of my laptops during installation of my cable modem and so therefore that eliminates that altogether. I get great speeds on both of my laptops when using Windows both the one with the software you mentioned and the one without it.

Also, I have tried plugging my laptop into the router with the ethernet jack to see how my speed would be effected and believe it or not, this actually made things worse for me. Not by much, but there was definately a speed decrease while running Mint through my ethernet port of my router. I still havent tried hooking directly into the Modem to see whether or not the router is the culprit. I plan on doing this sometime tonight actually.

I do not know why I never considered trying that out but I always just thought it was Mint as Windows is not effected at all by slow speeds. It is still really puzzling as to why using ethernet wouldnt give me a speed increase but it truly does not.

If the problem is in fact the router as Husse stated in his post, does anyone have a list of routers that are not effected by this and a list of routers that are? Once we have figured out exactly were these terribly slow speeds are coming from and if it is in fact a router issue we should start a list of routers that are effected by this.

Husse,
Just out of curiosity what type of router are you using?

Man Ive searched high and low to figure this out and it seems like I never get anywhere. First I was convinced it was drivers, but once I installed Mint on 2 other laptops it made it clear that drivers werent the issue. Even haven installed Mint on 3 laptops total here at my house, I was still skeptical as to whether or not the problem may in fact be caused by lousy wifi support on linux based operating systems as Ive read so much about it on the internet. But the nail in the coffin had to be when I hooked up my laptop to the ethernet jack and just took the wifi thing out of the picture. To my surprise my speeds werent any better at all. And at sometimes seemed like they were worse than when using Wifi.

There definately is a issue with internet speeds here on Linux and it's definately not just Mint. I thought maybe it was just Ubuntu and its children OS's but although I have never successfully gotten any of my laptops set up using Wifi on another Linux OS, I have used them with ethernet connection and they too suffer from slow as all hell internet speeds.

I will keep you guys posted as to what happens when I take the router out of the picture and just hook directly into my cable modem. If anyone has any more advice please let me know.

One final thing I should add is that the problem is not from IPV6, I have heard alot of talk about this being the main reason for slow internet speeds but the simple fact is that if I am not mistaken which I am pretty sure I'm not, is that Mint7 and Jaunty are the only versions that have IPV6 on by default with no option of disabling it. If this is the truth then only these versions should be plagued by this issue. For me it does not matter like I said I have used plenty of versions of Linnux based OS and the problem is there with all that I have tried. If it was just IPV6 I should be able to just switch over to Mint 6 or 5 and be alright. Mint 5 I have not tried but the issue is still there in all its ugliness in Mint 6 as well as , Ubuntu jaunty, Kubuntu, OpenSuse 11, Fedora 11, Debian Lenny, Sabayon, Mandriva(whatever the newest version is).

So I can say with confidence its not IPV6.
Check out my blog at http://mintguru.blogspot.com/If anyone would like to contribute to the project send me a message..
Follow me on Twitter http://twitter.com/LinuxDruid
User avatar
theevilone6620
Level 4
Level 4
 
Posts: 212
Joined: Sun Jul 12, 2009 8:40 am

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Sat Sep 12, 2009 7:34 am

I think we are getting a bit towards understanding this - but we need to know moore
IPv6 is indeed a candidate and the compression program in some Windows also, but not the solution
I use a Dlink modem-router that by now is at least 5 years old. I have upgraded the firmware though
DSL-504T
Again - remember this is a two step thing
1) From the equipment the ISP has* to the modem
2) From the modem/router to your computer
*this can be a variety of different equipment and in some cases you don't have a modem, but mostly you have some sort of "box"
I have 8 Mbit/s ADSL and the speed I find when I look in the configuration pages for DSL-504T is 8000 kbit/s
This also about what I get in normal use in my different computers - Win or Lin
Take a look in the config for your ADSL modem (if you have ADSL) and see what speed you get - it should not vary if you look at it from Windows or Linux - if it does you have a problem
The next step would be to use wireshark or some such to analyze traffic in Win and Lin
I think this is a problem of some hardware not liking Linux, but I can't be sure
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby phil on Sat Sep 12, 2009 11:30 am

After modifying my resolv.conf to time out at 1 sec instead of 5 sec I see a considerable improvement in access to the internet, without any time-outs so far. I plan to modify resolve.conf on two other computers today. I cannot measure the actual traffic flow at this time, but I plan to get some software that will allow doing this.

One of my friends is a network guru and assisted me in operating a wireless internet service from Mexico for several years. I am going to try to enlist his help. He is an Ubuntu and Centos fan. He has noticed the slow downs and stalls but rarely goes on line with Windows so so far is unable to compare performance..

I am using an Zoom ASDL X5 modem/router series 0228 furnished by the telephone company. I am convinced that the slowness has nothing to do with the modem/router since Windows XP SP3+ which is dual booted on three computers attached to the modem/router do not have a problem. Two of my computers have Mint 7 XFCE and one Mint 6 XFCE on them. The problem exists on all three.

It has also occurred to me that our remote location aggravates the problem. We probably have less service bandwidth via under the sea fiber cable than most of the rest of you on the forum to your house. And I am referring to the entire Caribbean area as the service area. One meg is the maximum available. My typical rate is 280mbps down and 120mbps up. My typical ping to
US locations, for instance open DNS (208.67.222.222) is about 70 ms. Dig @208.67.222.222 is 115ms so if anything hangs up somewhere in between a timeout of 5 s becomes a big delay. Microsoft uses about a 1 sec time-out. I get much faster response with my ISP but I think his DNS may be intermittent in returning an answer. And TTL from my tests is very short.

More later.

phil
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: Slow Internet Coonection in Mint 7 Gloria

Postby theevilone6620 on Sat Sep 12, 2009 2:03 pm

I am using a Motorola SurfBoard DB5120 cable modem. Therefore I dont know if what you are talking about is possible since its not a ADSL modem????

Anyways I dont think the issue is the modem as the issue is only present in Mint and not Windows. If it was the modem it should effect Windows also.

ANyways, I am pretty much stumped as to what to do next so I need some guidance.
Check out my blog at http://mintguru.blogspot.com/If anyone would like to contribute to the project send me a message..
Follow me on Twitter http://twitter.com/LinuxDruid
User avatar
theevilone6620
Level 4
Level 4
 
Posts: 212
Joined: Sun Jul 12, 2009 8:40 am

Re: Slow Internet Coonection in Mint 7 Gloria

Postby phil on Sat Sep 12, 2009 4:22 pm

A little more information. I installed darkstat and got it going. It indicates that during the stalled period a new request for DNS is sent out containing 384 bytes every second until a DNS response is received, indefinitely. There seems to be a rollover of the nameservers listed. This is what seems to tie up the modem so a ping to the gateway cannot be sent.. I think it indicates that lack of DNS contact is the cause. I tried using Bind9 to see if that helped and do not find that it does, but a faster timeout does seem to help to eventurally find a nameserver. Here is my resolve.conf

nameserver 200.32.248.1 (Local telco dns)
nameserver 127.0.0.0 (This is local host bind9)
nameserver 200.32.218.132 (Local telco dns)
nameserver 208.67.222.222 (Open DNS)
options timeout:1 (Added to replace the default 5 second timeout from Linux)

Why is performance not the same as with Windows?? I use the same nameservers but not Bind9. I don't know how to set the timeout in Windows. But Windows works fine the way it comes and my original install disk is dated 2001. Crazy!!

I am convinced that with the experts available on this forum a solution will be found. Thanks for your help.
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: Slow Internet Coonection in Mint 7 Gloria

Postby ibm450 on Mon Sep 14, 2009 9:32 am

Image
Asus UL50VT laptop ~ LM10 - Unity 12.04 - Win 7
Image
User avatar
ibm450
Level 5
Level 5
 
Posts: 604
Joined: Sun Jan 11, 2009 6:56 am
Location: Kwinana, Western Australia

Re: Slow Internet Coonection in Mint 7 Gloria

Postby phil on Tue Sep 15, 2009 9:31 am

Thanks ibm450, you got me to thinking and doing a little exploring. I found that the repositories have just what is need to improve caching. It is dnsmasq. I installed it and what do you know? My dns lookup time was cut by more than 50% on average. It is a bit tricky to install, but not difficult. if you are familiar with doing things on the command line. My web access for Linux is approximately the same as with Windows now. See man dnsmasq. It works, but time will tell if there are gotchas.

Thanks again for your help.
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: Slow Internet Coonection in Mint 7 Gloria

Postby theevilone6620 on Tue Sep 15, 2009 3:54 pm

Phil,
Im thinking of installing this dnsmasq you said has boosted your speeds as mine are suffering really badly as yours were. You say that installation is quite tricky so I was wondering if you could give me a run down of exactly what installing and setting this app up entails. That way i know what I am getting myself into. I dont want to attempt this if i am going to end up really screwing up my setup and end up with no access to the net.

Thanks in advance

EDIT

However I just read this on the DNSMASQ site so I think i may have no need to install it as it is already a part of my router firmware.

Supported platforms include Linux (with glibc and uclibc), *BSD, Solaris and Mac OS X. Dnsmasq is included in at least the following Linux distributions: Gentoo, Debian, Slackware, Suse, Fedora, Smoothwall, IP-Cop, floppyfw, Firebox, LEAF, Freesco, fli4l, CoyoteLinux, Endian Firewall and Clarkconnect. It is also available as FreeBSD, OpenBSD and NetBSD ports and is used in Linksys wireless routers (dd-wrt, openwrt and the stock firmware) and the m0n0wall project.


I have a Linksys router so it is already installed in the firmware. What do you think? Do you think I would still benefit from it?
Check out my blog at http://mintguru.blogspot.com/If anyone would like to contribute to the project send me a message..
Follow me on Twitter http://twitter.com/LinuxDruid
User avatar
theevilone6620
Level 4
Level 4
 
Posts: 212
Joined: Sun Jul 12, 2009 8:40 am

Re: Slow Internet Coonection in Mint 7 Gloria

Postby igorzwx on Tue Sep 15, 2009 4:03 pm

As I remember, somebody noticed on Ubuntu forums that
the master bug (pulseaudio) can slowdown internet connection.
PulseAudio is a network server and a sound server.
Last edited by igorzwx on Wed Oct 07, 2009 9:16 pm, edited 1 time in total.
igorzwx
Level 5
Level 5
 
Posts: 599
Joined: Sat Sep 05, 2009 3:13 pm

Re: Slow Internet Coonection in Mint 7 Gloria

Postby phil on Wed Sep 16, 2009 9:56 am

I am not sure what to think about the router situation. I thought it could be used with a router like ipcop to advantage on a private network.

Here is an article about installing dnsmasq, a little dated but it got me started.

Local DNS Cache for Faster Browsing August 2, 2006
Posted by Carthik in administration, guides, packages, ubuntu. trackback
A DNS server resolves domain names into IP addresses. So when you request “google.com” for example, the DNS server finds out the address for the domain, and sends your request the right way.
You can run a DNS cache on your computer. This will speed up the process of looking up domain names when browsing. The difference is about 30-60 ms for me. Multiply that difference by the number of websites you visit a day for an approximate estimate of the speed improvement. Of course, all this would be worth it if it weren’t for the fact that setting this up is way too easy.
The following instructions are for someone with a cable (broadband) internet connection, where the computer gets it’s local IP address using DHCP from the router in your house/office:
The package we will be using for caching nameserver lookups is called dnsmasq. So first, install it using:
$sudo apt-get install dnsmasq
(If you can’t find then, then you probably haven’t added the Universe repository to your list of repositories.)
No uncomment the following line (that is edit the line to NOT have a “#” in the beginning) in the file /etc/dnsmasq.conf:
listen-address=127.0.0.1
Now edit /etc/dhcp3/dhclient.conf and make sure the section below exactly like this, especially the line that says “prepend domain-name-servers 127.0.0.1;”

#supersede domain-name "fugue.com home.vix.com";
prepend domain-name-servers 127.0.0.1;
request subnet-mask, broadcast-address, time-offset, routers,
domain-name, domain-name-servers, host-name,
netbios-name-servers, netbios-scope;
Explanation for the above change: In the normal case, when you get a new dhcp lease, the dhcp3 client (tool) on your computer gets a new lease, and updates the /etc/resolv.conf file on your computer with the right values for the DNS servers to use (usually some machine in the network of your hosting provider). Adding the “prepend” option as we did above ensures that “127.0.0.1″ will appear on the top of the list of DNS servers. That magic number refers to your own computer. So in the future, whenever your computer needs to resolve a domain name, it will forward that request to dnsmasq (which is running at 127.0.0.1 – your computer). If the details for the domain name are already in you cache, well and good, dnsmasq will serve it up and make the process real fast. If it is not in the cache, then dnsmasq will look at the /etc/resolv.conf file and use the nameservers listed below the “127.0.0.1″. I hope that explains things.
Now open the file /etc/resolv.conf in your text editor. It probably looks like:

search yourisp.com
nameserver 217.54.170.023
nameserver 217.54.170.024
nameserver 217.54.170.026
The 127.0.0.1 is missing right now since you haven’t renewed your lease after you edited the /etc/dhcp3/dhclient.conf file. So, let us add that in manually this one time. After you do, your /etc/resolv.conf file will look like the following:

search yourisp.com
nameserver 127.0.0.1
nameserver 217.54.170.023
nameserver 217.54.170.024
nameserver 217.54.170.026

Don’t worry if the numbers are different – if they are not, then hey – we must be neighbours
Okay. We are almost done here. All we have to do now is to restart dnsmasq so that the changes we made to the configuration file take effect. You can do that using the command:
$sudo /etc/init.d/dnsmasq restart.
Now you are running a local DNS cache. If you want to measure your speed improvement, type the command:
$dig google.com
You will see something like “;; Query time: 38 msec” there.
Now type the command again, and you should see something like:”;; Query time: 2 msec”
See, the first time, since google.com’s details were not in your cache (you are using it for the first time), the query took 38 ms. The second time, the cache speeds up the lookup. I have been using this for over a month now, and haven’t had a problem.
The following is ONLY for dsl customers
Note: If you have a dsl connection, the following may work:
Basically, the differences are in how the “conf” files are edited and used.
Copy the /etc/resolv.conf file to /etc/resolv.dnsmasq.conf
Then, edit the /etc/dnsmasq.conf file as follows:

# Change this line if you want dns to get its upstream servers from
# somewhere other that /etc/resolv.conf
resolv-file=/etc/resolv.dnsmasq.conf
You also have to uncomment the line that says listen-address=127.0.0.1
Now, edit /etc/resolv.conf to have ONLY the following line in it:
nameserver 127.0.0.1
Next, edit /etc/ppp/peers/dsl-provider and change the line:
usepeerdns to
#usepeerdns
(that is, comment out that line)
The ppp client does not allow you to prepend the 127.0.0.1 entry to your /etc/resolv.conf file. So what we did in the above was to create a copy of your previous resolv.conf for dnsmasq to use for lookups, update the file to use a local cache, and then prevent the ppp client from overwriting the resolv.conf file the next time. Now you can restart the dnsmasq service as I explained above, and start enjoying faster name resolution.
I don’t have a dsl connection, and so all the above is to the best of my knowledge.
To those of you still on dial-up – THANK YOU for visiting my blog! (I’m too ignorant to know how to change things to get dnsmasq to work on dial-up )
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Sun Sep 27, 2009 11:57 am

Those of you that have more than one computer - can you see what speed you get from one computer to another - you could try copying an ISO or something
As I stated above you have to see this as a two step thing - first from your computer to the router and then from the router out on the internet
If we can find out the LAN speed and compare that to the speed to the internet we have found something to build on
I have about 850 kB/s in Mint on a 1000 kB/s ADSL connection - can't complain and I used to have about the same speed in XP and it seems to be about the same in Vista
Can't check LAN speed right now - Ive done something to my network configuration so sharing does not work, have to fix that first
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby theevilone6620 on Sun Sep 27, 2009 3:02 pm

Ok so I am kind of confused here, shouldnt the name servers be different based upon were you live and what ISP you have? The article that is posted in a post has instructions to change the /etc/resolve.conf file with a set of nameserver addresses. I dont see how this would help if they are not the ones that my ISP uses, in fact wouldnt this just break my connection to the net altogether?

Here is what my /etc/resolv.conf file looks like right now.

# Generated by NetworkManager
domain hsd1.mi.comcast.net.
search hsd1.mi.comcast.net.
nameserver 68.87.77.134
nameserver 68.87.72.134

I still cant figure out what has to be done to fix this speed issue. As ive said it only happens in Linux, Windows is way faster, in fact I booted into Windows the other night just to check it again for the first time in a while and still get around 12 to 14Mbps and Im still only getting around 4Mbps in Linux ...

Also take a look at this:

; <<>> DiG 9.5.1-P2 <<>> google.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 23928
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;google.com. IN A

;; ANSWER SECTION:
google.com. 36 IN A 74.125.45.100
google.com. 36 IN A 74.125.67.100
google.com. 36 IN A 74.125.127.100

;; Query time: 1105 msec <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< See how long its taking?!?!?!
;; SERVER: 68.87.77.134#53(68.87.77.134)
;; WHEN: Sun Sep 27 15:14:11 2009
;; MSG SIZE rcvd: 76
Check out my blog at http://mintguru.blogspot.com/If anyone would like to contribute to the project send me a message..
Follow me on Twitter http://twitter.com/LinuxDruid
User avatar
theevilone6620
Level 4
Level 4
 
Posts: 212
Joined: Sun Jul 12, 2009 8:40 am

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Mon Sep 28, 2009 6:27 am

I just made a reset of my ADSL modem/router and my connection is even better - response time is lower
Consumer modems and routers tend to get more or less filled with "crap" over time and a reset flushes that out
I wonder if there is something that fills the router in certain combination of hard- and software
And this is on my list of things to look at
A response time of a second as above is absurd, but I don't have a solution for it now
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby phil on Mon Sep 28, 2009 10:07 am

Yes, three violins, over a second is absurd. I also notice that the ttl in your dig is only 36 seconds. Could the problem be that the internet is bogged down at times by DNS lookups due to very short ttl offered by the DNS servers? Right now I am trying to find out how to set my own ttl to at least 24 hours. That way none of my DNS lookups would expire from day to day. I have experimented with putting some addresses into the /etc/hosts. It is quite helpful but I take the chance that a web address changes.

I also found out that Windows does have an internal caching system. There is even a command option in ipconfig to look at the cache.

We have a special case in Belize in that we only have one ISP and all internet traffic has to be routed through one undersea cable (Arcos, in case you are interested) and it has less bandwidth than a lot of you on this forum are used to.

Oh yes, and my modem gets reset very often because power goes off about three times each day due to inadequate power generation and weather.
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Mon Sep 28, 2009 6:50 pm

and my modem gets reset very often because power goes off about three times each day

That does not reset the modem - most modems have a little hole where you can push something like a paper clip until it clicks
Some wants power on some power off
After that everything is "factory reset" including user name and password
I know you would not expect anything like routing tables and the like to reside there, but it seems some modems/routers transfers such to a non volatile part of memory and it gets flushed first with such a reset
(you can search for consumer routers and the user name scorp123 for a better explanation)
When you turn the modem off it also looses more or less unwanted items :)
I think we are onto something here - the only thing that I find irritating with internet on Linux is that there are a lot of DNS look ups - I've changed a setting in the modem to make it only use the DNS servers I specify - seems to work slightly better but used it too short time to be sure
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby theevilone6620 on Tue Sep 29, 2009 2:04 am

I dont really understand still as no one has answered my question about the nameserver addresses. Do they have to be the ones specifc to your ISP?

The reason I ask is because I have read in several places, were people are trying to help and solve this issue and they provide addresses for soemone to fill in their settings. Is it possible to use any DNS addresses when changing these settings or do they have to be the ones that are specific to your ISP??

Also, can someone explain to me how changing them would in fact speed up your connection?

Like I said in a previous post, in regards to that dnsmaq app, It is already a part of my routers firmware or somthing.

I also stumbled upon this and this dude apparantly is having similar problems on Debian.

[quoteA friend of mine advised me to take a look at /etc/dhclient.conf (as well as man dhclient.conf). I don't know whether this is a Debian-specific file, but at any rate I managed to overwrite the nameserver IPs in /etc/resolv.conf by adding the following statement to /etc/dhclient.conf:

supersede domain-name-servers 195.186.4.108; # nameserver IP of my ISP

As long as I only surf at home this actually solves my problem perfectly. But these settings have the disatvantage that nameserver IPs are always overwritten no matter where I surf, i.e. also at school where I've always gotten the correct nameserver IPs right away. These are now overwritten automaticly by the IP of my own ISP, which is again somewhat of a nuisance...

@ Nerderello: So the idea is that I put a script in ip-up.d that checks the current nameserver settings in /etc/resolv.conf and replaces them if necessary, am I right? I'll try. By the way I don't have a /etc/sysconfig on Debian Sid.
knockey is offline Reply With Quote][/quote]

So is it safe to say that the problem is stemming from the name server lookup times? Or is that only part of the problem? Honestly there has to be some way to fix this issue, I am still hesitant to try and install the dnsmaq as Ive read it has tanked some peoples connections so that they couldnt connect afterwards. What about another app called, "PDNSD". You can check it out here http://freshmeat.net/projects/pdnsd/.

Is that basically the same thing as the dnsmasq application? I really have hardly any knowledge of networking, and internet access issues, I actually just downloaded a few ebooks that deal with the subject intensively, they are college level books as well as preperation texts for certifications.

Anyways, who is the networking expert supposed to be around here anyways? I need to figure this out quick as Im getting real sick and tired of dealing with it. I actually heard that Fedora does not suffer from this issue at all, however Ive never been able to get my Wifi working on Fedora at all, but then again I havent tried very hard either. It may just be time to switch distros if this issue isnt solved in Mint 8 at least.

Does anyone know if using that distro that is focused on networking utilities would help to diagnose this issue? I forget the name of it but I know there is a distro that has a lot of tools for examining networking, packets and all that mess. Maybe that could provide the answer we are seeking. However, I did just read tonight that someone wasnt getting this issue when he went to school with his laptop and got on their wifi connection which would mean it was specific to his router. I have yet to take my laptop to school with me and I think Ill try that on wednesday and see what happens.
Check out my blog at http://mintguru.blogspot.com/If anyone would like to contribute to the project send me a message..
Follow me on Twitter http://twitter.com/LinuxDruid
User avatar
theevilone6620
Level 4
Level 4
 
Posts: 212
Joined: Sun Jul 12, 2009 8:40 am

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Tue Sep 29, 2009 5:25 am

pnsd seems top be something that addresses the same problem as dnsmasq - you find it in the repositories
In theory you can use any nameserver but the best is to always use that of your ISP
To solve the problem that /etc/resolv.conf is overwritten see this part of a wiki
Forget that it is talking about Envy - it was written when Bianca was the latest version (or possibly Cassandra)
The way this speeds thing up is that it (hopefully) makes it faster to get name resolution thus speeding things up
At worst there are look ups during a download slowing it down, this depends on both the computer and the router and the modem
If Windows has a built in DNS cache and Linux not this can explain that Linux is slow in some cases, depending on all the equipment involved
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], RobertLM78, somewhere and 23 guests