Slow Internet Coonection in Mint 7 Gloria

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Re: Slow Internet Coonection in Mint 7 Gloria

Postby phil on Tue Sep 29, 2009 10:14 am

From Microsoft

To disable the DNS cache permanently in Windows, use the Service Controller tool or the Services tool to set the DNS Client service startup type to Disabled. Note that the name of the Windows DNS Client service may also appear as "Dnscache."

Note The overall performance of the client computer decreases and the network traffic for DNS queries increases if the DNS resolver cache is deactivated.

The DNS Client service optimizes the performance of DNS name resolution by storing previously resolved names in memory. If the DNS Client service is turned off, the computer can still resolve DNS names by using the network's DNS servers.

When the Windows resolver receives a positive or negative response to a query, it adds that positive or negative response to its cache, and as a result, creates a DNS resource record. The resolver always checks the cache before querying any DNS server. If a DNS resource record is in the cache, the resolver uses the record from the cache instead of querying a server. This behavior expedites queries and decreases network traffic for DNS queries.

You can use the Ipconfig tool to view and to flush the DNS resolver cache. To view the DNS resolver cache, type ipconfig /displaydns at a command prompt. Ipconfig displays the contents of the DNS resolver cache, including the DNS resource records that are preloaded from the Hosts file and any recently queried names that were resolved by the system. After a certain time period, the resolver discards the record from the cache. The time period is specified in the Time to Live (TTL) associated with the DNS resource record. You can also flush the cache manually. After you flush the cache, the computer must query DNS servers again for any DNS resource records previously resolved by the computer. To delete the entries in the DNS resolver cache, type ipconfig /flushdns at a command prompt.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNSCache\Parameters
The TTL for positive responses is the lesser of the following values:

* The number of seconds specified in the query response the resolver received
* The value of the MaxCacheTtl registry setting.


Notes

* The default TTL for positive responses is 86,400 seconds (1 day).
* The TTL for negative responses is the number of seconds specified in the MaxNegativeCacheTtl registry setting.
* The default TTL for negative responses is 900 seconds (15 minutes).

If you do not want negative responses to be cached, set the MaxNegativeCacheTtl registry setting to 0.

To set the caching time on a client computer:

1. Start Registry Editor (Regedit.exe).
2. Locate and then click the following key in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters
3. On the Edit menu, point to New , click DWORD Value, and then add the following registry values:
Value name: MaxCacheTtl
Data type: REG_DWORD
Default value: 86400 seconds
Value data: If you lower the Maximum TTL value in the client's DNS cache to 1 second, this gives the appearance that the client-side DNS cache has been disabled.

Value name: MaxNegativeCacheTtl
Data type: REG_DWORD
Default: 900 seconds
Value data: Set the value to 0 if you do not want negative responses to be cached.
4. Type the value that you want to use, and then click OK.
5. Quit Registry Editor.

Mty note:

I am trying to dupllicate the above in Mint.

phil
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Linux Mint is funded by ads and donations.
 

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Tue Sep 29, 2009 4:46 pm

pdnsd is a hit!
I think it is what you are looking for Phil
It caches name resolution and to the hard drive when you shut down the computer
You find it in the repos
Code: Select all
apt install pdnsd

It also installs an application called resolvconf which finds DNS servers to use
After it's installed (with resolvconf) you don't do anything with it but you make two small edits in /etc so you might as well open /etc as root in Nautilus (be careful)
Add pdnsd to /etc/rc.local (before exit 0) this will start pdnsd at boot
Edit /etc/dhcp3/dhclient.conf
Uncomment the line
prepend domain-name-servers 127.0.0.1;
Reboot
Done
/etc/resolv.conf will now be changed so that the only uncommented content is nameserver 127.0.0.1
pdnsd works through 127.0.0.1
The response times are very low now (after the first visit to a site of course - it has to be cached first)
Pages begin to load instantly!
I have not noticed any faster download in the very small and unscientific test I made
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby phil on Tue Sep 29, 2009 7:43 pm

Thank you Husse.

I do not know how I missed it . I searched the repositories but did not find it. I have installed it and it is working but I have not fiddled with the timings yet, but it looks like it is the answer. Now a simple gui setup tool would be helpful for people who are uncomfortable with the command line interface, or maybe Mint could install it for a typical user much in line with the settings for Windows which people are used to.

phil
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: Slow Internet Coonection in Mint 7 Gloria

Postby DrHu on Tue Sep 29, 2009 8:00 pm

Husse wrote:I just made a reset of my ADSL modem/router and my connection is even better - response time is lower

That might be right, if the router is keeping some historical cache for its connections

However with a live Internet connection, flushing the client should be good enough
    sudo dhclient -r
    --release dhcp
    sudo dhclient
    --reconnect/renew dhcp
man dhclient..leases data
http://linux.die.net/man/8/dhclient

And dns (host) caching services..Linux
http://www.cyberciti.biz/faq/rhel-debia ... dns-cache/
http://linux.die.net/man/8/nscd
--might not be that great as a dns cache, but for Samba (disconnected sessions; the default share method in Mint) it could be useful.
User avatar
DrHu
Level 16
Level 16
 
Posts: 6624
Joined: Wed Jun 17, 2009 8:20 pm

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Tue Oct 06, 2009 5:18 am

This is a topic I will come back to - I have some ideas (and a mean keyboard - the spacebar does often not work and caps lock works to much :)) that I want to explore
Sadly the growth of Mint - which is wonderful - leaves me with so many topics to answer that I'm lagging behind
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby theevilone6620 on Wed Oct 07, 2009 3:23 pm

Well I actualy went ahead and installed the dnsmasq to my system and it did speed up my connection somewhat but still no where near as fast as Windows runs. ANyways, I just read the post Husse made about the pdns app, what is the difference between this and the dnsmasq app?

From what I read they do the same thing, but I see now that you are recommending it. Is there a big difference in what it does in comparion to dnsmasq? I had to manually edit some files when installing dnsmasq in order to get it to do its job and it did speed up my connection times somewhat, only after going to a page the first time though just like you said with the pdns app.

So can i expect a big diff if i switch to pdns and should i remove the dnsmasq app prior to installing pdns?

Thanks alot for working with us on this one Husse
Check out my blog at http://mintguru.blogspot.com/If anyone would like to contribute to the project send me a message..
Follow me on Twitter http://twitter.com/LinuxDruid
User avatar
theevilone6620
Level 4
Level 4
 
Posts: 212
Joined: Sun Jul 12, 2009 8:40 am

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Wed Oct 07, 2009 6:37 pm

No big difference between dnsmasq and pdns I think but pdns is dead easy to install and configure (no configuring :shock: )
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby uncannybuzzard on Sat Oct 10, 2009 8:04 pm

forgive me if i've missed this in the past pages, what do you get for the output of 'sudo mii-tool' ?
uncannybuzzard
Level 1
Level 1
 
Posts: 3
Joined: Sat Oct 10, 2009 8:03 pm

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Sun Oct 11, 2009 5:02 am

Welcome to Mint uncannybuzzard
There's a big chance you get
no MII interfaces found

But thanks for pointing it out
All in this topic please test sudo mii-tool and read the man page (here)
If you find a MII interface you might be able to force a higher speed
However as I read this it seems to work on LAN but not WAN
Please test the speed you get on your LAN and see if that is significantly better than on the internet
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby phil on Sun Oct 11, 2009 3:45 pm

The more I study slow dns lookup the more confused I get. I have dnsmasq and pdnsd running at the same time and they seem to get along together. The only way I have found to get the result that I really want, however, is to list ip numbers of the web sites that seem to be the most problem in the /etc/hosts file. I realize that by doing this I am vulnerable to a change in the ip number. This has not happened so far after several days, and I am sure does not happen very often.

One of the addresses that is a very slow look up frequently is linuxmint.com so I experiment with that.

What I want to see and cannot seem to configure with bind9, dnsmasq or pdnsd is the following:

1. All addresses accessed today should be saved for tomorrow with the time to live from yesterday saved and continued tomorrow. I do not leave my computers on when I am not using them, for a number of reasons. I am using SSD for both Linux and Windows, with data being saved on a conventional internal drive (soon to be replaced with SSD) and then periodically being saved to external conventional spinning drives.
2. Time to live to be adjustable, at my option.
3. If an address saved does not load in my browser or mail server, delete the saved address and get a new lookup.

I have also studied my DSL service. There are many serious slow downs and even some periods of lack of service even though my telephone always works. There are long periods of no access to root DNS servers. I assume from congestion.

I have been experimenting with Arch Linux (no danger of changing from Mint) and set it up to use ftp for getting my downloads from their servers. When a down load is in progress from Arch another computer connected to my modem/router either loses or almost loses connection to the internet. I have not had that problem with http and two computers updating at the same time for with Mint.

It is wonderful to live in the tropics in a third world country except for internet service and a few other minor inconveniences.
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Sun Oct 11, 2009 6:13 pm

Hi Phil
I'm thinking along the same lines, but the shear number of questions makes that I can't spend as much time with this as I wish
(And my wife's laptop had a hardware breakdown so now I have hours on end to install and configure the new one - with Vista, can't convince her to change)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby uncannybuzzard on Sun Oct 11, 2009 10:38 pm

Husse wrote:Welcome to Mint uncannybuzzard
There's a big chance you get
no MII interfaces found

But thanks for pointing it out
All in this topic please test sudo mii-tool and read the man page (here)
If you find a MII interface you might be able to force a higher speed
However as I read this it seems to work on LAN but not WAN
Please test the speed you get on your LAN and see if that is significantly better than on the internet


thanks. i've been using mint for a very long time now, but i stick to the ubuntu forums mainly, if any forums at all, since most of what is there applies to mint.

after fighting epic battles with speed issues in freebsd, i found out that MDIX auto-negotiation is a princess and often works incorrectly. true, it does not work on WLAN devices, but for any copper connection, it must be checked. i recently rebuilt my xbmc htpc on mint 7 and it had this problem. it's not usually the speed that negotiates wrong. if there's a problem, it's most likely connecting at half duplex instead of full.
as a side bar, just for the curious, duplex has to do with how the interface communicates. half-duplex is like a walkie talkie, where one person can talk at a time. full-duplex is like a telephone.

edit: there is a something similar for WLAN interfaces, insomuch as you can specify how they connect. in freebsd it's done with ifconfig. i'm not sure how to do it in linux, but i suspect iwconfig would be worth looking into.
uncannybuzzard
Level 1
Level 1
 
Posts: 3
Joined: Sat Oct 10, 2009 8:03 pm

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Mon Oct 12, 2009 5:46 am

I'll use this as a master topic
Other topics with similar problems
viewtopic.php?f=53&t=33299
viewtopic.php?f=53&t=33797
and about half a dozen others I have to find and add here
viewtopic.php?f=53&t=34123
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby phil on Mon Oct 12, 2009 10:33 am

Hi Husse,

Sorry to hear about your wife's computer. My wife is a convert to Linux, but she has been using Linux for about 6 years.

I have ordered another modem, a newer Zoom ADSL5 from Amazon so I can experiment with its setup and still be sure I can get back on the net in case of a goof-up. It should be here in a few more days. Although I do not think the modem is involved in the slow lookups since Windows seems to work fine all of the time there may some kind of interaction with Linux that causes the problem. The thing that really bugs me is that my version of Windows XP pro (fully updated) was originally produced in 2001. It was part of the software we had for the wireless ISP service that I managed in 2004. We had a radio link from Chetumal, Mexico to Corozal, Belize with about 200 customers in Chetumal and the Corozal area. We never identified a DNS look up problem at that time but I was personally using Mandrake with SSL along with our chief technical man to manage the network and to do my other work and personal correspondence. I have talked to him about our present problems and he thinks it might be related to the the present ADSL service provider who does blocking of VOIP or anything that resembles telephone communication. Recently the company was taken over by the government as a result of a feud between the principal stockholder and the government.

phil
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Sun Oct 18, 2009 6:18 am

This topic clearly demonstrates that it has something to do with DHCP
This is in the back of my head all the time, but sadly I still can't figure out a solution
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby ibm450 on Fri Oct 23, 2009 9:02 pm

phil wrote:I am not sure what to think about the router situation. I thought it could be used with a router like ipcop to advantage on a private network.

Here is an article about installing dnsmasq, a little dated but it got me started.

Local DNS Cache for Faster Browsing August 2, 2006
Posted by Carthik in administration, guides, packages, ubuntu. trackback
A DNS server resolves domain names into IP addresses. So when you request “google.com” for example, the DNS server finds out the address for the domain, and sends your request the right way.
You can run a DNS cache on your computer. This will speed up the process of looking up domain names when browsing. The difference is about 30-60 ms for me. Multiply that difference by the number of websites you visit a day for an approximate estimate of the speed improvement. Of course, all this would be worth it if it weren’t for the fact that setting this up is way too easy.
The following instructions are for someone with a cable (broadband) internet connection, where the computer gets it’s local IP address using DHCP from the router in your house/office:
The package we will be using for caching nameserver lookups is called dnsmasq. So first, install it using:
$sudo apt-get install dnsmasq
(If you can’t find then, then you probably haven’t added the Universe repository to your list of repositories.)
No uncomment the following line (that is edit the line to NOT have a “#” in the beginning) in the file /etc/dnsmasq.conf:
listen-address=127.0.0.1
Now edit /etc/dhcp3/dhclient.conf and make sure the section below exactly like this, especially the line that says “prepend domain-name-servers 127.0.0.1;”

#supersede domain-name "fugue.com home.vix.com";
prepend domain-name-servers 127.0.0.1;
request subnet-mask, broadcast-address, time-offset, routers,
domain-name, domain-name-servers, host-name,
netbios-name-servers, netbios-scope;
Explanation for the above change: In the normal case, when you get a new dhcp lease, the dhcp3 client (tool) on your computer gets a new lease, and updates the /etc/resolv.conf file on your computer with the right values for the DNS servers to use (usually some machine in the network of your hosting provider). Adding the “prepend” option as we did above ensures that “127.0.0.1″ will appear on the top of the list of DNS servers. That magic number refers to your own computer. So in the future, whenever your computer needs to resolve a domain name, it will forward that request to dnsmasq (which is running at 127.0.0.1 – your computer). If the details for the domain name are already in you cache, well and good, dnsmasq will serve it up and make the process real fast. If it is not in the cache, then dnsmasq will look at the /etc/resolv.conf file and use the nameservers listed below the “127.0.0.1″. I hope that explains things.
Now open the file /etc/resolv.conf in your text editor. It probably looks like:

search yourisp.com
nameserver 217.54.170.023
nameserver 217.54.170.024
nameserver 217.54.170.026
The 127.0.0.1 is missing right now since you haven’t renewed your lease after you edited the /etc/dhcp3/dhclient.conf file. So, let us add that in manually this one time. After you do, your /etc/resolv.conf file will look like the following:

search yourisp.com
nameserver 127.0.0.1
nameserver 217.54.170.023
nameserver 217.54.170.024
nameserver 217.54.170.026

Don’t worry if the numbers are different – if they are not, then hey – we must be neighbours
Okay. We are almost done here. All we have to do now is to restart dnsmasq so that the changes we made to the configuration file take effect. You can do that using the command:
$sudo /etc/init.d/dnsmasq restart.
Now you are running a local DNS cache. If you want to measure your speed improvement, type the command:
$dig google.com
You will see something like “;; Query time: 38 msec” there.
Now type the command again, and you should see something like:”;; Query time: 2 msec”
See, the first time, since google.com’s details were not in your cache (you are using it for the first time), the query took 38 ms. The second time, the cache speeds up the lookup. I have been using this for over a month now, and haven’t had a problem.
The following is ONLY for dsl customers
Note: If you have a dsl connection, the following may work:
Basically, the differences are in how the “conf” files are edited and used.
Copy the /etc/resolv.conf file to /etc/resolv.dnsmasq.conf
Then, edit the /etc/dnsmasq.conf file as follows:

# Change this line if you want dns to get its upstream servers from
# somewhere other that /etc/resolv.conf
resolv-file=/etc/resolv.dnsmasq.conf
You also have to uncomment the line that says listen-address=127.0.0.1
Now, edit /etc/resolv.conf to have ONLY the following line in it:
nameserver 127.0.0.1
Next, edit /etc/ppp/peers/dsl-provider and change the line:
usepeerdns to
#usepeerdns
(that is, comment out that line)
The ppp client does not allow you to prepend the 127.0.0.1 entry to your /etc/resolv.conf file. So what we did in the above was to create a copy of your previous resolv.conf for dnsmasq to use for lookups, update the file to use a local cache, and then prevent the ppp client from overwriting the resolv.conf file the next time. Now you can restart the dnsmasq service as I explained above, and start enjoying faster name resolution.
I don’t have a dsl connection, and so all the above is to the best of my knowledge.
To those of you still on dial-up – THANK YOU for visiting my blog! (I’m too ignorant to know how to change things to get dnsmasq to work on dial-up )



thank-you, this helped me alot and yes i can notice a speed difference with this method. is it possible to add this patch in LM8>?
Image
Asus UL50VT laptop ~ LM10 - Unity 12.04 - Win 7
Image
User avatar
ibm450
Level 5
Level 5
 
Posts: 604
Joined: Sun Jan 11, 2009 6:56 am
Location: Kwinana, Western Australia

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Sat Oct 24, 2009 6:47 am

I've proposed pdnsd (hope I got the letters right :)) to be included in Helena - does the same thing and is much easier to install and configure (none :))
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Wed Oct 28, 2009 7:27 am

As can be seen here there may also be something in your home folder that might play a role....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Slow Internet Coonection in Mint 7 Gloria

Postby phil on Thu Oct 29, 2009 6:49 pm

I got my new modem a Zoom ADSL X5, just a newer version of what I had before, installed today. It works fine, even works properly for DNS from ISP using DHCP while the old one did not. So far I cannot see any major change in DNS lookup. A few days of testing may uncover something.

I am pleased to see that Husse is recommending that pdnsd be a part of the next release. I hope it is installed by default, perhaps with some note that it can be disabled if it causes any problem. We know by now that Windows has an equivalent installed by default and that it seems to help a lot.

It still seems to be a problem if the TTL is too short if the internet speed slows or gets boged down with too many DNS requests so pdnsd should help.

Phil
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: Slow Internet Coonection in Mint 7 Gloria

Postby Husse on Fri Oct 30, 2009 8:40 am

I'm pleased to see that it's OK for you now phil
This shows it's a mix of hard- and software problems
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 
Previous

Return to Newbie Questions

Who is online

Users browsing this forum: bill_m, Bing [Bot], niowluka and 17 guests