Yet Another WiFi Question

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Yet Another WiFi Question

Postby blinux on Mon Jun 18, 2007 6:38 pm

Ok, I'm probably in the same boat as others, trying to bring Linux Mint into a XP / Vista environment and having WiFi problems. I'm actually trying to connect a desktop using a wireless PCI Card (D-Link DWA-542) to a Linksys Broadband Router (WRT54GS).

I happened to pick up the bootable CD for Linux Mint Lite 2.2 and installed it on a Dell Dimension. It is not running dual boot no XP or anything else.

I read the two common problem with WiFi thread but it didn't solve my problem.

I clicked on the Ndiswrapper driver installation tool and was able to install the D-Link driver from Windows installation CD and it came back with net5416 hardware present. I then went in and set the properties of wlan0 to the ESSID and password type and network password. While I know the ESSID is correct is the network password the key or the passphrase? I'm using WEP(64 bit).

When I run sudo /usr/lib/linuxmint/mintWifi/mintWify.py

It recognizes the installed drivers but iwconfig shows link quality 0 signal level 0 and then of course the DHCP on wlan0 fails to receive any offers.

I'd copy and paste the output and send it but of course at the moment the machine isn't talking to anyone.

Any help appreciated.
blinux
Level 1
Level 1
 
Posts: 5
Joined: Mon Jun 18, 2007 10:20 am

Linux Mint is funded by ads and donations.
 

Postby trianglman on Mon Jun 18, 2007 7:33 pm

If you are using WEP, there is no passphrase, just the key. You will also need to change the setting from Open Access to Shared Key (If I remember the options correctly).
trianglman
Level 1
Level 1
 
Posts: 5
Joined: Fri Jun 01, 2007 8:01 am

Postby Boo on Mon Jun 18, 2007 8:32 pm

Make sure you are using the right key.
you can have ASCII or HEX.
some routers generate a Hex key(or 4) from a pass phrase, but it is the Hex key you have to use.

I used to use a WEP 128bit Hex key. (now wpa2).

I thought the encryption/access thingy was Open.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby blinux on Mon Jun 18, 2007 9:03 pm

I've got it set to HEX and my router is set to shared key. I have an XP laptop that is connecting ok, using the same SSID and key value.

My router says "For Shared Key authentication, the sender and recipient use a WEP key for authentication."

I saw no where to set the open or shared key value in the Linux Mint wireless config or the channel.
blinux
Level 1
Level 1
 
Posts: 5
Joined: Mon Jun 18, 2007 10:20 am

Postby Boo on Mon Jun 18, 2007 10:38 pm

I think linux only uses the open wep authentication.

you could try changing your window to use open (and router).

I checked and i use to do this.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby blinux on Mon Jun 18, 2007 11:19 pm

Still no luck changed windows to use open and router to Auto.

Router state "The default is set to Auto, which allows either Open System or Shared Key authentication to be used. "

iwconfig comes back with

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate: 54 Mb/s
....

I didn't think it would be this tough, but thanks for the help.
blinux
Level 1
Level 1
 
Posts: 5
Joined: Mon Jun 18, 2007 10:20 am

Postby Boo on Mon Jun 18, 2007 11:56 pm

alright I have read your routers manual. (yes I'm a nerd)
term confusion between routers, or just me brain.

Use shared key. not auto.

If you are using the same WEP key on both ends I don't see why it is not working. unless the driver is a no go.

to be on the safe side (like me) change the essid from the default and dont broadcast it.
this will mean that you will have to enter it on the linux end and stops confusion if there are any other of the same wireless routers in the area.
Yes I have seen this type of confusion and even though the router to be used was closer the system would not connect.

hope this helps.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby blinux on Tue Jun 19, 2007 7:40 am

Ok, I've come full circle I'm back to shared key, the ssid was changed from the default when I installed the router ( 6 months ago). If you mean don't broadcast the ssid from the router, but then my laptop fell off the network and there was no change on the linux box. There are other networks in the area but their signal strength is very low compared to my local.

Maybe it is something with the driver. When I had XP on the machine it just connected after the install so I know at least it works on Windows! Perhaps I was premature clobbering my XP!
blinux
Level 1
Level 1
 
Posts: 5
Joined: Mon Jun 18, 2007 10:20 am

Postby blinux on Tue Jun 26, 2007 3:10 pm

Well, just to close the loop on this one. The good news is I am now using Bianca connected to the WiFi. The bad news is I don't have a good explanation for why it started working.

The only config change to the machine is removal of a USB connected hard drive. The settings that worked for Linksys WRT54GS router using a D-Link DWA-542 PCI card were pretty much out of the box. Mixed - support open and shared using WEP.

Oh well, I'm just glad it's working! Now should I risk upgrading to Casandra!!!!
blinux
Level 1
Level 1
 
Posts: 5
Joined: Mon Jun 18, 2007 10:20 am

Postby scorp123 on Tue Jun 26, 2007 3:27 pm

Boo wrote:I think linux only uses the open wep authentication.
Nope, I'm using WPA here ... :lol:
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby Boo on Tue Jun 26, 2007 6:47 pm

Im using WPA2. :lol: :lol:

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot], Tom885 and 28 guests