beryl missing min max icons (top bar)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

beryl missing min max icons (top bar)

Postby EvoCaliber on Thu Jun 21, 2007 1:30 pm

Yes, again it comes down to this.

My xorg:
Code: Select all
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon Feb 26 23:38:46 PST 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
    InputDevice    "Synaptics Touchpad"
EndSection

Section "Files"

   # path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "i2c"
    Load           "bitmap"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "vbe"
    Load           "dri"
    Load           "dbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier     "Synaptics Touchpad"
    Driver         "synaptics"
    Option         "SendCoreEvents" "true"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"      # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier     "Generic Monitor"
    HorizSync       28.0 - 96.0
    VertRefresh     43.0 - 60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "nVidia Corporation GeForce Go 7900 GTX"
    Driver         "nvidia"
    Option         "XAANoOffscreenPixmaps"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation GeForce Go 7900 GTX"
    Monitor        "Generic Monitor"
    DefaultDepth    16
    Option         "DisableGLXRootClipping" "True"
    Option         "XAANoOffscreenPixmaps"
    Option         "RenderAccel" "True"
    Option         "AllowGLXWithComposite" "True"
    Option         "backingstore" "True"
    Option         "TripleBuffer" "True"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Depth       1
        Modes      "1920x1200"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1920x1200"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1920x1200"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1920x1200"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1920x1200"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1920x1200"
    EndSubSection
EndSection

Section "DRI"
       Mode 0666
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection


Can somebody point out any mistakes, or if you need any more info. Have tried everything found on the forums here to no avail. Have it working on openSUSE, but want to test some distros to see what ill use in the end.
EvoCaliber
Level 1
Level 1
 
Posts: 3
Joined: Thu Jun 21, 2007 1:51 am

Linux Mint is funded by ads and donations.
 

Re: beryl missing min max icons (top bar)

Postby scorp123 on Thu Jun 21, 2007 2:00 pm

EvoCaliber wrote:Yes, again it comes down to this.
No it doesn't. You probably just selected a flaky windows decoration that doesn't work properly on your system. I bet if you tried a different window decoration the problem would go away. :wink:
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby EvoCaliber on Thu Jun 21, 2007 2:07 pm

Nope that didn't solve it either.
EvoCaliber
Level 1
Level 1
 
Posts: 3
Joined: Thu Jun 21, 2007 1:51 am

Postby scorp123 on Thu Jun 21, 2007 2:40 pm

EvoCaliber wrote:Nope that didn't solve it either.
Fact is that beryl is already working and that you have a window decorator ... And the 3D effects work too? This already excludes xorg.conf being the culprit. So the problem is most likely related to the window decorator. :wink:
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby EvoCaliber on Thu Jun 21, 2007 2:47 pm

yep, everything else works just fine. Have any recommendations?
EvoCaliber
Level 1
Level 1
 
Posts: 3
Joined: Thu Jun 21, 2007 1:51 am

Postby frank392 on Thu Jun 21, 2007 3:42 pm

The problem is here:
Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation GeForce Go 7900 GTX"
Monitor "Generic Monitor"
DefaultDepth 16
Option "DisableGLXRootClipping" "True"
Option "XAANoOffscreenPixmaps"
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "backingstore" "True"
Option "TripleBuffer" "True"
Option "AddARGBGLXVisuals" "True"

you have aded the 7 last lines in the wrong place.

they should go on the divice secction
and actually you only need to add this line:

Option "AddARGBGLXVisuals" "True"

here is my:
Section "Device"
Identifier "nVidia Corporation G71 [GeForce 7900 GS]"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"

hope that helps
frank392
Level 4
Level 4
 
Posts: 353
Joined: Wed Nov 22, 2006 1:29 pm

Postby scorp123 on Thu Jun 21, 2007 3:50 pm

frank392 wrote:you have aded the 7 last lines in the wrong place.
Hmmm ... I have to admit I didn't look at that. Might be a good idea to correct that.
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: avi_gunner, Bing [Bot], gary.zw, HarrisCreekCentral, KirbySmith and 24 guests