Duplicate Hard Drive Icons on Bootup

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Duplicate Hard Drive Icons on Bootup

Postby FrankStarr on Fri Jun 22, 2007 6:55 pm

I've Just updated Bianca to Cassandra. However, I noticed the same problem in Bianca.
Before update, on my desktop display, my hard drives by default were labeled:

117 GB FAT32 (LBA) volume hdb1 and

68 GB FAT32 (LBA) volume hda1.

When I tried to rename them by right clicking my mouse on the icon and rekeying the label, the old icons would reappear upon bootup, and I would have two sets for the two drives.

After upgrade, the first time I rebooted, the drives were labeled with the labels assigned by Windows, and I prefer these labels. Unfortunately, every subsequent reboot gives me duplicates with the old labels. Anything I can do besides just deleting the haunted clones?
FrankStarr
Level 1
Level 1
 
Posts: 7
Joined: Sat Apr 21, 2007 8:37 am

Linux Mint is funded by ads and donations.
 

Postby speaker219 on Sat Jun 23, 2007 12:58 am

Go in the mint menu, and in the search box, type "mintdesktop" and open it, in the settings, uncheck "mounted volumes". hit ok and close out. go back to the mint menu and search for "mintdisk" and open it. uncheck "show links for mounted partitions"
next time you restart your computer, you shouldn't have any icons =)
i'm new to linux, but i've already learned alot, so i'm glad to help with anything i can :mrgreen:

edit: ahh, i read that too fast. i don't know how to fix the label problem, sorry.
speaker219
Level 2
Level 2
 
Posts: 56
Joined: Tue Jun 19, 2007 4:54 pm

Nice Try, Speaker219

Postby FrankStarr on Sun Jun 24, 2007 8:42 am

Thanks for trying.
Looks like what I need, tho, is a way to figure where mintdesktop gets its labels for hard disk volumes, and see if there's a way to change the defaults.
FrankStarr
Level 1
Level 1
 
Posts: 7
Joined: Sat Apr 21, 2007 8:37 am

Postby Lolo Uila on Sun Jun 24, 2007 4:30 pm

Actually, the one you want to change is MintDisk.

Leave "Mounted Volumes" checked in MintDesktop, and UNcheck "Show links for mounted partitions" in MintDisk.

This Should leave you with just the Windows disk labels, and it will still auto-mount USB devices to the desktop.

(If you uncheck it in MinstDesktop you will have to manually mount hot-plugged USB drives...)

Also, make sure there are no references to your Windows formatted drives in fstab (even commented ones).
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], I2k4, petrapetra and 30 guests