Services oops.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Services oops.

Postby sourwire on Sun Jun 24, 2007 2:06 am

Ok, it will probaly sound really stupid, but I was turning off some services one sunny day that I though I didn't need. Once I turned one of them off, I can't configure my system anymore. Whenever I try to do something administatish, Linux says something like "You are not allowed to change system configuration."
I tried gksu services-admin from the terminal, same thing. Is there a way I can revert services back to default?

Thank you in advance, Nick Tsyukalo.
sourwire
 

Linux Mint is funded by ads and donations.
 

Re: Services oops.

Postby scorp123 on Sun Jun 24, 2007 5:02 am

sourwire wrote: "You are not allowed to change system configuration." I tried gksu services-admin from the terminal, same thing.
First, as Husse's signature says: "Don't break stuff if you can't fix it." :wink: Messing around with things that you don't understand is not very wise ... A lesson you now fully understand I guess.

Criticism apart, the error you get sounds more like an authentication issue. Did you mess around with the root account too? Does stuff like sudo su - give you a root shell? Besides, it would help if you could be more precise on what exactly you did to your system.

I don't know about others, but I for myself make notes on paper in a 'log book' before I do something potentially stupid (yes, I too do very stupid things sometimes!). On that paper I write down
    - the time and date
    - what I intend to do (e.g. disable "gdm")
    - why I intend to do it (e.g. "machine is a server, no GUI needed")
    - and how I did it (e.g. "removed relevant symlink from /etc/rc*.d sub-dirs")


If anything goes wrong I can easily revert my steps. You might wish to do this as well in the future? Even if you can't revert your steps yourself, you can then at least tell others what precisely you did and why you thought you had to do it. This helps a great deal to understand the causes of the problem.

Unprecise descriptions such as "I disabled some services and now my system don't work" doesn't really help to find a solution for you.
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

.

Postby sourwire on Sun Jun 24, 2007 1:45 pm

Well, the problem is that I can't remember which service that is.
I can still use sudo su. And I can also login to root from GDM.
I tried doing gsku services-admin while being root, but I get the same message: "you are not allowed to change system configuration."
I did not do anything to users. The only thing I changed in root was the password. I didn't change anything else. I started getting these errors right after I turned off that service. If only I remembered what it was...
Every time I login with normal user, I get a little window with this title "Internal Error". It says "failed to initialize HAL!"

This is what I get when I try gksu services-admin or services-admin
Code: Select all
Do something unusual today.  Pay a bill.
root@neekDellktop:~# gksu services-admin

(services-admin:4668): Liboobs-WARNING **: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
4668: arguments to dbus_connection_add_filter() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 4379.
This is normally a bug in some application using the D-Bus library.
4668: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 2873.
This is normally a bug in some application using the D-Bus library.

(services-admin:4668): Liboobs-CRITICAL **: run_message: assertion `oobs_session_get_connected (priv->session)' failed
4668: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 2873.
This is normally a bug in some application using the D-Bus library.


Hmm... Maybe I should reinstall. This install only lasted three days anyway.

I found out what HAL is on the Wikipedia http://en.wikipedia.org/wiki/HAL_%28software%29

HAL is a hardware abstraction layer and open-source software project that allows desktop applications on an operating system to readily access hardware information so that they can locate and use such hardware regardless of bus or device type. In this way a desktop GUI can present all resources to its user in a seamless and uniform manner.

For example HAL can gather information about removable storage devices and trigger their representation within the user's desktop environment.


Removable storage devices... my Windows partition now shows in two icons. One is "hda1" and the other one is "24GB Disk" This also happened when I turned off that service.
sourwire
 

Postby scorp123 on Sun Jun 24, 2007 3:49 pm

1. Why oh why did you turn off HAL ???

2. You gave root a password, so yes, you did mess around with this account, hence you are facing authentication issues now

3. When you are already root, there is no point in using "sudo" or "gksu": You already have God-like priviledges.

4. Never ever login to GUI as root!!! Too many scary things can happen.

5. You learned your lesson: Read Wikipedia *BEFORE* you mess around with your system.

Happy reinstalling then. :roll:
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

.

Postby sourwire on Sun Jun 24, 2007 4:21 pm

scorp123 wrote:
3. When you are already root, there is no point in using "sudo" or "gksu": You already have God-like priviledges.

4. Never ever login to GUI as root!!! Too many scary things can happen.


What scary things? I used it all the time, it's way easier than using the terminal.

Ok, I'm reinstalling then
sourwire
 

Re: .

Postby scorp123 on Sun Jun 24, 2007 5:17 pm

sourwire wrote:
scorp123 wrote: 4. Never ever login to GUI as root!!! Too many scary things can happen.
What scary things?


Never ever login into GUI as root!!
http://www.linuxmint.com/forum/viewtopic.php?p=7204#7204

Using stuff that temporarily will grant you root's God-like powers such as "sudo" or "gksu" is one thing, but you are never ever supposed to enable root and login into GDM and work as root all the time!!! :roll:
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

.

Postby sourwire on Mon Jun 25, 2007 1:42 am

All right, all right. I got the point. I won't enable it this time. :wink:
sourwire
 

Re: .

Postby scorp123 on Mon Jun 25, 2007 4:06 am

sourwire wrote:I won't enable it this time. :wink:
Well .. it was disabled for a good reason to start with and you shouldn't enable (or disable) stuff you know too little about :wink:
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: mintoreo, newyorkpaulie and 32 guests