OpenOffice Word doesn't have "times" font?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

OpenOffice Word doesn't have "times" font?

Postby Capricornxs on Tue Jun 26, 2007 11:19 am

I just noticed that in OpenOffice writer, the default font is set to "times" but when I go to format - character, under "times" it says the font is not installed and the closest font will be used instead. is this a known issue?

using: linuxmint 3.0 and openoffice writer 2.2

i have since installed windows "times new roman" font and set it as the default, but I'm still wondering why it didn't have "times" to begin with. Is it a copyright issue?
Thanks
Capricornxs
Level 1
Level 1
 
Posts: 11
Joined: Mon Jun 25, 2007 5:47 pm

Linux Mint is funded by ads and donations.
 

Postby scorp123 on Tue Jun 26, 2007 1:13 pm

Maybe it was a default set by the OpenOffice.org packagers? In any case: you can download Microsoft's core fonts package (with Arial, Courier and Times) plus you can use any other TrueType font you encounter (drag & drop into the "fonts:/" folder ... plus there is a menu item for this under System > Preferences > Fonts ... )
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby speaker219 on Tue Jun 26, 2007 1:53 pm

run:
Code: Select all
sudo apt-get install msttcorefonts

Then you will have the following fonts:
Andale Mono
Arial Black
Arial (Bold, Italic, Bold Italic)
Comic Sans MS (Bold)
Courier New (Bold, Italic, Bold Italic)
Georgia (Bold, Italic, Bold Italic)
Impact
Times New Roman (Bold, Italic, Bold Italic)
Trebuchet (Bold, Italic, Bold Italic)
Verdana (Bold, Italic, Bold Italic)
Webdings
speaker219
Level 2
Level 2
 
Posts: 56
Joined: Tue Jun 19, 2007 4:54 pm

Postby Capricornxs on Tue Jun 26, 2007 10:54 pm

speaker219 wrote:run:
Code: Select all
sudo apt-get install msttcorefonts

Then you will have the following fonts:
Andale Mono
Arial Black
Arial (Bold, Italic, Bold Italic)
Comic Sans MS (Bold)
Courier New (Bold, Italic, Bold Italic)
Georgia (Bold, Italic, Bold Italic)
Impact
Times New Roman (Bold, Italic, Bold Italic)
Trebuchet (Bold, Italic, Bold Italic)
Verdana (Bold, Italic, Bold Italic)
Webdings


neat!!! this worked great.

now another problem... due to my stupidity, I used the consol and removed a bunch of default fonts (like aakar) under font folder and now I'm regretting it. Is there anyway I can get them back? Reinstall? download them again? Please help! thanks!
Capricornxs
Level 1
Level 1
 
Posts: 11
Joined: Mon Jun 25, 2007 5:47 pm

Postby Ede on Wed Jun 27, 2007 12:31 am

Just for you, I'll upload the fonts to my server. :3
I just packed the whole folder, so they also include os-x fonts AND Microsoft core fonts.

They can all live happily together, so just use the font-settings to adjust your fonts instead of overwriting everything.

System -> Preferences -> Font

Or, in terminal;
Code: Select all
gnome-font-properties

This way, every user may use the fonts they like instead of beeing forced to use one set of fonts. :3

fonts.tar - 50.2 mB
User avatar
Ede
Level 4
Level 4
 
Posts: 294
Joined: Thu Jun 14, 2007 7:02 pm
Location: Norway

Postby speaker219 on Wed Jun 27, 2007 1:17 am

Ede wrote:Just for you, I'll upload the fonts to my server. :3
I just packed the whole folder, so they also include os-x fonts AND Microsoft core fonts.

They can all live happily together, so just use the font-settings to adjust your fonts instead of overwriting everything.

System -> Preferences -> Font

Or, in terminal;
Code: Select all
gnome-font-properties

This way, every user may use the fonts they like instead of beeing forced to use one set of fonts. :3

fonts.tar - 50.2 mB

:roll: Just by installing the Microsoft fonts doesn't force anyone to use them. They're there as fonts, it doesn't change any of your settings, it just allows the microsoft fonts to be chosen. In my Howto post, it *DOES* force you to use microsoft fonts, but that's only if you want to. By just running the sudo apt-get install msttcorefonts, it just adds the fonts, doesn't force you to do anything. :wink:

Also, how does the package end up being 52.2 MB? The msttcorefonts package is under 1MB and I just installed the OS-X fonts you posted in your howto post and alltogether, the fonts are only ~2 mb
speaker219
Level 2
Level 2
 
Posts: 56
Joined: Tue Jun 19, 2007 4:54 pm

Postby Ede on Wed Jun 27, 2007 8:56 am

Some confusion here. :P I thoght that he had removed every font he had. So I uploded EVERY font I had. All that's included in Cassandra + Os-X + MS.

>_>

Silly me.
User avatar
Ede
Level 4
Level 4
 
Posts: 294
Joined: Thu Jun 14, 2007 7:02 pm
Location: Norway

Postby Capricornxs on Thu Jun 28, 2007 12:13 am

thanks so much ede, but my post in the ubuntu forum got a reply and it worked. I just had to go under the install software thingy and find the ttf packages and they got redownloaded and reinstalled. YAY!!!

thanks guys!
Capricornxs
Level 1
Level 1
 
Posts: 11
Joined: Mon Jun 25, 2007 5:47 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], clankfu, Google [Bot] and 38 guests