Fstab

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Fstab

Postby Loli on Wed Jun 27, 2007 10:21 am

I would like to have all my drives automounted. However, I seem to be having a problem. I have one (advertised size :P)250GB hard drive, and I Have several partitions on it, A 14GB ext3(Where linuxmint is installed), 45GB ext3, 101ext3, a 55.3GB ext3, and a 13.8 NTFS. I would like to have them all automounted, (It only automounts the NTFS). I changed the noauto to auto, but it seems that it was something else, because it kept mounting for a while (didn't work though it just kept trying again and again), but it must have been the wrong thing. Any help please?
Code: Select all
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda3
UUID=8b588b96-917d-4b49-8357-316281e95984 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda9
UUID=c0f3b1dd-4de8-4a96-8609-4325b5a96887 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
Loli
Level 1
Level 1
 
Posts: 14
Joined: Tue Jun 26, 2007 7:44 pm

Linux Mint is funded by ads and donations.
 

Re: Fstab

Postby KrazyPenguin on Wed Jun 27, 2007 2:18 pm

Loli wrote:I would like to have all my drives automounted. However, I seem to be having a problem. I have one (advertised size :P)250GB hard drive, and I Have several partitions on it, A 14GB ext3(Where linuxmint is installed), 45GB ext3, 101ext3, a 55.3GB ext3, and a 13.8 NTFS. I would like to have them all automounted, (It only automounts the NTFS). I changed the noauto to auto, but it seems that it was something else, because it kept mounting for a while (didn't work though it just kept trying again and again), but it must have been the wrong thing. Any help please?
Code: Select all
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda3
UUID=8b588b96-917d-4b49-8357-316281e95984 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda9
UUID=c0f3b1dd-4de8-4a96-8609-4325b5a96887 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0


sda3 must be your Mint Linux.
sda9 is your swap.

That's all you are mounting here.

Here is mine so it should help:
# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda3 :
UUID=31269454-0b00-47db-bf95-511b101940e5 / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/sda6 :
UUID=128e7197-de5c-40ea-b51f-cb4d041e5980 /home ext3 defaults 0 2
# Entry for /dev/sda2 :
UUID=a71498fb-16be-4807-afb3-84050a4af575 /media/sda2 ext3 defaults 0 2
# Entry for /dev/sda7 :
UUID=45BB-69AE /media/sda7 vfat defaults,utf8,umask=007,gid=46 0 1
# Entry for /dev/sda1 :
UUID=DA38F06438F040D5 /windows ntfs-3g defaults,locale=en_CA.UTF-8 0 1
# Entry for /dev/sda5 :
UUID=281b5311-ee0c-4989-a02c-80eefef776fd none swap sw 0 0
/dev/scd1 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto 0 0


sda1 = windows
sda2 = ext3
sda3 = mint
sda4 (not listed) = logical extension
sda5= swap
sda6 = ext3 (/home)
sda7 = stuff (fat shared)

Your UUID's will be different.

Good luck !!!
;-)
KrazyPenguin
Level 1
Level 1
 
Posts: 46
Joined: Thu Jun 14, 2007 9:59 pm


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 28 guests