Problem Quitting

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Problem Quitting

Postby georgeg on Sat Jun 30, 2007 2:24 am

I'm trying to run Mint 3.0. While restarting the computer works pretty much as expected, selecting Quit to shut down the PC when I'm done for the day, doesn't work as expected. The computer doesn't shut down, it just goes to a black screen with a Mint logo in the center. Is this normal behavior? How am I suppose to know when its safe to pull the plug? (No, I don't leave my PC powered up 24/7)
georgeg
Level 2
Level 2
 
Posts: 84
Joined: Fri May 18, 2007 9:59 am

Linux Mint is funded by ads and donations.
 

Postby athiwatc on Sat Jun 30, 2007 4:55 am

Did you just install from the live CD
athiwatc
Level 1
Level 1
 
Posts: 16
Joined: Thu Jun 28, 2007 4:42 am

Re: Problem Quitting

Postby scorp123 on Sat Jun 30, 2007 5:23 am

georgeg wrote:selecting Quit to shut down the PC when I'm done for the day, doesn't work as expected.
How old is that PC? Could be that ACPI is causing problems and thus the OS can't properly power off the PC. On some older machines it won't work properly without some minor workarounds ....

If you want to try it out:

Edit /boot/grub/menu.lst as root (you have to type this into a terminal):
Code: Select all
sudo gedit /boot/grub/menu.lst

Locate the entries that load your OS, they might look something like this (my stuff is heavily modified so it most likely will look different):
    ...
    ## ## End Default Options ##

    title Cassandra, kernel 2.6.21.5
    root (hd0,4)
    kernel /vmlinuz-2.6.21.5 root=/dev/hda6 vga=791 ro quiet splash
    initrd /initrd.img-2.6.21.5
    quiet
    savedefault
    ...
Locate the line I highlighted above and add these parameters:
Code: Select all
apm=power-off acpi=force


The line should now read something like this:
Code: Select all
kernel          /vmlinuz-2.6.21.5 root=/dev/hda6 vga=791 ro apm=power-off acpi=force quiet splash
As mentioned before, please apply some common sense here! Don't copy & paste my entries 1:1 -- this will probably result in your system being hosed. Just add the entries I mentioned above so that the line in your boot loader config looks similar. Leave the other entries and parts untouched :wink:

After you have applied those entries, reboot your system and try again. Does the system properly power-off now?
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Re: Problem Quitting

Postby georgeg on Mon Jul 02, 2007 12:13 am

[quote="

After you have applied those entries, reboot your system and try again. Does the system properly power-off now?[/quote]

Thanks. That did the trick. Now, Mint shuts down properly.
georgeg
Level 2
Level 2
 
Posts: 84
Joined: Fri May 18, 2007 9:59 am


Return to Newbie Questions

Who is online

Users browsing this forum: WendyM and 52 guests