Permission to write

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Permission to write

Postby antiquexray on Sat Jun 30, 2007 3:03 pm

How do I give myself permission to write to the partition that has XP?
User avatar
antiquexray
Level 5
Level 5
 
Posts: 595
Joined: Sat Nov 18, 2006 6:04 pm
Location: Albert Lea Minnesota USA

Linux Mint is funded by ads and donations.
 

Re: Permission to write

Postby scorp123 on Sat Jun 30, 2007 3:42 pm

antiquexray wrote:How do I give myself permission to write to the partition that has XP?
Google for ntfs-3g .... Writing to a NTFS partition is somewhat *unsafe* BTW, Microsoft never really released the specifications. It would be better if you exchanged your data via a FAT32 partition (which is safe to use as both OS can safely access it) or if you used CD's, DVD's or maybe USB sticks....

As I said, I don't recommend writing to NTFS partitions from Linux and you shouldn't mess with these things unless you are perfectly sure what you do.
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Re: Permission to write

Postby antiquexray on Sat Jun 30, 2007 4:37 pm

scorp123 wrote:Google for ntfs-3g .... Writing to a NTFS partition is somewhat *unsafe* BTW, Microsoft never really released the specifications. It would be better if you exchanged your data via a FAT32 partition (which is safe to use as both OS can safely access it) or if you used CD's, DVD's or maybe USB sticks....

As I said, I don't recommend writing to NTFS partitions from Linux and you shouldn't mess with these things unless you are perfectly sure what you do.
OK, thanks. Next question then...how do I exchanged my data via FAT32?
User avatar
antiquexray
Level 5
Level 5
 
Posts: 595
Joined: Sat Nov 18, 2006 6:04 pm
Location: Albert Lea Minnesota USA

Re: Permission to write

Postby scorp123 on Sat Jun 30, 2007 7:02 pm

antiquexray wrote:...how do I exchanged my data via FAT32?
Find a FAT32 formatted disk and/or partition and then just drag & drop your files around?
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby OU812 on Sat Jun 30, 2007 7:21 pm

For vfat partitions, just edit fstab. In the arguments section, use

defaults,users,rw,umask=000

That should work.

john
OU812
Level 3
Level 3
 
Posts: 151
Joined: Fri Jun 29, 2007 8:01 pm
Location: California, USA

Postby Husse on Sun Jul 01, 2007 7:42 am

You can see that scorp123 mostly uses some other Linux than Mint (being a "server guy")
Mintdisk automounts with ntfs-3g so the disks are mounted in the normal case...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby antiquexray on Sun Jul 01, 2007 8:08 am

Husse wrote:You can see that scorp123 mostly uses some other Linux than Mint (being a "server guy")
Mintdisk automounts with ntfs-3g so the disks are mounted in the normal case...
Unfortunately, I'm not sure what automounts with ntfs-3g and being mounted in the normal case means. Are you saying that I should be able to do it because it is ntfs-3g?

PS Not only is Mint the only distro I run now (I have limited experience), but I'm just a amature noob :)
User avatar
antiquexray
Level 5
Level 5
 
Posts: 595
Joined: Sat Nov 18, 2006 6:04 pm
Location: Albert Lea Minnesota USA

Postby clem on Sun Jul 01, 2007 1:02 pm

Edit /etc/fstab and remove ALL references to your FAT/NTFS partitions (even references that are commented out). Then reboot. MintDisk will mount these in Read/Write mode and place icons on your desktop.

I'll write about mintDisk in the next mintMag. Very few people know how to use/configure it.

Clem
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5514
Joined: Wed Nov 15, 2006 8:34 am

Postby antiquexray on Sun Jul 01, 2007 1:40 pm

clem wrote:Edit /etc/fstab and remove ALL references to your FAT/NTFS partitions (even references that are commented out). Then reboot. MintDisk will mount these in Read/Write mode and place icons on your desktop.

I'll write about mintDisk in the next mintMag. Very few people know how to use/configure it.

Clem
Thanks Clem. Nice to hear from you again. Did as you said, but no icon on Desktop.
User avatar
antiquexray
Level 5
Level 5
 
Posts: 595
Joined: Sat Nov 18, 2006 6:04 pm
Location: Albert Lea Minnesota USA

Postby Husse on Sun Jul 01, 2007 5:23 pm

Code: Select all
but no icon on Desktop.

Check if you see the disk(s) in the file browser - if so check the settings for mintdesktop so it's marked to appear on the desktop
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby antiquexray on Sun Jul 01, 2007 7:11 pm

Well, I did as Clem said and I couldn't see my windows files as all. Fortunately for me, I made a copy of the fstab file, so I rebooted with the original file. I can see the windows files again, but I still don't have permission to change my access. I'd like to at least know how to do that. It's obvious I need to learn a lot more.
User avatar
antiquexray
Level 5
Level 5
 
Posts: 595
Joined: Sat Nov 18, 2006 6:04 pm
Location: Albert Lea Minnesota USA

Postby antiquexray on Sun Jul 01, 2007 9:57 pm

antiquexray wrote:...I still don't have permission to change my access. I'd like to at least know how to do that. It's obvious I need to learn a lot more.

For better or worse, I learned a little more. I successfully removed the "lock" icon from /windows and the permission now says "Create and delete files." I documented how I did it in hopes in can reverse it if I need to.
User avatar
antiquexray
Level 5
Level 5
 
Posts: 595
Joined: Sat Nov 18, 2006 6:04 pm
Location: Albert Lea Minnesota USA

Postby Husse on Mon Jul 02, 2007 5:14 pm

removed the "lock" icon from /windows

???
What is /windows? Do you have a volume label to your Windows partition?
And it should never have a lock!
Where is it mounted?
I'm not trying to make fun of you but trying to understand :)
A r/w ntfs partition should look like this in fstab:
Code: Select all
/dev/sda1 /media/sda1     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1

Of course you may have another partition and possibly UUID
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby antiquexray on Mon Jul 02, 2007 6:06 pm

Husse wrote:
removed the "lock" icon from /windows

???
What is /windows? Do you have a volume label to your Windows partition?
And it should never have a lock!
Where is it mounted?
I'm not trying to make fun of you but trying to understand :)
A r/w ntfs partition should look like this in fstab:
Code: Select all
/dev/sda1 /media/sda1     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1

Of course you may have another partition and possibly UUID
All I know is I followed the partition guide as posted in the wikimint. At the bottom of File Browser "File System", after /Bin, /Boot, etc, it says /windows. It use to have "lock" icon. It no longer does.

I'm taking a wild guess here, but I'm thinking you believe that to be wrong.

BTW, thanks for the email back Husse.
User avatar
antiquexray
Level 5
Level 5
 
Posts: 595
Joined: Sat Nov 18, 2006 6:04 pm
Location: Albert Lea Minnesota USA

Postby Husse on Tue Jul 03, 2007 7:24 am

you believe that to be wrong

No - I don't believe it to be wrong - I know it's wrong :)
Somehow you've managed to mount your Windows partition as a normal folder :)
That is if you created a folder called Windows to mount your ntfs into
You could do that - but I'd say you should not and it is owned by root and so is the ntfs partition unless you add user in the right place when mounting
In fstab add the following after the part that identifies your ntfs partition
Code: Select all
/media/"your ntfs"    ntfs    defaults,nls=utf8,umask=007,gid=46 0       1

Change "your ntfs" to whatever your partition is called - like sda2 or hdb1
Your complete line should be
Code: Select all
/dev/"your ntfs" /media/"your ntfs"     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1

//edit/ Typo corrected//
Remove/comment any other occurrence of the partition
You should now see it as a separate volume in the file browser - and the error could not be the result of following the partitioning guide....
Last edited by Husse on Tue Jul 03, 2007 6:34 pm, edited 1 time in total.
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby antiquexray on Tue Jul 03, 2007 4:30 pm

Husse wrote:In fstab add the following after the part that identifies your ntfs partition
Code: Select all
/media/"your ntfs"    ntfs    defaults,nls=utf8,umask=007,gid=46 0       1

Change "your ntfs" to whatever your partition is called - like sda2 or hdb1
Your complete line should be
Code: Select all
dev/"your ntfs" /media/"your ntfs"     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1

Remove/comment any other occurrence of the partition
You should now see it as a separate volume in the file browser - and the error could not be the result of following the partitioning guide....

GParted says /dev/sda1 (with an ! inside a triangle) and a lock icon

My fstab reads

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda2 :
UUID=1f12471a-9906-404f-901f-1f38484f8a16 / reiserfs notail 0 1
# Entry for /dev/sda4 :
UUID=64f176ce-3773-49b7-9dd8-1a91d5cbfcb1 /home ext3 defaults 0 2
# Entry for /dev/sda1 :
UUID=F48C842F8C83EB06 /windows ntfs-3g defaults,locale=en_US.UTF-8 0 1
# Entry for /dev/sda3 :
UUID=dbe6d70c-5c79-4058-a71c-b131c70a3e0d none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0

So I change it to read:

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda2 :
UUID=1f12471a-9906-404f-901f-1f38484f8a16 / reiserfs notail 0 1
# Entry for /dev/sda4 :
UUID=64f176ce-3773-49b7-9dd8-1a91d5cbfcb1 /home ext3 defaults 0 2
# Entry for /dev/sda1 :
UUID=F48C842F8C83EB06 /dev/sda1 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# Entry for /dev/sda3 :
UUID=dbe6d70c-5c79-4058-a71c-b131c70a3e0d none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
//edit/ Typo corrected/husse//
Am I following you here correctly?
User avatar
antiquexray
Level 5
Level 5
 
Posts: 595
Joined: Sat Nov 18, 2006 6:04 pm
Location: Albert Lea Minnesota USA

Postby Husse on Tue Jul 03, 2007 6:32 pm

Almost correct :)
The ! in a triangle is (obviously) a warning, I've also had it but unfortunately forgotten what it is.
Change this
UUID=F48C842F8C83EB06 dev/sda1 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

to either this
Code: Select all
/dev/sda1 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

or this
Code: Select all
UUID=F48C842F8C83EB06 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

The UUID is your /dev/sda1 with another kind of "naming"
UUIDs can cause a lot of touble so I prefer not to use them, but I think you should stick with the UUID version
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby antiquexray on Tue Jul 03, 2007 7:06 pm

Husse wrote:Almost correct :)
The ! in a triangle is (obviously) a warning, I've also had it but unfortunately forgotten what it is.
Change this
UUID=F48C842F8C83EB06 dev/sda1 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

to either this
Code: Select all
/dev/sda1 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

or this
Code: Select all
UUID=F48C842F8C83EB06 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

The UUID is your /dev/sda1 with another kind of "naming"
UUIDs can cause a lot of touble so I prefer not to use them, but I think you should stick with the UUID version
I've tried both, and although I can now see my windows os in the file manager, it says it is unable to mount it because it can't find /dev/sda1 in /etc/fstab.

Perhaps I should just reinstall Mint and go with the 1st option as seen in the Wiki. After all, tomorrow is a holiday here, and I have all day.

Does it matter that when I 1st install the other OS, partitioned the hard drive then, or should I have waited until I install Mint and used gparted?
User avatar
antiquexray
Level 5
Level 5
 
Posts: 595
Joined: Sat Nov 18, 2006 6:04 pm
Location: Albert Lea Minnesota USA

Postby Husse on Wed Jul 04, 2007 9:35 am

Oops!
I forgot - you have to create a folder to mount in
Code: Select all
sudo mkdir /media/sda1

which I think you've done once - a folder called "windows"
But better still is that you make a copy of fstab
Code: Select all
sudo cp /etc/fstab fstab.bak1

and then remove every trace of the ntfs partition in fstab - it then gets mounted by mintDisk
Check in mintDesktop that you have selected to show drives on the desktop
We got so "entangled" in this fstab that I forgot the best solution. It should have worked for you from the beginning
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby antiquexray on Wed Jul 04, 2007 6:22 pm

Husse wrote:Oops!
I forgot - you have to create a folder to mount in
Code: Select all
sudo mkdir /media/sda1

which I think you've done once - a folder called "windows"
But better still is that you make a copy of fstab
Code: Select all
sudo cp /etc/fstab fstab.bak1

and then remove every trace of the ntfs partition in fstab - it then gets mounted by mintDisk
Check in mintDesktop that you have selected to show drives on the desktop
We got so "entangled" in this fstab that I forgot the best solution. It should have worked for you from the beginning


No problem Husse, I look at all of this as learning experience. I appreciate all you r help. Besides, it's all working now except that I have 2 sda1 icons on my desktop now...go figure
User avatar
antiquexray
Level 5
Level 5
 
Posts: 595
Joined: Sat Nov 18, 2006 6:04 pm
Location: Albert Lea Minnesota USA

Linux Mint is funded by ads and donations.
 
Next

Return to Newbie Questions

Who is online

Users browsing this forum: deweylovem, Linny, norm.h, WharfRat and 50 guests