Workgroup Name. (SOLVED)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Workgroup Name. (SOLVED)

Postby BreezyCricket on Sun Nov 22, 2009 1:14 pm

I have a Windows Home Network of 3 Desktop and 1 Laptop PC.

The Network Name is 'Mystics', because I am always mystified when something actually works under Windows.

As a result I am determined to change to Linux and installed Mint on a second Laptop, on a trial basis.

If my understanding of how Networks work is correct, all machines must be part of the same Network, ie 'Mystics', but, although I do not recall entering any Network name during the Mint installation, my 'Mint' laptop has been assigned the Network name 'Workgroup', which is the Windows default.

Can anyone tell me how to change this to 'Mystics'.

Many Thanks.
Last edited by BreezyCricket on Tue Nov 24, 2009 3:56 pm, edited 1 time in total.
BreezyCricket
Level 1
Level 1
 
Posts: 6
Joined: Sat Nov 21, 2009 2:20 pm

Linux Mint is funded by ads and donations.
 

Re: Workgroup Name.

Postby DrHu on Sun Nov 22, 2009 1:22 pm

right-click My Computer on desktop>Properties>Change name>Mystics

Or In a terminal
  • sudo gedit /etc/samba/smb.conf
  • Find workgroup, change name to mystics..
    --reboot or restart samba
  • sudo /etc/init.d/samba restart

You can also install system-config-samba for more GUI control over samba settings..
User avatar
DrHu
Level 16
Level 16
 
Posts: 6694
Joined: Wed Jun 17, 2009 8:20 pm

Re: Workgroup Name.

Postby altair4 on Sun Nov 22, 2009 1:32 pm

Having the same workgroup name on all machines in a lan is a Samba myth. I have 3 workgroup names on my home network and everyone can see and share directories just fine. It does make it easier to work with however when you have everybody displayed in one place.

Anyway to answer your question ( finally :wink: ):

Press Alt+F2
Type gksu gedit /etc/samba/smb.conf

Find the following line ( it's somewhere in the very beginning of the file ):
# Change this to the workgroup/NT-domain name your Samba server will part of
workgroup = workgroup

Change it to
workgroup=Mystics

Save the file, open a Terminal and type sudo service samba restart.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5933
Joined: Tue Feb 03, 2009 10:27 am

Re: Workgroup Name.

Postby BreezyCricket on Mon Nov 23, 2009 2:26 pm

Many thanks for the replies.

It seems like my decision to change to Linux was the right one, because, after all, unlike Windows, I had a problem and it did not cost me a single tooth to get it fixed. :D

Cheers, and everything of the best to you and yours.
BreezyCricket
Level 1
Level 1
 
Posts: 6
Joined: Sat Nov 21, 2009 2:20 pm


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot] and 41 guests