No Video

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

No Video

Postby kenwood1995 on Sun Jul 15, 2007 11:23 am

My AGP video card died so I removed it and connected my monitor to the onboard vga, which is turned on, and when I boot now I appear to be in terminal mode?
I login as it asks and type startx as a friend said I should, but I guess I am still in terminal as I have no GUI.
Everything is OK in Windows XP
Remember I am a newbie.
What I gotta do?

Murry
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Linux Mint is funded by ads and donations.
 

Postby newW2 on Sun Jul 15, 2007 11:30 am

What is the on-board video? Nvidia, etc.
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA

Postby kenwood1995 on Sun Jul 15, 2007 11:59 am

It is VIA
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Postby newW2 on Sun Jul 15, 2007 12:43 pm

Enter:
sudo /etc/init.d/gdm start

If you don't get the GUI, try Ctrl+Alt+F7. If that doesn't work do Ctrl+Alt+F1 and enter the code:
sudo dpkg-reconfigure xserver-xorg

This will start a text-based "wizard" that will ask you questions about your keyboard, your mouse, your graphics card, and your monitor. Answer the questions as best you can. If you don't know the answer to a question, just go with the default and press Enter.

When you're done, press Control-Alt-F7 to get back to graphical mode and then Control-Alt-Backspace to reset the X server (so your changes can take effect).

The above thanks to: http://psychocats.net/ubuntu/nox
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA

Postby kenwood1995 on Sun Jul 15, 2007 1:48 pm

Got it.
The Ctrl+Alt+F1 and then the reconfigure worked fine.
Thank you much.
I am alive and well as a newbie can be.
Murry
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Postby newW2 on Sun Jul 15, 2007 2:06 pm

Glad it worked. Have fun learning! Mint is a great distribution and the moderators on this forum are some of the most active and engaged around. They are extremely talented and give excellent advice. See you around here more often giving help to newbies soon, I'm sure. :D
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA

Postby kenwood1995 on Sun Jul 15, 2007 4:32 pm

Seeing as we are on a positive roll here, does anyone know why my soundcards keep changing designations each time I reboot or restart?
My Ensoniq will be dsp0 and my onboard will be dsp1 and on a restart they will swap designations.
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Postby Husse on Tue Jul 17, 2007 6:32 am

you should have made a new post and I'd seen it long before. This bumps this for me and I'll get back when the soon coming thunderstorm has passed
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby ceti on Tue Jul 17, 2007 7:26 am

kenwood1995 wrote:Seeing as we are on a positive roll here, does anyone know why my soundcards keep changing designations each time I reboot or restart?
My Ensoniq will be dsp0 and my onboard will be dsp1 and on a restart they will swap designations.


Hi, Kenwood, try this (it worked for me):

1 - Open a Terminal and type: sudo asoundconf list <ENTER>

I got back:

Names of available sound cards:
VT82xx
UAC3553B


I then did:

sudo asoundconf set-default-card VT82xx

...and rebooted to test.

Of course, you'll have to replace the last line with your own soundcard designation. Let me know if it worked. Actually, I have a Plan B.

Cheers
Sorry, but that's the way it is.
User avatar
ceti
Level 2
Level 2
 
Posts: 87
Joined: Tue Feb 27, 2007 7:41 am
Location: Brazil

Postby Husse on Tue Jul 17, 2007 2:05 pm

Lightning risk gone and I make a quick check and see that some other helpful forum member has come up with the solution (I hope)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby kenwood1995 on Tue Jul 17, 2007 6:36 pm

OK tried that but when I rebooted the one I had set to default was now dsp1, whereas before reboot it was dsp
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Postby ceti on Tue Jul 17, 2007 7:12 pm

kenwood1995 wrote:OK tried that but when I rebooted the one I had set to default was now dsp1, whereas before reboot it was dsp


What do you get when you type sudo asoundconf list at the terminal?
Which one you want to be the default?
I'm waiting...

Cheers
Sorry, but that's the way it is.
User avatar
ceti
Level 2
Level 2
 
Posts: 87
Joined: Tue Feb 27, 2007 7:41 am
Location: Brazil

Postby kenwood1995 on Wed Jul 18, 2007 9:35 am

I think it may have worked, I am just interpreting the results wrong?

In terminal I type

sudo asoundconf list

Result

Names of available sound cards
V8237
AudioPCI

Then as requested, I type

sudo asoundconf set-default-card AudioPCI

I was expecting to see AudioPCI come up as dsp and the V8237 come up as dsp1
Now AudioPCI comes up as dsp1 everytime
So I guess I am OK?
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Postby ceti on Wed Jul 18, 2007 1:16 pm

No, I think you're interpreting right, if you want AudioPCI to be the default. Did you try swicht the cards in the above command?

Anyway, if they're not working the way you want, do this (that's the Plan B):

1 -Check if ALSA-order changes by typing:
cat /proc/asound/cards

2 - If it does, you could try to find out what modules are using the cards by typing:
lsmod | grep snd

3 - Then, open a Terminal, type gedit /etc/modprobe.d/alsa-base <ENTER>, and put these 02 lines to end of the file and save & reboot:
options name-of-the-one-you want-to-be-the-default-as-it-appears-after-the-above-command (lsmod >grep snd) index=0
options name-of-the-one-you want-to-be-your-second-card-as-it-appears-after-the-above-command (lsmod >grep snd) index=1

In my case, a lsmod | grep snd outputs:
snd-via82xx
snd-usb-audio

I want my internal card (VIA8237) to be the default and the external soundcard (USB Philips) to be second, so I append the following lines to the end of /etc/modprobe.d/alsa-base:
options snd-via82xx index=0
options snd-usb-audio index=1


I'm waiting your feedback...

Cheers
Sorry, but that's the way it is.
User avatar
ceti
Level 2
Level 2
 
Posts: 87
Joined: Tue Feb 27, 2007 7:41 am
Location: Brazil

Postby kenwood1995 on Wed Jul 18, 2007 4:09 pm

Looks like that done it.
I thank you.
A lot of good info available on this forum.
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot], Seiikey and 35 guests