How-to enable 'Don't ask for password on login'?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

How-to enable 'Don't ask for password on login'?

Postby averageschmoe on Fri Jan 22, 2010 6:31 pm

I'm in the process of reformatting several windows computers and am using Helena as the swap. The normal computers are on a network and require users to sign in but since this is temporary and mostly to see how people respond to a different OS I don't want to have a requirement to login, I just want it on and available. The problem is that even though there is a message telling people not to sign out, they are doing so out of habit and no one knows the password to get back in. Under 'Users and Groups' there is a greyed-out box that reads 'Don't ask for password on login'. I can't enable it even if I am logged in as root. What do I need to do to enable this or is their an easier option I am over-looking? I tried creating a Guest account with no password but that doesn't seem to be an option. This may not seem like a newbie question but if you had ever met me you would understand.
averageschmoe
Level 1
Level 1
 
Posts: 4
Joined: Tue Oct 27, 2009 9:07 am

Linux Mint is funded by ads and donations.
 

Re: How-to enable 'Don't ask for password on login'?

Postby garda on Sat Jan 23, 2010 4:08 am

I don't know how to enable the option, but I do know of a way to achieve what you want.

All you need to do is edit /etc/pam.d/gdm:
Code: Select all
gksu gedit /etc/pam.d/gdm

Then locate the line that reads @include common-auth. Copy and paste this line right before it:
Code: Select all
auth sufficient pam_listfile.so item=user sense=allow file=/etc/nopassusers onerr=fail

Example:
    auth sufficient pam_listfile.so item=user sense=allow file=/etc/nopassusers onerr=fail
    @include common-auth
Press CTRL-S to save it. Next, create a file called nopassusers in /etc/:
Code: Select all
gksu gedit /etc/nopassusers

Add the username that you want to make accessible without password. Press CTRL-S to save, then close the editor.

Ask what you don't understand here.
User avatar
garda
Level 5
Level 5
 
Posts: 744
Joined: Sat Aug 30, 2008 2:55 am
Location: /root

Re: How-to enable 'Don't ask for password on login'?

Postby StanTheMan on Sat Jan 23, 2010 10:49 pm

If you are using the Gnome desktop , click on the main menu > System > Administration > Login Screen . Give the necessary password for administratiion . Click on the radio button 'Log in as' > automatically.

If you have KDE there is a similar setting in Settings.
StanTheMan
Level 5
Level 5
 
Posts: 577
Joined: Fri Feb 13, 2009 7:07 pm

Re: How-to enable 'Don't ask for password on login'?

Postby gordon.cooke on Sun Jan 24, 2010 10:01 pm

In Mint: on the menu you can select "Control Center"
from there under he System heading select "Login Screen"
That has an option to "Login As" any user (you'll need to click on "unlock" and enter your root password)

This is basically the same as StantheMan, but through the control center. This will automatically login anyone whenever booted.

Another Option-- (( I cant get this to work- anyone know how? ))
In the user manager (Control Center>Users & Groups) if you bring up the properties for a user there is an option box for "Dont ask for password to login" But it is always greyed out. I hae tried it after unlocking with root password, Ive logged in as root, Ive added a second username and Ive tried it with the login screen option to login without password both on and off. It is always greyed out and unavailable.

How is this enabled?? That would be a great way to set the computer to either allow multiple accounts without passwords (each one could not ask for password but still be a separate account) or to have just one account (Guest) that doesnt need a password, but is not the account that always automatically logs in. Its an option thats tehre but I cant figure how to enable it.
------------------------------------------------------------------------
Mint 13 64bit Cinnamon
Asus U56E Laptop, Core i5-2410M, Intel graphics, 6GB RAM
Mint 9 64bit
Averatec 2573 Laptop, AMD Turion 64x2, ATI Graphics, Atheros wireless, 3GB RAM
User avatar
gordon.cooke
Level 3
Level 3
 
Posts: 151
Joined: Tue Dec 01, 2009 9:48 pm
Location: New York

Re: How-to enable 'Don't ask for password on login'?

Postby garda on Mon Jan 25, 2010 12:57 am

@gordon.cooke:

The said option is not grayed out in Gloria/Ubuntu Jaunty,
only in Helena/Karmic.

The fact there seems to be no obvious way to turn the option on
in Helena/Karmic makes me think that the change was made in
the source code. Maybe the Ubuntu folks have a strong reasoning
behind this, maybe they don't. I really have no clue.

Anyway, the trick mentioned in my post above gives the same
effect, and it's legit. Enter man pam.d in terminal to get
more information.
User avatar
garda
Level 5
Level 5
 
Posts: 744
Joined: Sat Aug 30, 2008 2:55 am
Location: /root


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Mute Ant and 39 guests