Audio problems

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Audio problems

Postby Chaz on Sat Jan 23, 2010 3:33 am

When I pluged in my head phones, I expected to get sound through them only. Unfortinitly, that is not what happened. Both the head phones and the speakers are reciveing the output. How do I make it so that it is either the speakers or the head phones?
Chaz
Level 1
Level 1
 
Posts: 8
Joined: Mon Jan 18, 2010 10:22 pm
Location: Youngstown, OH

Linux Mint is funded by ads and donations.
 

Re: Audio problems

Postby Silent Warrior on Sat Jan 23, 2010 6:28 am

I just got hit with this as well, after upgrading xserver-xorg. In my case, the front audio-channels had been muted. Look around in various mixers or volume-controls until you see a bunch of things that are muted. When you see something you recognize as your output, unmute it and all's well.
If that's NOT your problem, be sure to tell us what soundcard you're using, and what lspci has to say about it.
Silent Warrior
Level 4
Level 4
 
Posts: 464
Joined: Mon Aug 24, 2009 1:10 pm
Location: Göteborg, Sverige

Re: Audio problems

Postby Chaz on Sat Jan 23, 2010 4:29 pm

I'll try that and let you know. I forgot to say that I'm using the universal version instead of the main, and that my sound is intergrated on an Intel Grant County 2 board made for emachines. I'm hoping that what you gave me works cause I don't know how to do much in linux yet.
Chaz
Level 1
Level 1
 
Posts: 8
Joined: Mon Jan 18, 2010 10:22 pm
Location: Youngstown, OH

Re: Audio problems

Postby Chaz on Sat Jan 23, 2010 11:54 pm

Ok, nothing is muted, and I don't know what lspci is or where to find it. My sound card is intergrated on the main board. I was looking for something simular to a windows device manager to get more information about my audio, but I was unable to find one. The only sound drive I could find on my system is pulse audio and I tried all of the settings but got the same result.
Chaz
Level 1
Level 1
 
Posts: 8
Joined: Mon Jan 18, 2010 10:22 pm
Location: Youngstown, OH

Re: Audio problems

Postby Silent Warrior on Mon Jan 25, 2010 2:48 pm

For lspci: Open a Terminal and type 'sudo lspci'. :) It will dump a LOT of information on you though - I don't know for sure how it's listed, but see if the line 'sudo lspci | grep audio' gets you something we can work with.
(Hints to other intrepid readers: I don't know what else to do about this. Any other takers?)
Silent Warrior
Level 4
Level 4
 
Posts: 464
Joined: Mon Aug 24, 2009 1:10 pm
Location: Göteborg, Sverige

Re: Audio problems

Postby Chaz on Tue Jan 26, 2010 1:43 am

Ok, this is all I got from lspci about audio: Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (rev 01). I don't know how that will help, but there it is. For some reason, pulse audio has bith the front and the rear outputs tied together as one device. If I mute the rear, the front also mutes, it I mute the front, nothing happens. I just figured this out tonight while playing with the pulse audio settings some more.
Chaz
Level 1
Level 1
 
Posts: 8
Joined: Mon Jan 18, 2010 10:22 pm
Location: Youngstown, OH

Re: Audio problems

Postby remoulder on Tue Jan 26, 2010 2:28 pm

Chaz, have a play with the PulseAudio Device Chooser which should be in the Sound & Video menu, if not it's probably hidden (unticked) in Edit menu. If that doesn't help, you may have to play with alsamixer, type alsamixer in a terminal. I suggest you read up on both a little before changing anything.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Audio problems

Postby Chaz on Fri Jan 29, 2010 8:54 pm

Ok, I went to alsmixer, and it doesn't even recognize my headphones as a seperate output. The main volume works, the headphone does nothing, and the next two work, but the rest seam to do nothing, although they do alow me to move them up and down. The headphone one doesn't even let me do that.
Chaz
Level 1
Level 1
 
Posts: 8
Joined: Mon Jan 18, 2010 10:22 pm
Location: Youngstown, OH

Re: Audio problems

Postby remoulder on Sat Jan 30, 2010 11:19 am

If you open a terminal and enter aplay -l (lowercase L) it should list all the recognized sound cards starting with card 0.

If you then enter amixer -c 0 contents (where 0 is the card number) it should list the cards controls and their settings. Look for a control called Headphone Playback Switch and check the value if it's there, it should be on. Enter amixer --help to see how to change the value. If it's not there has your card been correctly identified?
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: ChannieMole, glitchg, Google [Bot], Kardosh, norm.h and 32 guests