DVD slow, very busy - where to start?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

DVD slow, very busy - where to start?

Postby base_uk on Sat Jan 30, 2010 5:52 pm

Hi all,
fairly new to linux, using Helena, second question: I have exchanged my CD drive with an internal DVD writer, LG GH22NS40. It does work but but not like it should (and does under XP) . Problem is the drive is very busy when playing dvds or cds, and playback from audio cds keeps getting interrupted every so often , a problem I didn't have when playing the same cds from my old cd drive.

So... where would i have to start looking for possible solutions? Is this a driver issue? Couldn't find any linux drivers on the LG site. More general: How do I find out if my system has a problem with the device? Would appreciate any pointers!
base_uk
Level 1
Level 1
 
Posts: 14
Joined: Fri Jan 29, 2010 6:40 pm

Linux Mint is funded by ads and donations.
 

Re: DVD slow, very busy - where to start?

Postby richyrich on Sat Jan 30, 2010 5:57 pm

Is it the only optical drive connected to the cable, or I guess I should ask first, is it ide or sata ?
User avatar
richyrich
Level 13
Level 13
 
Posts: 4679
Joined: Mon May 04, 2009 8:31 pm
Location: Somewhere in northern Saskatchewan, Canada

Re: DVD slow, very busy - where to start?

Postby base_uk on Sat Jan 30, 2010 6:19 pm

Hi again,
it's my first and only SATA device. The CD drive had been an IDE slave.
base_uk
Level 1
Level 1
 
Posts: 14
Joined: Fri Jan 29, 2010 6:40 pm

Re: DVD slow, very busy - where to start?

Postby richyrich on Sat Jan 30, 2010 6:33 pm

One thing to check, is the buffer settings in the Player you are using. Have you burned a cd/dvd lately? What was the system buffer / device buffer showing during the burn ? Were they both up near the 90-100% ?

I've installed/use a lot of LG drives, and haven't run into this problem before . ?

richy
User avatar
richyrich
Level 13
Level 13
 
Posts: 4679
Joined: Mon May 04, 2009 8:31 pm
Location: Somewhere in northern Saskatchewan, Canada

W

Postby base_uk on Sat Jan 30, 2010 6:51 pm

richyrich wrote:One thing to check, is the buffer settings in the Player you are using. Have you burned a cd/dvd lately? What was the system buffer / device buffer showing during the burn ? Were they both up near the 90-100% ?

I've installed/use a lot of LG drives, and haven't run into this problem before . ?

richy

First thanks for your kind effort!
- check, is the buffer settings
Hmm, where would I check that? Opened /usr/bin/banshee - no luck
- Have you burned a cd/dvd lately
Well no, the last thing I set fire to was the Helena install...
base_uk
Level 1
Level 1
 
Posts: 14
Joined: Fri Jan 29, 2010 6:40 pm

Re: DVD slow, very busy - where to start?

Postby richyrich on Sat Jan 30, 2010 6:58 pm

Image

I was thinking right in the Banshee preferences ? sorry, I'm on my Mint 8 kde at the moment, don't have Banshee. :(
User avatar
richyrich
Level 13
Level 13
 
Posts: 4679
Joined: Mon May 04, 2009 8:31 pm
Location: Somewhere in northern Saskatchewan, Canada

Re: DVD slow, very busy - where to start?

Postby base_uk on Sat Jan 30, 2010 7:01 pm

richyrich wrote:Image

I was thinking right in the Banshee preferences ? sorry, I'm on my Mint 8 kde at the moment, don't have Banshee. :(

Yeah but the same problems occur with Rhythmbox or while playing videos. So how about SATA support - any settings or stuff I have to activate?
base_uk
Level 1
Level 1
 
Posts: 14
Joined: Fri Jan 29, 2010 6:40 pm

Re: DVD slow, very busy - where to start?

Postby richyrich on Sat Jan 30, 2010 7:08 pm

You can check the sata settings in the BIOS . . . if you want some assist, post what the settings are (ahci, ide enhanced, ide legacy, etc.)
User avatar
richyrich
Level 13
Level 13
 
Posts: 4679
Joined: Mon May 04, 2009 8:31 pm
Location: Somewhere in northern Saskatchewan, Canada

Re: DVD slow, very busy - where to start?

Postby base_uk on Sat Jan 30, 2010 7:27 pm

richyrich wrote:You can check the sata settings in the BIOS . . . if you want some assist, post what the settings are (ahci, ide enhanced, ide legacy, etc.)

I'll check that tomorrow - it does work however under win XP. Thanks again.
base_uk
Level 1
Level 1
 
Posts: 14
Joined: Fri Jan 29, 2010 6:40 pm

Re: DVD slow, very busy - where to start?

Postby base_uk on Sun Jan 31, 2010 1:36 pm

So after spending a couple more hours with this I'm thoroughly confused ;)

The DVD drive gets mounted automatically on boot and also when putting in a cd or dvd. Even when there is no entry in fstab. When installing Helena it created an entry for the CDROM drive which was installed then. So I thought, despite automatic booting I need a mountpoint in fstab. After several attempts it currently looks like this:
Code: Select all
/dev/sr0   /media/dvd   udf   rw,user,noauto,exec,unhide   0   0
Doesn't read cd however, but when I set fs to auto, it won't mount at all.
Still the dvds do not show up at /media/dvd when automatically mounted.

But either way, the same problems persist. It's no fun at all to play music or videos from the drive, still slow, ultra busy and pretty noisy.

Also why is my dvd drive called sr0 when every example I found on the web suggests it should be on /dev/dvd - and does it matter?


You can check the sata settings in the BIOS . . . if you want some assist, post what the settings are (ahci, ide enhanced, ide legacy, etc.)

Hmm, my mb is Gigabyte MA770-UD3. BIOS lets me select SATA modes ahci, ide native or raid. I tried ahci and ide native, but that didn't seem th have any effects in the behaviour of the drive in my Linux environment. Currently it's ide Native. Not sure about ide enhanced or legacy, on ide channel 2 BIOS auto detects ide/sata devices and lets me choose access modes Auto and Large, currently set to default value Auto.
base_uk
Level 1
Level 1
 
Posts: 14
Joined: Fri Jan 29, 2010 6:40 pm

Re: DVD slow, very busy - where to start?

Postby base_uk on Sun Jan 31, 2010 5:44 pm

Update: I have recently updated to kernel version 2.6.31-17 via update manager. Now I logged in to the old version, 2.6.31-14, and voila - no problems with the dvd anymore. Audio CDs as well as Video DVDs play well.

Whatever that means...like, never do kernel updates...? :)

Also I have now added a symlink from /dev/sr0 to /dev/dvd. This seems to be necessary for some apps.
base_uk
Level 1
Level 1
 
Posts: 14
Joined: Fri Jan 29, 2010 6:40 pm

General SATA-Problem, no DMA?

Postby base_uk on Thu Feb 11, 2010 7:16 pm

Actually the drive behaves as badly as ever. I have read lots of stuff n the web in the meantime describing problems with dvd-devices and SATA-Devices in general, about setting dma via hdparm etc.. No solution yet but I'm not willing to throw the towel yet... I could however need a helping hand ;)
So here's a collection of info that should hopefully hold a hint to what's going on
---
Device:
HL-DT-ST DVDRAM GH22NS40
Internal SATA

BIOS Settings:
AHCI enabled or Native IDE (no influence on behaviour registered)

System:
Kernel : Linux 2.6.31-14-generic (x86_64)
Compiled : #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009
Distribution : Linux Mint 8 Helena - x64 Edition
-------------------
$ sudo mount
/dev/sda7 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/sda5 on /media/fileshare type fuseblk (rw,noexec,nosuid,nodev,allow_other,blksize=4096)
/dev/sda6 on /media/foto type fuseblk (rw,noexec,nosuid,nodev,allow_other,blksize=4096)
/dev/sda8 on /home type ext4 (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/uk/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=uk)
-----------------
fstab:
proc /proc proc defaults 0 0
# / was on /dev/sda7 during installation
UUID=fceff43b-e914-469c-95ff-3d257dc43c89 / ext4 errors=remount-ro 0 1
# /home was on /dev/sda8 during installation
UUID=6a9cae5a-18ff-4575-8ce3-d9c33504b18e /home ext4 defaults 0 2
# swap was on /dev/sda9 during installation
UUID=6c083d2f-49d7-4a33-b202-6c63b4dece96 none swap sw 0 0
#/dev/scd0 /media/cdrom0 iso9660 user,auto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sda5 /media/fileshare ntfs rw,user,auto,noexec,utf8
/dev/sda6 /media/foto auto rw,user,auto,noexec
/dev/sr0 /media/cdrom0 iso9660,udf user,auto,exec
---------------------
$ sudo hdparm /dev/sr0

/dev/sr0:
multcount = 0 (off)
IO_support = 1 (32-bit)
readonly = 0 (off)
readahead = 256 (on)
HDIO_GETGEO failed: Inappropriate ioctl for device#

There's also several lines in the output from dmesg that seems to relate to the drive but I'm not sure what is relevant , so please just ask and I'll try to find it.

Thanks again for any help!
base_uk
Level 1
Level 1
 
Posts: 14
Joined: Fri Jan 29, 2010 6:40 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot] and 16 guests