X failed to start up

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

X failed to start up

Postby Ramint on Thu Aug 02, 2007 7:34 pm

Hello Every body,
I'm new to the world of linux, this night I have installed Linux mint on my pc, and every thing went fine and smooth. I lunched Envy trying to download the ATI driver for my graphic card, and I use the automatic mode. when the download finished, and I pressed the apply button, a message appeared asking me if I wnat to restart my pc, I pressed yes. when I restarted the pc I can no more use the gdm, and xorg is not running, all I have is a command line.
my question is, how to restor the original settings of the xorg to the state befor the installation of the ati driver?

thanks in advance.
best regards Ramintu
Ramint
Level 1
Level 1
 
Posts: 11
Joined: Sun Jul 15, 2007 3:43 am

Linux Mint is funded by ads and donations.
 

Postby raezel on Fri Aug 03, 2007 3:19 am

Open the xorg.conf (vi /etc/X11/xorg.conf) and edit it so that you replace every fglrx with ati.
raezel
Level 1
Level 1
 
Posts: 18
Joined: Tue Jul 17, 2007 9:48 am

Postby scorp123 on Fri Aug 03, 2007 3:49 am

raezel wrote:Open the xorg.conf (vi /etc/X11/xorg.conf) and edit it so that you replace every fglrx with ati.
1. You forgot sudo ... As normal user he won't be able to save the file
2. Why vi ...? He already wrote that he is a beginner, so suggesting a vi as editor isn't really going to help ...

Better command would be: sudo nano /etc/X11/xorg.conf

If nano should not exist, it can be installed on the fly: sudo apt-get install nano
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby raezel on Fri Aug 03, 2007 5:47 am

scorp123 wrote:1. You forgot sudo ... As normal user he won't be able to save the file
2. Why vi ...? He already wrote that he is a beginner, so suggesting a vi as editor isn't really going to help ...

Better command would be: sudo nano /etc/X11/xorg.conf


The only reason I suggested vi was because it was the only (command line) text editor that I knew. Didn't intensionally meant to give bad advice.
raezel
Level 1
Level 1
 
Posts: 18
Joined: Tue Jul 17, 2007 9:48 am

Postby tseliot on Fri Aug 03, 2007 9:08 am

Boot in Recovery Mode (select it from the GRUB menu)

type:
Code: Select all
envy -t


and uninstall the ATI driver from there, then exit.

Restore the backup your previous xorg.conf:
type:
Code: Select all
cd /etc/X11/

Code: Select all
ls

you'll see xorg.conf and other backup files (e.g. xorg.conf_backup_200703022015)

replace xorg.conf with a backup:
Code: Select all
sudo cp name_of_your_backup_file xorg.conf


then reboot by typing:
Code: Select all
reboot
tseliot
Level 1
Level 1
 
Posts: 43
Joined: Wed Feb 07, 2007 6:55 am

10x

Postby Ramint on Sat Aug 04, 2007 4:34 pm

thank you all for the help, it helped me allot.
Ramint
Level 1
Level 1
 
Posts: 11
Joined: Sun Jul 15, 2007 3:43 am

Postby kcirick on Sat Aug 04, 2007 9:57 pm

raezel wrote:
scorp123 wrote:1. You forgot sudo ... As normal user he won't be able to save the file
2. Why vi ...? He already wrote that he is a beginner, so suggesting a vi as editor isn't really going to help ...

Better command would be: sudo nano /etc/X11/xorg.conf


The only reason I suggested vi was because it was the only (command line) text editor that I knew. Didn't intensionally meant to give bad advice.


LOL, I've been using Linux for quite some time, and I still can't use vi... My fav. text editor is joe, but everyone their own favourites. pico is pretty straight forward for most people too (I don't know if that is installed by default or not...)
kcirick
Level 1
Level 1
 
Posts: 36
Joined: Sat Aug 04, 2007 9:03 pm

x failes to startup

Postby mamar on Thu Aug 09, 2007 4:36 pm

My problem is similar:
My notebook (sony) doesn't have CD or FDD. So, I'm removing the HDD, transfering it to my other notebook (dell) and installing linuxmint there. Then I take the HDD and put back in the original notebook. It boots up nicely, but it doesn't load X. I end up with a command line. I know all about Windows (even DOS), but nothing about Linux. Is there any way to force linux to detect my video card and load the GUI?

PS: 1- I've tried to install every other possible way. The BIOS doesn't recognize externall CD, floppy, USB or nothing else.
2- That "trick"worked in the past with PClinuxOS 2007, but after trying another distro, I couldn't reproduce the "trick"again.

What would you recomend? Please assume I know nothing about Linux commands.
mamar
Level 1
Level 1
 
Posts: 1
Joined: Thu Aug 09, 2007 4:23 pm

Postby Husse on Thu Aug 09, 2007 5:43 pm

Welocme to Mint mamar
(Hm I think I just saw that nick somewhere else :))
When you install on another computer than the one you want to use the install will be a bad one - not adjusted to your hardware. But you have no option...
Read the trouble shooter for the liveCD
http://www.linuxmint.com/wiki/index.php ... ur_Live_CD
you may get some ideas there. If you have internet connection you can even install the correct driver with envy
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse on Thu Aug 09, 2007 5:45 pm

And a small correction - in recovery mode (mentioned above) you are root so no sudo is needed
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot], Mute Ant, WharfRat, WoodLark and 22 guests