External drive permissions / ownership

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

External drive permissions / ownership

Postby wspurlock on Fri Aug 10, 2007 10:20 am

I installed Mint about a month ago, and have been fighting with getting access to my Magellan Explorest 210. The unit connects by a USP port. When I plug it in and turn it on in file transfer mode, it shows up as an external drive (/media/MAP DATA), but I cannot write to the drive. After trying everything that I could think of last night I reinstalled Mint. In the live evaluation version I had no problem writing to the units hard drive, which BTW is VFAT. However as soon as I reinstalled a fresh copy of Mint I had the same problem. Looking at the permissions for the drive, the owner is listed as root with an access of create and delete files. File Access is set to "---" Other external drives have the exact same settings and I have no proplem writing to them. Just on the off chance I went in this morning and turned off MintDisk and after a reboot the owner of the drive is listed as my user name and not root. All the other settings remain the same and I still am unable to write to the drive. Any attempts return an error of "You do not have permission to write to this folder. Now, to make this more interesting before I reinstalled Mint I installed a copy of OpenSUSE 10.4 Gnome and things worked just fine. Also I have a friend that has the same uniit , he is running Mint also and can connect with no problems. Anyone have any ideas at all. I'm about to start pulling my hair out over this.
wspurlock
Level 1
Level 1
 
Posts: 4
Joined: Fri Aug 10, 2007 9:56 am

Linux Mint is funded by ads and donations.
 

Postby Boo on Sun Aug 12, 2007 9:38 pm

could you post your /etc/fstab file.
mintdisk should handle windows drives but if there is an entry in fstab for the partition (even a commented out on), mintdisk will ignore the partition.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby red-e-made on Mon Aug 13, 2007 1:24 pm

You might also consider changing the device permissions with chmod, if possible. I know that it can easily change permissions of files and folders - right-click, open in Terminal, log in as root, run the command, and exit root before exiting Terminal (very important!). Not so sure if this would work with devices.

There's a great tutorial here. Even if it doesn't work for your problem, bookmark it - it's a good resource.
User avatar
red-e-made
Level 5
Level 5
 
Posts: 525
Joined: Sat Jul 14, 2007 11:31 am

Problem solved

Postby wspurlock on Tue Aug 14, 2007 5:42 am

Turns out that the problem was caused by a corruption of the drive in the GPSr unit.
wspurlock
Level 1
Level 1
 
Posts: 4
Joined: Fri Aug 10, 2007 9:56 am


Return to Newbie Questions

Who is online

Users browsing this forum: all41, Bing [Bot], BlackVeils, Distro-Don and 26 guests