Issues with sound card on Dell Inspiron 9300

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Issues with sound card on Dell Inspiron 9300

Postby dbau on Tue Aug 14, 2007 11:13 pm

Hello,
I'm running Mint 3.0 on my Dell Inspiron 9300 laptop (2.6.20-16).
I do have sound, but the sound quality is really poor. For some strange reason the sound quality gets better the higher the volume is. As far as I can tell the on board sound card is being recognized, and the driver is installed properly:

dbau@(none):~$ lshw -class sound
*-multimedia
description: Multimedia audio controller
product: 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller
vendor: Intel Corporation
physical id: 1e.2
bus info: pci@00:1e.2
version: 03
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=Intel ICH latency=0
resources: ioport:ed00-edff ioport:ec40-ec7f iomemory:dffffe00-dfffffff iomemory:dffffd00-dffffdff irq:16

Any ideas what could be the cause and how I should go about fixing this issue?

Thanks,
Daniel
dbau
Level 1
Level 1
 
Posts: 2
Joined: Tue Aug 14, 2007 10:38 pm
Location: California

Linux Mint is funded by ads and donations.
 

Postby Husse on Wed Aug 15, 2007 11:49 am

Welcome to Mint dbau
A quick googling for your problem reveals nothing.
The main reason is (of course) AC97 which is a standard integrated soundcard but with not too good quality and also heavily software dependent
On the other hand I've got one nvidia/AC97 with OK sound.
Check if there is a difference between alsa and oss - this is selected in the preferences of your application
As far as I can see your lshw looks OK
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby dbau on Wed Aug 15, 2007 11:31 pm

Thanks for your fast reply. I'll check if switching between alsa and oss makes a difference.
---Daniel
dbau
Level 1
Level 1
 
Posts: 2
Joined: Tue Aug 14, 2007 10:38 pm
Location: California


Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot], kc1di, Resistor and 24 guests