Reinstall Mint now have two icons for NTFS volume on desktop

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Reinstall Mint now have two icons for NTFS volume on desktop

Postby mschilling on Tue Aug 14, 2007 11:28 pm

The last time I installed Mint I didn't see the two icons, only one showed on the desktop. Also now, when I boot, I get a screen prompting me to pick an os, Linux or XP, to boot from. I should have only one os on each drive, so there shouldn't be an option. Previously, with the first install, I picked the drive to boot from and the installed os was booted. Any idea what I did wrong with the second install? Somehow my system now sees the main hdd as a dual boot, I think, whereas I have a second hdd for Mint.
mschilling
Level 2
Level 2
 
Posts: 94
Joined: Wed Aug 01, 2007 9:48 pm
Location: Toronto

Linux Mint is funded by ads and donations.
 

Postby Boo on Tue Aug 14, 2007 11:44 pm

mint and ubuntu will find and list OS's on all the disks in your system.
so it is normal to have a choice between OS's to boot in grub, but by default it should boot mint.

I would need more information about your systems configuration and how you boot now compared to last time.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby mschilling on Wed Aug 15, 2007 12:53 am

It's a Dell D600 laptop with a second hdd in place of the optical drive. The bios can be set to boot from the different drives by using F12 at boot up. The first time I installed Mint I had the Mint hdd in the internal hdd bay and used the optical to boot from for the install. Then I moved the Mint hdd to the second hdd caddy and returned the XP drive to the internal spot.
The second time I installed Mint, I booted from an external USB optical drive and installed Mint over top the first install on the same hdd, but this time that hdd was in the second hdd caddy. Grub now sees a choice of two systems on the hdd. When I choose XP, the bios will start booting from the internal hdd, and when I choose Mint, it will boot from the second hdd. There is now no need to press F12 to choose a drive to boot from. Maybe this is the way the setup should work (?)
mschilling
Level 2
Level 2
 
Posts: 94
Joined: Wed Aug 01, 2007 9:48 pm
Location: Toronto

Postby Boo on Wed Aug 15, 2007 1:16 am

yes this is totally normal.
That is the way it is meant to boot.

what happened the second time is that mint could see the primary drive with windows on it so it added it to the grub boot menu.

what also happened is that mint wrote grub to the MBR (master boot record) of the primary disk (windows).
so now if you use F12 and choose the second disk (mint) it may not boot.
but since you installed to it the first time grub is also in its MBR and so may boot it anyway.

well if you mix up the hard drives now you may have booting problems so please ask questions if this happens.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby red-e-made on Wed Aug 15, 2007 6:11 am

I had this same thing happen to me when I did a re-install. I recommend booting from your LiveCD and manipulating your partitions using GParted. You may need to re-install afterwards.
User avatar
red-e-made
Level 5
Level 5
 
Posts: 525
Joined: Sat Jul 14, 2007 11:31 am

Re: Reinstall Mint now have two icons for NTFS volume on desktop

Postby antiquexray on Wed Aug 15, 2007 7:41 am

mschilling wrote:The last time I installed Mint I didn't see the two icons, only one showed on the desktop. Also now, when I boot, I get a screen prompting me to pick an os, Linux or XP, to boot from. I should have only one os on each drive, so there shouldn't be an option. Previously, with the first install, I picked the drive to boot from and the installed os was booted. Any idea what I did wrong with the second install? Somehow my system now sees the main hdd as a dual boot, I think, whereas I have a second hdd for Mint.
I have the same...check out this link:

http://linuxmint.com/forum/viewtopic.ph ... ion&t=3594

After learning why they were being mounted, I was able to remove one of the icons. The problem is that it then wouldn't show my flash drive, cd, etc., when mounted.
User avatar
antiquexray
Level 5
Level 5
 
Posts: 608
Joined: Sat Nov 18, 2006 6:04 pm
Location: Albert Lea Minnesota USA


Return to Newbie Questions

Who is online

Users browsing this forum: asmolinski425, oldgranola, Pastcal and 44 guests