Write permission on NTFS volume

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Write permission on NTFS volume

Postby ForeverNoob on Thu Aug 16, 2007 1:21 pm

Hi All,

How can I grunt write permission on a mounted NTFS volume for a specific user?

[using Cassandra]

TIA
ForeverNoob
Level 1
Level 1
 
Posts: 19
Joined: Mon Aug 13, 2007 11:06 am

Linux Mint is funded by ads and donations.
 

Postby Boo on Fri Aug 17, 2007 1:14 am

more info please.

does anyone now have write permission to the NTFS volume?

mintdisk runs in user space so anyone can write to it.

if you set the NTFS volume to mount via the fstab file you can restrict who can read and write to it.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby ForeverNoob on Fri Aug 17, 2007 5:00 am

Hi Boo,

Thank you for replying.

There is only one user defined, and he doesn't have write permission. The volume owner is root.

This is the entry in fstab:

UUID=4844D36844D35772 /media/sda6 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

It is OK to give everyone write permission by default.
ForeverNoob
Level 1
Level 1
 
Posts: 19
Joined: Mon Aug 13, 2007 11:06 am

Postby ForeverNoob on Sat Aug 18, 2007 9:04 am

Problem solved. It wasn't a permission thing, all I had to do was to enable write support in the NTFS configuration tool.

Thanks
ForeverNoob
Level 1
Level 1
 
Posts: 19
Joined: Mon Aug 13, 2007 11:06 am

Postby Husse on Sun Aug 19, 2007 11:27 am

all I had to do was to enable write support in the NTFS configuration tool
That is a permission thing :)
It changes the permissions of that disk
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby clem on Sun Aug 19, 2007 2:29 pm

To be precise it's a not a permission problem but a mount options one.

Clem
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5580
Joined: Wed Nov 15, 2006 8:34 am

Postby Husse on Mon Aug 20, 2007 4:49 am

Oh Clem....
It mounts the disk in a place where you have permissions, would that be the proper description? :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Patrissimo on Sun Aug 26, 2007 10:39 pm

I have a second hard drive in my computer. It has 2 partitions. the first one (hdb1) was formatted in fat32. I used the partition editor to change it to ntfs last night.
Now the desktop icon for hdb1 is gone and I can only access it thru sudo nautilus. I do have some kind of new disk icon on my desktop, labelled "disk." When I open it I just get a "lost and found" file
I tried changing the permissions for hdb1 under "properties," but they are just the same as my other partition (hdb5).
I tried the ntfs configuration tool, but it only offers me the option to enable write support to an external device.
I would like to have hdb1 behave like it did when I installed Mint, what can I do?
I'm very noob, and I've tried some of the suggestions I've found here, but I'm stuck.
Patrissimo
Level 1
Level 1
 
Posts: 17
Joined: Thu Mar 01, 2007 9:08 am

Postby Patrissimo on Mon Aug 27, 2007 12:04 am

I went into Mintdisk and changed the mount point to hdb1, restarted, and sure enough, hdb1 was there on the desktop. But hdb5 was gone.
So I went back and restored it to <<DEVICE>>, restarted, and I have only hdb5 again.
Is there something I can enter after /media/ in the mount point box that will get me both drives?
Patrissimo
Level 1
Level 1
 
Posts: 17
Joined: Thu Mar 01, 2007 9:08 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: egolatra, Mute Ant and 31 guests