Video Card

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Video Card

Postby kenwood1995 on Sat Aug 18, 2007 3:55 pm

Because of experience, I am still here in the "newbie".
I was using an ATI 128mb video card, but I removed it because of noise on my Ham radio receiver, and replaced it with an Nvidia GEForce FX5200 128mb card and run the "dpkg-reconfigure xserver-xorg"
and all seems to work OK, but Google Earth wont start.
What did I do wrong?
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Linux Mint is funded by ads and donations.
 

Postby nick on Sat Aug 18, 2007 4:44 pm

Hi

Not sure if you done anything wrong, had trouble with one Nvidia card and Google Earth ( black patches)

Removed Google Earth and now put in latest and is 100%

Not sure what Google earth is "seeing" has it configured itself for your previous ATI card?

Try completly removing Google Earth and re-installing. Dont forget to delete the .Googleearth file
(Files/View/Show hidden)

(Now can I go back to RDA ssb contest and work some Russians stations on 80m :) )

Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby kenwood1995 on Sat Aug 18, 2007 6:33 pm

Go for it Good Luck
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Postby kenwood1995 on Sat Aug 18, 2007 8:45 pm

Well I done it now.
I downloaded and run a driver from Nvidia and now I can't get a graphical display with either video card.
I think I remember seeing something when the Nvidia setup was running, about a new kernel, whatever that means.
Anyway, I'm here in ugh (MS) now.
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Postby nick on Sun Aug 19, 2007 4:13 am

Hi


I think I remember seeing something when the Nvidia setup was running, about a new kernel, whatever that means.


Each time you get a new kernel you will usually have set up 3d drivers again.

At text interface try "sudo envy -t"
see what it says ( leave Nvidia card in) uninstall any drivers indicated, if no drivers are indicated "install Nvidia"
then "sudo dpkg-reconfigure xserver-xorg" again.

If you installed Nvidia without envy uninstall the Nvidia that way, the repeat above.

Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby scorp123 on Sun Aug 19, 2007 6:01 am

nick wrote:Each time you get a new kernel you will usually have set up 3d drivers again.
Yes, because the driver needs to hook-up with the kernel. As soon as you touch the kernel e.g. by upgrading or re-compiling it, those hooks are gone and you need to re-install e.g. the Nvidia drivers. What happens during driver installation (if you don't do this manually that is) is that the needed Nvidia modules are compiled again against the kernel; and from there on it should work (again) ... until the next kernel update.
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby kenwood1995 on Sun Aug 19, 2007 8:08 am

OK here's where I am now.
I tried the "sudo envy -t" and got a list.
Number 1 on the list was "install nvidia"
I selected that and hit enter, as asked
A lot happened, then I did "sudo dpkg-reconfigure xserver-xorg"
Now I have my graphical display.
Thank you.
Now I will do a fresh install of Google Earth, my original problem, and see if it works?
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Postby kenwood1995 on Mon Aug 20, 2007 9:20 am

Installed Google Earth from the packages and it doesn't work.
The Google Earth splash screen comes up and then disappears in about 2 seconds.
If I go in a terminal and try to run it, I get a very long page of stuff that I don't understand and then at the bottom it says there is a bug in the program and will send an error report the next time Google Earth is started.
This is with using the NVIDIA card.
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Postby tseliot on Tue Aug 21, 2007 9:10 am

kenwood1995 wrote:A lot happened, then I did "sudo dpkg-reconfigure xserver-xorg"

why?

can you post your /etc/X11/xorg.conf ?
tseliot
Level 1
Level 1
 
Posts: 43
Joined: Wed Feb 07, 2007 6:55 am

Postby kenwood1995 on Tue Aug 21, 2007 12:18 pm

That seems the only way I can get a graphical display.
Been doing a lot of foolin around with this.
I am now using the ATI card, and hopefully here is what you asked for, the xorg.conf.

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "int10"
Load "vbe"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "ATI Technologies Inc Radeon R250 [Mobility FireGL 9000]"
Driver "vesa"
BusID "PCI:1:0:0"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "17LCDMONITO"
Option "DPMS"
HorizSync 28-64
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon R250 [Mobility FireGL 9000]"
Monitor "17LCDMONITO"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Postby nick on Tue Aug 21, 2007 3:28 pm

Hi

Did you delete the .Googleearth file before installing new one?

Files/view/Show hidden if not try deleting it now, and try again

Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby Lolo Uila on Tue Aug 21, 2007 5:01 pm

You are currently running the "Vesa" graphics driver, which is safe, but the slowest, ugliest, most limited driver available. Your ATI card is fully supported under the open-source driver and that's what you should be using. To configure your ATI card, do the following:
Code: Select all
sudo modprobe -r fglrx
sudo apt-get remove xorg-driver-fglrx; sudo apt-get install libgl1-mesa-glx libgl1-mesa-dri

This will remove the proprietary ATI driver and install the open-source ATI driver. Then you have to edit xorg.conf to enable the driver:
Code: Select all
sudo gedit /etc/X11/xorg.conf

Look in your xorg.conf for this section:
Code: Select all
Section "Device"
Identifier "ATI Technologies Inc Radeon R250 [Mobility FireGL 9000]"
Driver "vesa"
BusID "PCI:1:0:0"
Option "UseFBDev" "true"
EndSection

Change the "vesa" to "radeon" and delete Option "UseFBDev" "true" so it looks like this:
Code: Select all
Section "Device"
Identifier "ATI Technologies Inc Radeon R250 [Mobility FireGL 9000]"
Driver "radeon"
BusID "PCI:1:0:0"
EndSection

Save the file and exit any running applications, then restart the xserver [Contrl]+[Alt]+[Backspace].

Now lets see if the changes are working:
Code: Select all
glxinfo | grep vendor

Should show you this:

server glx vendor string: SGI
client glx vendor string: SGI
OpenGL vendor string: Tungsten Graphics, Inc.


And:
Code: Select all
glxinfo | grep "direct rendering"

Should say direct rendering: yes.

If you get the above responses then you are running the proper open-source ATI driver and things like Beryl and Google Earth should work (if they are installed correctly).

You might also want to delete the following section from your xorg.conf:

SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection


So that only the Depth 24 section remains and your "screen" section looks like this:

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon R250 [Mobility FireGL 9000]"
Monitor "17LCDMONITO"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection


Note that any changes to the xorg.conf file require restarting the xserver before they will take affect.

Good luck!

Aloha, Tim
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Postby kenwood1995 on Tue Aug 21, 2007 7:56 pm

Here's what happened.

On your first Code:
Nothing was done as it says that those two items, "libgl1-mesa-glx"
and "libgl1-mesa-dri" are already installed.

Next Code:
Changed driver to "radeon" and deleted "UseFBDev" "true"

Restarted xserver.

Code:
"glxinfo | grep vendor"
The result was:
"Xlib: extension "GLX" missing on display "0.0"
"Error couldn't find RGB GLX visual"

Code:
"glxinfo | "direct rendering"
The result was same as above.
kenwood1995
Level 1
Level 1
 
Posts: 39
Joined: Thu Apr 05, 2007 9:33 am

Postby Lolo Uila on Wed Aug 22, 2007 2:03 am

That's odd... sounds like something is screwy with your Linux install (or at least your video drivers).

I went through your xorg.conf again and compared it to mine and the only difference (besides the name of your video card and monitor) is a missing Load "i2c" under, Section "Module" and I'm pretty certain that module is related to the motherboard and not the video card.

You could try put "ati" where I told you to put "radeon" before, although I doubt that will make a difference.

Only other suggestion I have at this point (short of a complete reload) is to reinstall the open-source video drivers. Find them in synaptic and mark them for reinstall.

Aloha, Tim
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: postan and 38 guests