Updating

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Updating

Postby jdtexas on Tue Aug 21, 2007 10:46 pm

I am very new to Linux. Mint worked great for a while, but now when notified of available updates, I receive this message when the updater tries to retreive the packages:
W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... 1_i386.deb
Could not connect to localhost:4001 (127.0.0.1). - connect (111 Connection refused)
Not sure what to do. Any help would be greatly appreciated.
jdtexas
Level 1
Level 1
 
Posts: 2
Joined: Tue Aug 21, 2007 10:37 pm

Linux Mint is funded by ads and donations.
 

Postby Boo on Tue Aug 21, 2007 10:57 pm

Can you install applications via synaptic?

do you have a firewall setup on the pc?
the message is saying that it can not connect to port 4001 on your computer.
turn off the firewall and see if it works then.

what happens if you untick the rsync package in the updater and do an update?

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Re: Updating

Postby scorp123 on Wed Aug 22, 2007 4:20 pm

jdtexas wrote: Could not connect to localhost:4001 (127.0.0.1). - connect (111 Connection refused)
Could it be that you used your own host (= 127.0.0.1) as proxy somehow?
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Updating

Postby jdtexas on Wed Aug 22, 2007 9:13 pm

Thanks for the suggestions, but no go so far.

I disabled the firewall. Made no difference. I tried the Synaptic package handler. It gives the same error message the updater displays. I checked to see if the 127.0.0.1 address was listed as a proxy. It was. I deleted it but still it will not work. I am sure there is some crucial piece I am leaving out. I am using a wireless connection at home, a wired connection at work. Results are the same for both places.
I unchecked the rsync package, but still the same results. Getting frustrated!
jdtexas
Level 1
Level 1
 
Posts: 2
Joined: Tue Aug 21, 2007 10:37 pm

Re: Updating

Postby scorp123 on Thu Aug 23, 2007 4:07 am

jdtexas wrote:I checked to see if the 127.0.0.1 address was listed as a proxy. It was. I deleted it
So if you used your own host as a proxy so maybe you also used some sort of proxy process somewhere somehow in the past? e.g. 'squid' or something like that?

As I see it your problem is this:

For reasons you did not state yet you configured your own machine as proxy and you had it running on port 4001; hence all the package managers accessed their repos via this host:port combination. But now: Somehow you stopped the proxy from working, e.g. either by reconfiguring it or by removing it from your system. But your package managers are still pointing at the --now defunct-- proxy, hence you get this error message: "Could not connect to localhost:4001 (127.0.0.1). - connect (111 Connection refused)"

So as I see it you have to completely remove any remaining references to the proxy and access the repos (and everything else?) directly. Then it should work.
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Distro-Don, Google Adsense [Bot], Mute Ant, roger25118, sjr and 28 guests