need help

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

need help

Postby darkernights on Thu Aug 23, 2007 1:13 am

I just installed mint on my laptop and was trying to install drivers for my video card, after reboot it says something about window x not loading. now all i get is command prompt. is there any way to undo what i did?
darkernights
Level 1
Level 1
 
Posts: 5
Joined: Thu Aug 23, 2007 1:11 am

Linux Mint is funded by ads and donations.
 

Postby pulsta on Thu Aug 23, 2007 4:52 am

Hi there,

Yup I've done this myself only recently and the solution is quite simple...but only if there are backups of the X config. file.

at the terminal prompt type:

cd /etc/X11


now type:

ls -l


and you will see a bunch of files...the file we are interested in is xorg.conf

or more importantly other backup versions of xorg.conf that you can find there...are there any??

if so its just a matter of renaming the backup file to xorg.conf overwriting the bad one you had there...and your done.

I'm only a learner myself but hopefully this will point you in the right direction...If not then someone more 'senior' can chime in.

Cheers

Kerry


[/b]
pulsta
Level 1
Level 1
 
Posts: 5
Joined: Wed Aug 01, 2007 4:13 am

Postby Husse on Thu Aug 23, 2007 5:08 am

Welcome to Mint darkernights
Boot in recovery mode and then try
Code: Select all
dpkg-reconfigure -phigh xserver-xorg

This command needs sudo, but you are already root in recovery mode. Leave the TTY by typing exit. If you end up in the destop reboot immediately as you are root.
If that does not help use the vesa driver as an intermediate solution until you find out which driver you should use. Instructions for how to do that here
http://www.linuxmint.com/wiki/index.php ... ms_as_well
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby darkernights on Thu Aug 23, 2007 1:10 pm

Husse,

thanks for the welcome, and the fix worked perfectly.
darkernights
Level 1
Level 1
 
Posts: 5
Joined: Thu Aug 23, 2007 1:11 am

Postby Adler on Tue Aug 28, 2007 4:58 pm

Welcome to Mint darkernights


Husse,

Good one! Video Drivers have caused me a few Xorg problems in the past. LOL!

Adler
User avatar
Adler
Level 4
Level 4
 
Posts: 363
Joined: Mon Jan 01, 2007 9:29 pm
Location: Wilwood, New Jersrey


Return to Newbie Questions

Who is online

Users browsing this forum: karlchen, Trio3b and 20 guests