Change of desktop workspace switching

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Change of desktop workspace switching

Postby oldal on Sun Jul 04, 2010 2:06 am

Hi,

I want a simple desktop switching between my 4 desktop workspaces. By right clicking on the bottom panel I've added the Wall type workspace switch. It is very nice - I like it a lot. I want the workspace switching to take place when I click on the Wall workspace switch and not by any other method.

Currently when the mouse pointer is very close to the side, the workspace flips to the next one. How do I get rid of this behaviour now that I have a nice workspace switch on the bottom panel?

Thank you for your patience and your help.

I am using a freshly installed linuxmint 9, a 32 bit OS, a 64 bit amd64 processor and an inexpensive video card.

OldAl.
---
OldAl - in Canberra, the capital of Australia
User avatar
oldal
Level 1
Level 1
 
Posts: 26
Joined: Sat Jul 03, 2010 1:35 am
Location: Canberra, Australia

Linux Mint is funded by ads and donations.
 

Re: Change of desktop workspace switching

Postby gn2 on Sun Jul 04, 2010 4:49 am

One way is to right-click on the desktop, click "Change Desktop Background" then "Visual Effects" then select "None".

There's probably another way which allows retention of the other (i.m.o. annoying) effects but I'm afraid I don't know how.

One way to switch desktops is Ctrl + Alt + Left or Right arrow
User avatar
gn2
Level 5
Level 5
 
Posts: 893
Joined: Mon Nov 30, 2009 5:54 am
Location: Bonnie Scotland

Re: Change of desktop workspace switching

Postby Old Marcus on Sun Jul 04, 2010 3:33 pm

Go to the Menu, go to Preferences, then Compiz Config Settings Manager.

Here, in the Desktop section, select desktop wall and in the window that appears, select the Bindings tab. Here you can change what actions make the viewport switch happen. Expand the 'Move within Wall' option, and on the move left and move right options, change them to 'Disabled'. This will stop the workspace switching when you move your mouse to the edge of the screen.

Any problems, feel free to reply. :)
Linux Mint 8 RC1 = Nice
'apt install' can be used on Linux Mint as a shortcut for 'sudo apt-get install'. 'apt x' can be used for various other apt commands as well.
When a problem is solved, please add [SOLVED] to your thread title.
User avatar
Old Marcus
Level 4
Level 4
 
Posts: 395
Joined: Sun Jun 08, 2008 4:51 pm
Location: Exeter, UK

Re: Change of desktop workspace switching

Postby eejd on Mon Jul 05, 2010 12:44 am

Ctrl - Alt - arrow does not work for me; perhaps conflicting / interfering with ibus set up? For now, I just mouse-click on the desktop to get there.

In any event, is there a way to reassign the key combo to change Desktops? How about Alt-N where N is the number of the desktop.

Also, I don't know how to use the Desktop Cube / Rotate / Desktop Wall. Once you enable them, how do you invoke their function?

Thanks for your help.
eejd
Level 1
Level 1
 
Posts: 21
Joined: Sun Nov 01, 2009 1:03 am

Re:[solved] Change of desktop workspace switching

Postby oldal on Mon Jul 05, 2010 2:14 am

Old Marcus wrote:Go to the Menu, go to Preferences, then Compiz Config Settings Manager.
Here, in the Desktop section, select desktop wall and in the window that appears, select the Bindings tab. Here you can change what actions make the viewport switch happen. Expand the 'Move within Wall' option, and on the move left and move right options, change them to 'Disabled'. This will stop the workspace switching when you move your mouse to the edge of the screen.


Thank you for the accurate description, Marcus. I followed you advice and disabled switching. The workspaces now are switched by clicking on the small workspace display that I am used to. BTW, the workspace display on the bottom tool bar is rather nice, as it clearly indicates visually what is open within each workspace.

Great advice, promptly given accurate information! Thanks for other replies, too. Good try - greatly appreciated.

OldAl.
---
OldAl - in Canberra, the capital of Australia
User avatar
oldal
Level 1
Level 1
 
Posts: 26
Joined: Sat Jul 03, 2010 1:35 am
Location: Canberra, Australia

Re: Change of desktop workspace switching

Postby hamhamt on Mon Sep 23, 2013 1:27 pm

for anyone having this problem (like myself) still in the newest version of linux mint (olivia)

System Settings --> Windows --> Enable Edge Flip

accomplishes the same feat
hamhamt
Level 1
Level 1
 
Posts: 4
Joined: Fri Aug 09, 2013 2:32 pm


Return to Newbie Questions

Who is online

Users browsing this forum: norm.h and 29 guests