ATI drivers freak problem

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

ATI drivers freak problem

Postby NiksaVel on Mon Sep 10, 2007 2:27 am

Hey all... I am trying to help a buddy of mine install ATI drivers, but it's not really working out... we used Envy to install it... xorg.conf checks out okay, but fglrxinfo still reports mesa is being used... :/// whaaaat to doooo?

here's the xorg.conf:

Code: Select all
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
       FontPath        "/usr/share/fonts/X11/misc"
       FontPath        "/usr/share/fonts/X11/cyrillic"
       FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
       FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
       FontPath        "/usr/share/fonts/X11/Type1"
       FontPath        "/usr/share/fonts/X11/100dpi"
       FontPath        "/usr/share/fonts/X11/75dpi"
       # path to defoma fonts
       FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
       Load    "i2c"
       Load    "bitmap"
       Load    "ddc"
       Load    "dri"
       Load    "extmod"
       Load    "freetype"
       Load    "glx"
       Load    "int10"
       Load    "vbe"
EndSection

Section "InputDevice"
       Identifier      "Generic Keyboard"
       Driver          "kbd"
       Option          "CoreKeyboard"
       Option          "XkbRules"      "xorg"
       Option          "XkbModel"      "pc105"
       Option          "XkbLayout"     "us"
       Option          "XkbOptions"    "lv3:ralt_switch"
EndSection

Section "InputDevice"
       Identifier      "Configured Mouse"
       Driver          "mouse"
       Option          "CorePointer"
       Option          "Device"                "/dev/input/mice"
       Option          "Protocol"              "ImPS/2"
       Option          "ZAxisMapping"          "4 5"
       Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
       Driver          "wacom"
       Identifier      "stylus"
       Option          "Device"        "/dev/input/wacom"
       Option          "Type"          "stylus"
       Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "InputDevice"
       Driver          "wacom"
       Identifier      "eraser"
       Option          "Device"        "/dev/input/wacom"
       Option          "Type"          "eraser"
       Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "InputDevice"
       Driver          "wacom"
       Identifier      "cursor"
       Option          "Device"        "/dev/input/wacom"
       Option          "Type"          "cursor"
       Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "Device"
       Identifier      "ATI Technologies Inc RV350 AS [Radeon 9550]"
       Driver  "fglrx"
       Option  "VideoOverlay" "on"
       Option  "OpenGLOverlay" "off"
       BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
       Identifier      "C994"
       Option          "DPMS"
EndSection

Section "Screen"
       Identifier      "Default Screen"
       Device          "ATI Technologies Inc RV350 AS [Radeon 9550]"
       Monitor         "C994"
       DefaultDepth    24
       SubSection "Display"
               Depth           1
               Modes           "1280x1024" "1024x768" "800x600" "720x400" "640x480"
       EndSubSection
       SubSection "Display"
               Depth           4
               Modes           "1280x1024" "1024x768" "800x600" "720x400" "640x480"
       EndSubSection
       SubSection "Display"
               Depth           8
               Modes           "1280x1024" "1024x768" "800x600" "720x400" "640x480"
       EndSubSection
       SubSection "Display"
               Depth           15
               Modes           "1280x1024" "1024x768" "800x600" "720x400" "640x480"
       EndSubSection
       SubSection "Display"
               Depth           16
               Modes           "1280x1024" "1024x768" "800x600" "720x400" "640x480"
       EndSubSection
       SubSection "Display"
               Depth           24
               Modes           "1280x1024" "1024x768" "800x600" "720x400" "640x480"
       EndSubSection
EndSection

Section "ServerLayout"
       Identifier      "Default Layout"
       Screen          "Default Screen"
       InputDevice     "Generic Keyboard"
       InputDevice     "Configured Mouse"
       InputDevice     "stylus"        "SendCoreEvents"
       InputDevice     "cursor"        "SendCoreEvents"
       InputDevice     "eraser"        "SendCoreEvents"
EndSection

Section "DRI"
       Mode    0666
EndSection





Section "Extensions"
       Option "Composite" "Disable"
EndSection
Windows is extremely fast after a fresh install. If you want to make it stay that way: - don't use it.
-Clem
User avatar
NiksaVel
Level 5
Level 5
 
Posts: 806
Joined: Wed Feb 28, 2007 4:06 am
Location: Croatia

Linux Mint is funded by ads and donations.
 

Postby Lolo Uila on Mon Sep 10, 2007 9:47 pm

That is odd. Your xorg file seems to be configured correctly?

You could try something like:

Code: Select all
sudo apt-get remove libgl1-mesa-glx libgl1-mesa-dri; sudo apt-get install xorg-driver-fglrx


to have only the fglrx driver installed. Or you could use synaptic to do the same thing, and do a complete removal of mesa to purge any other configuration files. From what I can see of your xorg.conf you should be running fglrx.

Don't forget to restart X after any changes.
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Postby NiksaVel on Wed Sep 12, 2007 4:17 am

yes... everything SHOULD be working properly :D


btw... it's ATI 9550 card... if that means anything to any1...
Windows is extremely fast after a fresh install. If you want to make it stay that way: - don't use it.
-Clem
User avatar
NiksaVel
Level 5
Level 5
 
Posts: 806
Joined: Wed Feb 28, 2007 4:06 am
Location: Croatia

Postby oedenfield on Wed Sep 12, 2007 2:09 pm

Similarly I have a Radeon 9250 and with the livecd it was detected as a 9200 and used the "legacy" driver.

Once installed Mint now uses a Mesa driver.

I have no idea why.
oedenfield
Level 1
Level 1
 
Posts: 15
Joined: Wed Sep 12, 2007 1:40 pm

Postby Lolo Uila on Sat Sep 22, 2007 8:19 am

Which version of Mint are you trying to install the ATI driver on?
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Postby oedenfield on Sat Sep 22, 2007 9:12 am

I've been using Cassandra KDE Community Edition
oedenfield
Level 1
Level 1
 
Posts: 15
Joined: Wed Sep 12, 2007 1:40 pm

Postby Lolo Uila on Sun Sep 23, 2007 4:13 pm

oedenfield,

mesa is the name of the default Linux driver system. Look in your /etc/X11/xorg.conf file and see what the "device" section says. If it identifies your card correctly and says the driver is "ati" or "radeon" then you are okay. If it says "vesa" then look at the link below for info on getting it running right.

http://www.howtoforge.com/ubuntu_feisty ... ati_radeon

NiksaVel,

The 9550 should work well with the default open-source driver. See the link above for info on getting dri working under the open-source driver.

I have run both the open-source driver and the ATI binary driver with various ATI cards up to the X800 XT PE and both worked well, but the ATI driver was always more trouble to get working properly (usually a LOT more trouble). I have been trying to get it working on my X1950 for over a week and I'm getting nowhere. I've tried every trick I know, and every trick I can find on various forums and guides and it just won't work. I either get the mesa driver, or a hard locked computer with a black screen. Unfortunately the X1k series cards are not supported by the open-source driver so I'm kind of stuck at this point. EDIT: I did get it working. The newer drivers from ATI wouldn't work, but the one in the Ubuntu repository did.

Anyway, good luck with your ATI adventures. Hope you get it working.

Aloha, Tim
Last edited by Lolo Uila on Sun Oct 21, 2007 4:33 pm, edited 2 times in total.
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Postby nuno_nunes on Sat Oct 20, 2007 12:31 pm

Tank you...

I a very problems for configure this a ATI Radeon 9250 with 256 Mb
User avatar
nuno_nunes
Level 1
Level 1
 
Posts: 37
Joined: Sun Oct 14, 2007 4:30 pm
Location: Portugal

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: colyn, WharfRat and 23 guests