bash environment variable tab completion

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

bash environment variable tab completion

Postby droggo on Mon Oct 15, 2007 12:34 pm

With a default install of Mint, the bash shell tab completion is escaping the $ character. For instance, I have a directory /opt/foo and have exported FOO=/opt/foo. When I try to get to the directory using the command: cd $F then hit tab, I get the command: cd \$FOO

Can anyone tell me what to change in order to disable the escaping of the $ ? I know this is possible using bash, because neither my Gentoo nor my Fedora boxes do it.

Thanks in advance =)
droggo
Level 1
Level 1
 
Posts: 1
Joined: Mon Oct 15, 2007 12:26 pm

Linux Mint is funded by ads and donations.
 

Postby Husse on Wed Oct 17, 2007 5:48 am

would cd F do it?
bash is controlled by some hidden files in your home folder and files in /etc/bash_completion.d and /etc proper
I don't have the time to check in on that. The normal prompt is called PS1 in these files - perhaps you find it if you look around
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Pierre, SandsOfArrakis and 31 guests