monodevelop

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

monodevelop

Postby karl on Fri Oct 26, 2007 2:44 pm

Hello everybody,

I installed monodevelop but was not able to run any programs, I googled the cause of the problem and it seems it was a bug which had been fixed in newer versions, so I am now trying to install the latest, However, I get the following error:

Code: Select all
checking for UNMANAGED_DEPENDENCIES_MONO... checking for UNMANAGED_DEPENDENCIES_MINT... configure: error: Please install mono version 1.1.10 or later to install MonoDevelop.
Please see http://www.mono-project.org/ to download latest mono sources or packages


Seems quite straightforward. But then i did /usr/bin/mono -V, which gave me:

Code: Select all
karl@desktop:~/monodevelop-0.16$ /usr/bin/mono -V
Mono JIT compiler version 1.2.3.1, (C) 2002-2006 Novell, Inc and Contributors. w

So I have a later version than 1.1.10.

Can anyone help me install this, please?

TIA
karl
Level 1
Level 1
 
Posts: 20
Joined: Tue Oct 02, 2007 3:36 pm
Location: Torquay, Devon, England

Linux Mint is funded by ads and donations.
 

Postby Husse on Sat Oct 27, 2007 7:16 am

I think you should try the mono pages for this
The only thing I can see is that it you have
Mono JIT

Maybe there is Mono JIT and just Mono?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby karl on Sun Oct 28, 2007 7:49 am

Thanks for the response.

I'm pretty sure I have the correct application. What (or where) are mono pages, please?

A few hours of googling and I have managed to get past the error, in my OP.

I now have a new one :oops:

Code: Select all
checking for GLIB_SHARP... Requested 'glib-sharp-2.0 >= 2.8.0' but version of GLib is 2.4.0
configure: error: Package requirements (glib-sharp-2.0 >= 2.8.0) were not met:


Can I update glib? If so, how would I do this?

Thanks.
karl
Level 1
Level 1
 
Posts: 20
Joined: Tue Oct 02, 2007 3:36 pm
Location: Torquay, Devon, England

Postby Husse on Sun Oct 28, 2007 2:50 pm

Mono pages
http://www.mono-project.com/
the number one hit if you google for mono
This is really hard to find something about.
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby karl on Sun Oct 28, 2007 5:04 pm

Sorry,

When you said "pages" I didn't realise you meant "website". I've been there, but can't find the solution.
karl
Level 1
Level 1
 
Posts: 20
Joined: Tue Oct 02, 2007 3:36 pm
Location: Torquay, Devon, England

Postby Husse on Mon Oct 29, 2007 7:39 pm

My error - it's so boring to use the same expression over and over again :lol:
This is not something I know anything about (well.....)
Does not ring any bells and I still think the mono site should be the place :shock:
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby karl on Tue Oct 30, 2007 3:31 pm

Yeah, I probably could have interpreted the correct meaning from your post - if my brain wasn't overloaded with this :oops:

I'll keep looking, but in the mean time use emacs/CLI.

Cheers
karl
Level 1
Level 1
 
Posts: 20
Joined: Tue Oct 02, 2007 3:36 pm
Location: Torquay, Devon, England

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot] and 28 guests