sound problems

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

sound problems

Postby gjclt on Sun Oct 28, 2007 7:41 am

I installed Mint yesterday. I have loads of midi files but can't get them to play. Tried Audacity. Also downloaded Rosegarden but am told it does not work. Any suggestions?
gjclt
Level 1
Level 1
 
Posts: 4
Joined: Sat Oct 27, 2007 11:31 am

Linux Mint is funded by ads and donations.
 

Postby nick on Sun Oct 28, 2007 7:51 am

Hi

Maybe this will help?

HOWTO: Getting MIDI to work fully in Ubuntu

http://ubuntuforums.org/showthread.php?t=8736

Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby gjclt on Mon Oct 29, 2007 3:37 pm

Thanks. I now have Midi working, but the quality is not very good. Will have to experiment. Rosegarden does not work. Message says that system timer resolution is to low. No idea what that means.
gjclt
Level 1
Level 1
 
Posts: 4
Joined: Sat Oct 27, 2007 11:31 am

Postby nick on Mon Oct 29, 2007 3:51 pm

Hi

5.6. What does "System timer resolution is too low" mean?
If you see this message in an error dialog when Rosegarden starts up, then you are probably using a Linux kernel that doesn't offer sufficiently high-resolution system timers for MIDI use.
Rosegarden uses ALSA sequencer queue scheduling (inside the Linux kernel) for its MIDI output. The sequencer queue can use a variety of timing sources, of which the default is the kernel system timer. The kernel system timer was 1000 Hz in Linux 2.6 kernels up to 2.6.12, but as of 2.6.13 it's now 250 Hz in mainline kernels. This is not good enough for good MIDI timing.
Your options are:
Switch the sequencer to use a different timing source (Settings -> Configure Rosegarden... -> Sequencer -> Synchronisation). The best one in theory is the RTC timer, which is only available if you have snd-rtctimer loaded, but unfortunately that has a habit of totally locking systems running real-time kernels. Meanwhile, the PCM timers only work if the JACK audio server is running, and suffer jitter corresponding to the JACK buffer size.
Recompile your kernel with system timer set to 1000 Hz. Sadly there's no way to change this without a recompile. It's the best solution though.
Switch to a different Linux distribution that provides a kernel more appropriate for multimedia use.
Put up with the poorer timing of a 250 Hz timer (if you want to get rid of the warning while continuing to use this timer, set the timer source to "system timer" rather than "(auto)").

http://www.rosegardenmusic.com/resources/faq/#toc31

Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], s2s and 25 guests