I am such a Newbie...

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

I am such a Newbie...

Postby SandMan on Sun Oct 28, 2007 11:17 am

Hi.

First of all, my system consists of the following:
P4 CPU, X1950Pro 256mbRAM,2GB DDR
I appologise for poor english skills in this post.. :oops:
-and also if these problems are described in other threads. I havne not been ale to find this specific problem in my searches.

1. My first roblem occurs when installing fro the Live CD. I can not boot the CD without using the boot option: "boot: live acpi=off". If I do not use this boot option the loading stops and the text says something about hardware hald... and that graphics mode is only supperted on intel chips.. Is this coused by my motherboard beeing about 4,5 years old, bios or what?

2. When boot is done, and installation is done I followed the guide in this tread:

http://linuxmint.com/forum/viewtopic.php?t=6207

When rebooting the screen goes blank and my monitor reports that "Mode not supported". My screen is able to run with 1280x1024 resolutin at 60 Hz. What can I do to fix the problem and how to install the drivers correctly?

I hope someone can help me out.. -Sick and tired of MS-slavery...
SandMan
Level 1
Level 1
 
Posts: 3
Joined: Sun Oct 28, 2007 11:01 am
Location: Tromsoe - Northern Norway

Linux Mint is funded by ads and donations.
 

Postby linuxviolin on Sun Oct 28, 2007 11:32 am

Hi SandMan! Welcome!

For the problem with your resolution try to boot with the liveCD then go to your hard disk to modify your /etc/X11/xorg.conf file with your resolution and change the driver section with 'nv'.
Also you should be able to modify the lines HorizSync and VertRefresh with the specifications of your monitor. Then reboot from your hard disk.

With this you will use the generic driver but at least you should be able to use Mint. :D

Hope that solve this problem.
K.I.S.S. ===> "Keep It Simple, Stupid"
"Simplicity is the ultimate sophistication." (Leonardo da Vinci)
"Everything should be made as simple as possible, but no simpler." (Albert Einstein)
User avatar
linuxviolin
Level 8
Level 8
 
Posts: 2055
Joined: Tue Feb 27, 2007 6:55 pm
Location: France

Postby SandMan on Sun Oct 28, 2007 12:52 pm

Thanks for the reply. :D

The solution would probably have corrected my problem, but seeing that I am such a Newbie I managed to screw the Xorg.Conf file up completely. Since the ATI driver installeation was the first thing I did I am now reinstalling MINT. :wink:

However I would still like to use a proper driver for my ATI-card, and run Beryl in a good manor.. Anyone who can help me specify why the earlier mentioned guide did not work for me?

And ACPI=off, is it OK to keep running the system in this mode?
SandMan
Level 1
Level 1
 
Posts: 3
Joined: Sun Oct 28, 2007 11:01 am
Location: Tromsoe - Northern Norway

Postby Lolo Uila on Sun Oct 28, 2007 5:52 pm

Even if the GUI (desktop) doesn't boot you can boot into recovery mode and edit the xorg.conf file with nano.

Anyway... once you're reloaded and booted into the Mint desktop, try it again, but before you do anything at all execute the following command (from a terminal):

Code: Select all
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup


If you have problems booting after installing the ATI driver, boot into recovery mode from the grub boot menu; log in to the command shell, and enter the command:

Code: Select all
sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

which will restore the default file and let you reboot into GNOME.

Now, when you are installing the ATI driver and editing your xorg.conf file, also look for this section:

Code: Select all
SubSection "Display"
   Depth      24
EndSubSection

and add a Modes line, like this:
Code: Select all
SubSection "Display"
   Depth      24
   Modes      "1280x1024"
EndSubSection


And, if you know the spec's on your monitor, you can add them as well. Look for the section that identifies your monitor and add these lines below the Option "DPMS" entry:

Code: Select all
   Option      "DPMS"
   HorizSync   28-80 # substitute YOUR monitor's spec's here !!
   VertRefresh   48-75 # and here...


Once you are done installing fglrx and editing xorg.conf, save your changes, but before you reboot do this:

Code: Select all
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.ati

Which will make a copy of your edited xorg file. Then if you need further help you can post that here for us to take a look at. Hopefully the changes above will get you going though. I also recently posted a message about using Synaptic to install the fglrx driver, which can be found here (my 2nd post in the thread):
http://linuxmint.com/forum/viewtopic.php?t=6262

If you're more comfortable using Synaptic you could give that a try.

And finally; you can also edit the xorg.conf file from recovery mode with the nano text editor. From the recovery command shell, enter:

Code: Select all
sudo nano /etc/X11/xorg.conf


This is a non-graphical editor. All cursor controls and keyboard (no mouse). The easiest fix for a non-booting system is to simply change Driver "fglrx" to Driver "vesa" then hit CONTROL+X then Y Enter to save the file.

Good luck!

Aloha, Tim
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Postby SandMan on Mon Oct 29, 2007 12:17 pm

Thank you very much! This worked perfectly.
SandMan
Level 1
Level 1
 
Posts: 3
Joined: Sun Oct 28, 2007 11:01 am
Location: Tromsoe - Northern Norway


Return to Newbie Questions

Who is online

Users browsing this forum: adf2000, b1g3ar5 and 29 guests