Can't run Package Manager anymore

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Can't run Package Manager anymore

Postby fachrevi on Wed Nov 21, 2007 10:33 pm

I have a message event running Package Manager : "E: The package virtualbox need to reinstalled, but I can't find an archive for it". the followed message caused the installation virtual box in my linuxmint I force to quit.
How to fixed this problem ? thank's.
fachrevi
Level 1
Level 1
 
Posts: 4
Joined: Wed Nov 21, 2007 9:34 pm

Linux Mint is funded by ads and donations.
 

Re: Can't run Package Manager anymore

Postby Boo on Thu Nov 22, 2007 1:38 am

can you see virtualbox using synaptic?
can you post your /etc/apt/sources.list
you could try using the software portal (mintInstall) to install it.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Re: Can't run Package Manager anymore

Postby fachrevi on Thu Nov 22, 2007 3:45 am

After I trying using portal (mintinstall), I can see virtualbox in synaptic list (were mintinstall progress but the progress always standing on about 50%, never completed).
I mark the list to remove then the message followed tell "E: virtualbox: Package is in a very bad inconsistent state - you should".
I also try to upgrade then the message followed tell "can't be authenticated". Please.. :cry: :cry: :cry: help :!:
fachrevi
Level 1
Level 1
 
Posts: 4
Joined: Wed Nov 21, 2007 9:34 pm

Re: Can't run Package Manager anymore

Postby Boo on Thu Nov 22, 2007 7:17 pm

try to purge virtual box first then install again.

sudo dpkg -P virtualbox

install using the software portal.

synaptic sees all packages that are installed even if the repository they are from is not in your /etc/apt/sources.list.
mintinstall will add and remove a repository from sources.list to be able to install a package.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Re: Can't run Package Manager anymore

Postby fachrevi on Thu Nov 22, 2007 9:27 pm

root@fachrevi-desktop:/home/fachrevi# sudo dpkg -P virtualbox
dpkg: error processing virtualbox (--purge):
Package is in a very bad inconsistent state - you should
reinstall it before attempting a removal.
Errors were encountered while processing:
virtualbox

this is the result. should I reinstall my linuxmint ? in order to start install virtualbox from beginning.
fachrevi
Level 1
Level 1
 
Posts: 4
Joined: Wed Nov 21, 2007 9:34 pm

Re: Can't run Package Manager anymore

Postby fachrevi on Fri Nov 23, 2007 5:12 am

after try n error ... at lease I use "sudo dpkg --remove --force-remove-reinstreq virtualbox" and it's work.
thank's boo for u'r concern.
fachrevi
Level 1
Level 1
 
Posts: 4
Joined: Wed Nov 21, 2007 9:34 pm


Return to Newbie Questions

Who is online

Users browsing this forum: cweeks127, devsfan1830, kyphi, xerion567 and 30 guests

cron