Korean

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Korean

Postby sticknam50392 on Sun Dec 16, 2007 5:40 pm

Hello everyone.
Does anybody know how to install support for Korean (viewing and typing) on Mint?
I tried typing in "Korean" on the package manager, but so many files with similar descriptions popped up that I have no idea which one(s) to install.
Help?
Thanks in advance.
sticknam50392
Level 1
Level 1
 
Posts: 21
Joined: Thu Nov 22, 2007 10:29 pm

Linux Mint is funded by ads and donations.
 

Re: Korean

Postby EnvoyRising on Mon Dec 17, 2007 2:42 pm

안녕하세요?

On windows, after installing the Korean IME, you have to press Alt+Space to switch keyboard layouts, then right_alt to switch between English and 한글, right? Well, aside from English and Korean, I don't type in any other languages, so having two keyboard layouts was just redundant. As such, I have it set up so that I only have to pres the right_alt key to toggle Hangul. If you would like the same set up, just follow the steps below exactly. If you require other keyboard layouts, skip all the sections in parenthesis labeled optional.

1. Install Language Support for Korean

a) Navigate to Daryna > Administration > Language Support
b) After confirming the installation of additional packages, scroll down to Korean, select it, then click Apply.
c) Check the "Enable support to enter complex characters check box, then click OK.

2. Enable Korean Keyboard Layout
a) Navigate to Daryna > Preferences > Keyboard
b) On the layouts tab, click the add button near the bottom left of the window
c) Select "Korea, Republic of" from the layouts drop down box optional: to make things easier later on, I suggest using the 101/104 Compatible Variant), then click Add.
d) Confirm changes and select Close(optional: make sure to select Korean as your default layout, then simply delete the English layout as you won't be needing it)

3. Restart XSession
a. ctrl+alt+backspace
b. Log back in

Other things I've done that you might find interesting:

I. I disabled the other scim shortcuts becaues they seemed to get in my way (especially ctrl+space)
a. Navigate to Daryna > Preferences > SCIM Input Method Setup
b. Under Frontend > Global Setup, clear all but the "Hangul" entry for Trigger. All other fields should be blank.
c. Under IME Engine > Global Setup, make sure that only 2bul, Hangul, Hanja Romaja, and Hanja are enabled for Korean; and English/European for Other.
d. Under IME Engine > Hangul, select the Keyboard tab and make sure that only Hangul_Hanja is listed as the Hangul to Hanja key

II. I got rid of the notification area icon. (Just more wasted space in my book)
a. With SCIM Input Method Setup still open, go under Panel > GTK and ensure that Never is selected from the "Show" drop down list.
b. Uncheck the "show tray icon (bottom right corner, under "misc")

III. Sometimes, nautilus, gnome-terminal, and other programs wouldn't allow me to type in them, so I had to use a quick fix, found here

Also, please note that if you manage to find yourself typing in hangul with caps lock on, you won't be able to turn English back on until after you've turned caps lock back off
EnvoyRising
Level 1
Level 1
 
Posts: 23
Joined: Thu Nov 29, 2007 6:50 am


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 30 guests