How do I change permissions on root owned Fat32 Partition

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

How do I change permissions on root owned Fat32 Partition

Postby Fornhamfred on Sat Dec 29, 2007 8:39 am

I am new to Mint and have multi-installed mint on 160gb drive which has a 50gb Fat32 partition for storage. I need to be able to share this partition with my XP box. Mint can be seen in my network places on XP and I can access the home directory but the Fat32 icon gives the message that storage is not accessible, you may not have permission. When I look at the properties of the partition it shows owner root with create and delete files, Group plugdev with create and delete files and Others none. I have tried logging in as root and changing permissions but the changes do not save. Can I change this through a terminal and how?
Fornhamfred
Level 6
Level 6
 
Posts: 1141
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Linux Mint is funded by ads and donations.
 

Re: How do I change permissions on root owned Fat32 Partition

Postby Husse on Sat Dec 29, 2007 12:02 pm

You are not clear on this - I read you as you have problems accessing the FAT32 in the network from XP...
Could you clarify?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: How do I change permissions on root owned Fat32 Partition

Postby Fornhamfred on Sat Dec 29, 2007 12:12 pm

Yes. That is exactly what I am trying to do.
Fornhamfred
Level 6
Level 6
 
Posts: 1141
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: How do I change permissions on root owned Fat32 Partition

Postby Husse on Sat Dec 29, 2007 2:54 pm

I'm lost - on the same computer you don't (and can't) use the network - you access the files directly (in Nautilus if you are on gnome)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: How do I change permissions on root owned Fat32 Partition

Postby deadguy on Sat Dec 29, 2007 3:50 pm

fornhamfred,

this may help you: https://help.ubuntu.com/community/FilePermissions

a good list of bash commands: http://www.ss64.com/bash/
User avatar
deadguy
Level 5
Level 5
 
Posts: 710
Joined: Wed Aug 15, 2007 9:41 pm
Location: Illinois USA

Re: How do I change permissions on root owned Fat32 Partition

Postby Husse on Sun Dec 30, 2007 10:14 am

I don't think this is a permissions problem. FAT32 files are automounted by mintDesktop as read/write
Or we are dealing with one dual boot and one XP computer in which case it's a networking problem
We need to know which it is - and I won't spend time looking up the post with the solution for the networking problem if I don't know it is one
This is not the first time today I ask people to supply the necessary facts and write in a manner that makes it easy to read - else you are waisting my (and others) time
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: How do I change permissions on root owned Fat32 Partition

Postby Fornhamfred on Sun Dec 30, 2007 12:40 pm

Husse
Sorry I thought my first post was precise but obviously not. I have two computers one with Linux installed and the other Windows XP home. They are networked (hardwired) through a modem/router. On the Linux machine I have PcLinux, Mepis and Mint plus a 50GB Fat32 partition for storage. In PcLinux I can see all the shared drives on the XP machine and on the XP machine I can see and access all the shared files of PcLinux including the 50gb Fat32 partition. With Mint I can access all the shared files on the XP machine but from the XP machine I can only access the home file on Mint and not the Fat32 partition. As previously stated when in XP the mint storage partition is not accessible. I agree it could be a network problem but not in windows as it works fine with PcLinux. Mepis is even worse as so far I have not managed to even see Mepis on the XP machine. A copule of years ago I had the same problem with Mepis and it was resolved by amending the smb.conf file but unfortunately I cannot find my copy.

Another strange thing is that I have the network servers icon on the desktop in Mint, which when clicked takes me into Nautilus and shows the windows network, then Mshome but only the Mint machine not XP, when acessing the home folder in Nautilus and clicking the network folder both machines are displayed and all the XP files can be accessed.

Note Edited After setting a static IP address on Mint the network server icon on the desktop displays the XP machine and all shared files can be accessed. However it has not changed the situation on the XP machine.
Fornhamfred
Level 6
Level 6
 
Posts: 1141
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: How do I change permissions on root owned Fat32 Partition

Postby deadguy on Sun Dec 30, 2007 4:06 pm

ah, I was confused :shock: I thought you wanted to know how to change permissions..........

anyway, this link may help you: http://www.cody-snider.com/linux/howto- ... ndows.html
User avatar
deadguy
Level 5
Level 5
 
Posts: 710
Joined: Wed Aug 15, 2007 9:41 pm
Location: Illinois USA

Re: How do I change permissions on root owned Fat32 Partition

Postby Husse on Sun Dec 30, 2007 5:11 pm

Thanks deadguy
You are very much alive.....
This is the contents of one of the posts I was thinking of (at least it seems so)
Another thing is that you must have the same user name and password in Windows as in Linux if my memory serves me right (may be mentioned in that page - but there is another instructive post on this in the forum. Sadly the search in this forum is crap so I am hesitant to go look for it - I know it's there, but where :))
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: How do I change permissions on root owned Fat32 Partition

Postby deadguy on Sun Dec 30, 2007 5:53 pm

Husse wrote:Another thing is that you must have the same user name and password in Windows as in Linux if my memory serves me right


oh yes, I had forgotten about that :oops:
your memory does serve you right!!!
User avatar
deadguy
Level 5
Level 5
 
Posts: 710
Joined: Wed Aug 15, 2007 9:41 pm
Location: Illinois USA

Re: How do I change permissions on root owned Fat32 Partition

Postby Fornhamfred on Mon Dec 31, 2007 10:02 am

Thanks deadguy,

What I do not understand is why I can see my home directory from the XP box and can display the contents but can see the FAT32 partition (Storage below) but cannot access it.

Before I completely rewrite my smb.conf I have listed my smb.conf file with only the uncommented lines.

Can you see anything wrong with this which would cause the problem.

[global]

workgroup = MSHOME

server string = %h server (Samba, Ubuntu)

dns proxy = no

log file = /var/log/samba/log.%m

max log size = 1000

syslog = 0

panic action = /usr/share/samba/panic-action %d

security = share

encrypt passwords = true

passdb backend = tdbsam

obey pam restrictions = yes

guest account = nobody
invalid users = root

passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n

socket options = TCP_NODELAY

wins support = no
[printers]
comment = All Printers
browseable = no
path = /tmp
printable = yes
public = no
writable = no
create mode = 0700


[print$]
comment = Printer Drivers
path = /var/lib/samba/printers
browseable = yes
read only = yes
guest ok = no


[STORAGE]
path = /media/sdb9
available = yes
browsable = yes
public = yes
writable = yes


[Mint home]
path = /home/wilf
available = yes
browsable = yes
public = yes
writable = yes

The user names and passwords are the same in Mint as in Linux.
Fornhamfred
Level 6
Level 6
 
Posts: 1141
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: How do I change permissions on root owned Fat32 Partition

Postby shae on Mon Dec 31, 2007 6:08 pm

This is a little tricky because one mistake can make a real mess. So I can tell you what you need to edit, please open a terminal and run the following code:

Code: Select all
cat /etc/fstab


Then post the results here.

Note: This command does not change or alter your system. It just prints the contents of that configuration file in terminal so I can have a look at it.
shae
Level 1
Level 1
 
Posts: 2
Joined: Mon Dec 31, 2007 6:03 pm

Re: How do I change permissions on root owned Fat32 Partition

Postby deadguy on Mon Dec 31, 2007 6:48 pm

I see nothing wrong with your smb.conf (I am no network "expert" though)

maybe Husse will see something I missed (he's far more knowledgeable than I!)

what I find strange is that you can access your mint home files from xp but not your fat32 partition.
I would think it would be all or none if it was a network issue???

also you say you can access your fat32 partition from xp when your booted to pclinux so, I'm just wondering,
what the permissions are for your fat32 partition in pclinux?? are they different than in mint??

also, do what shae requested. shae may be able to help better than I.
User avatar
deadguy
Level 5
Level 5
 
Posts: 710
Joined: Wed Aug 15, 2007 9:41 pm
Location: Illinois USA

Re: How do I change permissions on root owned Fat32 Partition

Postby Husse on Tue Jan 01, 2008 10:50 am

I'm sorry but networking is my really weak spot....
But I don't see anything obviously wrong in your samba conf file
However fstab may give a clue - but I have not had a FAT partition in ages :) (not since XP appeared)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: How do I change permissions on root owned Fat32 Partition

Postby Fornhamfred on Tue Jan 01, 2008 1:46 pm

Thanks everyone.

I have had to re-install due to wrecking my home partition but have once again got exactly the same problem.

My fstab file is as follows:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sdb5
UUID=c1dc58d3-b71b-4be0-8ae3-da600b778276 / ext3 defaults,errors=remount-ro 0 1
# /dev/sdb6
UUID=281e6968-7d7a-4bc4-a8be-4dd10c11dfa4 /home ext3 defaults 0 2
# /dev/sda1
UUID=E2645FA7645F7CEB /media/sda1 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda5
UUID=e0ff5442-61c2-405d-b8d5-2b988888beda /media/sda5 ext3 defaults 0 2
# /dev/sda7
UUID=a863777d-765c-49a8-812b-4caf4e55a688 /media/sda7 ext3 defaults 0 2
# /dev/sdb1
UUID=68dc285d-cabe-4e1c-b099-eb9e0da6f2b6 /media/sdb1 ext3 defaults 0 2
# /dev/sdb10
UUID=993333c4-b0e2-4907-a7c5-5d08d95d4ba4 /media/sdb10 reiserfs defaults 0 2
# /dev/sdb3
UUID=df0c65c7-86f4-4ab0-8dae-12df8b4a9a43 /media/sdb3 ext3 defaults 0 2
# /dev/sdb7
UUID=54033174-f5a9-44a1-b4ea-2798e493b774 /media/sdb7 ext3 defaults 0 2
# /dev/sdb8
UUID=e2034005-30d2-45f3-a1ba-acb46b43a02f /media/sdb8 ext3 defaults 0 2
# /dev/sdb9
UUID=4774-CC8F /media/sdb9 vfat defaults,utf8,umask=007,gid=46 0 1
# /dev/sda6
UUID=1287bb72-1be3-401a-b567-d0a6ee289cab none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec 0 0

The storage partition is sdb9

Out of interest the PcLinux fstab is as follows:

# /dev/hda5, size=20659527, type=131: Journalised FS: ext3 (extended)
/dev/hda5 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
# /dev/hda7, size=15406272, type=131: Journalised FS: ext3 (extended)
/dev/hda7 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0
# fd: H1440
/dev/fd0 /mnt/floppy auto user,exec,rw,noauto 0 0
# /dev/hda1, size=19310067, type=7: NTFS (primary)
/dev/hda1 /mnt/win_c ntfs user,exec,ro,noauto,nls=utf8,umask=0 0 0
LABEL=Storage /mnt/windows vfat umask=0,user,exec 0 0
none /proc proc defaults 0 0
none /proc/bus/usb usbfs defaults 0 0
none /tmp tmpfs defaults 0 0
# /dev/hda6, size=5317452, type=130: Linux swap (extended)
/dev/hda6 swap swap defaults 0 0

and the PcLinux Samba file shows the following shares all of which are accessible from XP.

[homes]
comment = Home Directories
guest ok = yes
read only = no

[Unnamed]
path = /mnt/win_d
comment = FAT32
guest ok = yes
read only = no

[PCLinux Home]
path = /home/wilf
guest ok = yes
read only = no
case sensitive = no
strict locking = no

[STORAGE]
path = /mnt/windows
guest ok = yes
read only = no

Hope this helps.
Fornhamfred
Level 6
Level 6
 
Posts: 1141
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: How do I change permissions on root owned Fat32 Partition

Postby McLovin on Tue Jan 01, 2008 2:05 pm

it may actually be a permissions issue, if you right click and open the properties dialog, click on the permissions tab, what does it say for "others"? or "smb"? you want to see create and delete files for the access group that you want to access, I had to do something similar when I was using OpenSuse for a file server, I'm sure there are better ways, and someone else may know a better way, but the way that worked for me was to log in as root, (or open a terminal and open nautilus as root from within the terminal) and change the permissions. also make sure that your Mint and XP network names are the same.
User avatar
McLovin
Level 5
Level 5
 
Posts: 788
Joined: Thu Aug 23, 2007 6:53 pm

Re: How do I change permissions on root owned Fat32 Partition

Postby Fornhamfred on Tue Jan 01, 2008 3:15 pm

Logging in as root, the permissions are as follows Group plugdev, create and delete files, others none. I have tried to change the others section but the display just reverts back to none. It can obviously be changed thro the terminal but I do not know how. Can you see anything obvious between the permissions on Mint and PcLinux? Mint & XP user names and passwords are the same.
Fornhamfred
Level 6
Level 6
 
Posts: 1141
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: How do I change permissions on root owned Fat32 Partition

Postby deadguy on Tue Jan 01, 2008 3:52 pm

there is a kde app(works fine in gnome too!!) called krusader that makes changing permissions easy.
you can get it in synaptic. it is a file browser that has a root mode. see this post topic: viewtopic.php?f=90&t=7375&p=46852&hilit=krusader#p46852
User avatar
deadguy
Level 5
Level 5
 
Posts: 710
Joined: Wed Aug 15, 2007 9:41 pm
Location: Illinois USA

Re: How do I change permissions on root owned Fat32 Partition

Postby Husse on Tue Jan 01, 2008 4:16 pm

You could also try to change the line in fstab for fat32 (in Mint) as follows
Code: Select all
# /dev/sdb9
UUID=4774-CC8F /media/sdb9 vfat umask=0,user,exec 0 0

This replaces the "permissions part" in Mint with that from PCLOS and it's perfectly OK to use and gives the rights to "user" - i.e. just about anyone
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: How do I change permissions on root owned Fat32 Partition

Postby Fornhamfred on Wed Jan 02, 2008 4:09 pm

Thanks Husse.

Unfortunately my mint home partition has once again been trashed, this time by trying to install PcLinux Gnome. It would appear that when any distro (which does not request a home partition during install) is being installed something happens to the mint home partiton to make it unusable. This has happened with Freespire and PcLinux Gnome. Do you know of any way to protect the mint home partition?

Assuming that I have to re-install again then I will try your suggestion and report on the result.
Fornhamfred
Level 6
Level 6
 
Posts: 1141
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Linux Mint is funded by ads and donations.
 
Next

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], panorain, Yahoo [Bot] and 21 guests