New install: Speakers dont work, but headphones do...

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

New install: Speakers dont work, but headphones do...

Postby quickfoot on Tue Oct 25, 2011 8:59 am

I have installed Linux Mint 11 on an ASUS K53U laptop (AMD C-50 cpu).

My problem is that the headphones work, but the speakers on the laptop do not work at all.

How can I get it to work? :?

:? I have tried making sure that my user has permission to access the audio devices.
:? I have used alsamixer to set the speaker volume to max.

Any ideas? :)
quickfoot
Level 1
Level 1
 
Posts: 6
Joined: Tue Oct 25, 2011 8:30 am

Linux Mint is funded by ads and donations.
 

Re: New install: Speakers dont work, but headphones do...

Postby seppalta on Tue Oct 25, 2011 3:17 pm

Don't know if it will help but you can try all the settings available from the controls mentioned in 17 in http://douwil7.100webspace.net/linux/Tuning%20LXDE.html . Maybe you'll find a setting that produces audio. :D
seppalta
Level 4
Level 4
 
Posts: 390
Joined: Wed Jun 08, 2011 12:08 pm

Re: New install: Speakers dont work, but headphones do...

Postby quickfoot on Wed Oct 26, 2011 7:30 am

seppalta wrote:Don't know if it will help but you can try all the settings available from the controls mentioned in 17 in http://douwil7.100webspace.net/linux/Tuning%20LXDE.html . Maybe you'll find a setting that produces audio. :D


Thanks for the link. It did provide me with more tools, but unfortunately it did not lead to a fix.

I still have no sound. :(

What I did learn is that my laptop has support for sound via HDMI output as well as regular Analog Audio.
Also, it appears that in alsamixer that the HDMI is being chosen as the default output device even though in gnome sound control it looks like Analog is set.
:!: In alsamixer I have to manually select the Analog Audio from the list as sound card #1... #0 is HDMI and default is also HDMI.
card#1 is Chip: Realtek ALC269VB

:idea: I'm not an expert, but it seems that whatever is considered the default is what will work here. :idea:
:?: Is there a way to force card#0 to be my Analog Audio (Realtek ALC269VB)? :?:

If I am off base, please let me know as well.
quickfoot
Level 1
Level 1
 
Posts: 6
Joined: Tue Oct 25, 2011 8:30 am

Re: New install: Speakers dont work, but headphones do...

Postby Silent Warrior on Wed Oct 26, 2011 2:00 pm

Forcing... I don't know about that - maybe disabling HDMI-out in BIOS, but let's just try avoiding that. It's not e-l-e-g-a-n-t. :)

If you click the speaker in the notification area and go into Sound settings, what do you see on the tabs Hardware and Output? The speakers you're trying to use, are they built-in, or external? When you used ALSA Mixer, did you see <MM> (mute) below some output or other?
Silent Warrior
Level 4
Level 4
 
Posts: 464
Joined: Mon Aug 24, 2009 1:10 pm
Location: Göteborg, Sverige

Re: New install: Speakers dont work, but headphones do...

Postby quickfoot on Thu Oct 27, 2011 5:41 pm

Silent Warrior wrote:Forcing... I don't know about that - maybe disabling HDMI-out in BIOS, but let's just try avoiding that. It's not e-l-e-g-a-n-t. :)

If you click the speaker in the notification area and go into Sound settings, what do you see on the tabs Hardware and Output? The speakers you're trying to use, are they built-in, or external? When you used ALSA Mixer, did you see <MM> (mute) below some output or other?


Well, no worries about doing an inelegant thing... my BIOS does not have a setting for disabling it. :oops:

:arrow: Right now, in the volume control it is set to "Analog Speakers".
:arrow: The speakers are built in.
:arrow: In ALSA Mixer there is no "<MM> (mute)" below any of the output vertical bars.
quickfoot
Level 1
Level 1
 
Posts: 6
Joined: Tue Oct 25, 2011 8:30 am

Re: New install: Speakers dont work, but headphones do...

Postby Silent Warrior on Sun Oct 30, 2011 3:30 am

Congratulations, you shouldn't be having any trouble at all with those settings. At least, that's been my experience, but I only have one soundcard in this laptop. But what about your Hardware tab, then? What profile is it set to?
Silent Warrior
Level 4
Level 4
 
Posts: 464
Joined: Mon Aug 24, 2009 1:10 pm
Location: Göteborg, Sverige

Re: New install: Speakers dont work, but headphones do...

Postby quickfoot on Mon Oct 31, 2011 4:55 am

Silent Warrior wrote:Congratulations, you shouldn't be having any trouble at all with those settings. At least, that's been my experience, but I only have one soundcard in this laptop. But what about your Hardware tab, then? What profile is it set to?


My hardware tab shows the following:

Analog Stereo Duplex
Digital Stereo (HDMI) Output
Profile: Analog Stereo Duplex
quickfoot
Level 1
Level 1
 
Posts: 6
Joined: Tue Oct 25, 2011 8:30 am

Re: New install: Speakers dont work, but headphones do...

Postby Silent Warrior on Mon Oct 31, 2011 10:05 am

... Then, you should have sound. Seriously, this is just weird - your chip is supported under ALSA since 1.0.16*. The only way your settings differ from mine is the HDMI Out. Then again, I think there were some occasions when I had to give it a sort of running start in order to get sound. Keep the volume control open, while playing some music or whatever with any media player, and see what happens on the different tabs when you connect and disconnect your headphone.
I... suppose you shouldn't see much going on, really, but keep in mind that you won't need anywhere near as much volume to get audible sounds from headphones as you would with normal speakers.

... AH, GOT IT! W-well, that is, I remember what I had to monkey around with to get sound. With the volume control/sound settings open, go to the Hardware tab and see if there's any change when you set the profile to Analog Output. If so, see if it changes back when you set it to Analog duplex again. Also check the Output tab - try the different connections.

[Edit]
* Or is it? It seems to be an ongoing story. I did a search at alsa-project.org, and there are entries in the change logs at least into 1.0.22 where work has been done for the ALC269...

Ah, it seems Arch comes to the rescue yet again: https://bbs.archlinux.org/viewtopic.php ... 31#p888831
There was a suggested solution in the bottom post when I looked. Try it, and see what happens.
Silent Warrior
Level 4
Level 4
 
Posts: 464
Joined: Mon Aug 24, 2009 1:10 pm
Location: Göteborg, Sverige

Re: New install: Speakers dont work, but headphones do...

Postby AlbertP on Mon Oct 31, 2011 10:21 am

I am still wondering why no one hasn't yet suggested using the model setting for the Realtek ALC269. Being device #0 or #1 really does not matter, as the headphones on the same ALC269 chip do work.
Alsamixer always displays device #0 by default. But this DOES NOT MEAN that Device #1 is disabled by it.

These settings are available:
Code: Select all
ALC269
======
  basic         Basic preset
  quanta        Quanta FL1
  laptop-amic   Laptops with analog-mic input
  laptop-dmic   Laptops with digital-mic input
  fujitsu       FSC Amilo
  lifebook      Fujitsu Lifebook S6420
  auto          auto-config reading BIOS (default)

Please run this command:
Code: Select all
gksudo gedit /etc/modprobe.d/alsa-base.conf

And put this line in the text editor which opens:
Code: Select all
options snd-hda-intel model=auto

And replace auto with a model setting from the list above. You need to reboot for the model setting to take effect.

Another good advice: Don't touch Alsamixer! Make sure everything's unmuted and then leave it this way. You are using PulseAudio on Mint 11 Gnome.

By the way, are you sure that your sound chip is a Realtek ALC269? You can find it with this command:
Code: Select all
cat /proc/asound/card0/codec* | grep Codec

Replace card0 with card1 if it only displays HDMI audio.
Again, if your soundcard is card0 or card1 does NOT matter at all.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: New install: Speakers dont work, but headphones do...

Postby rainserpent on Sat Nov 24, 2012 2:04 pm

Thank you Albert, for your reply to this post :!: After messing around with all sorts of things, adding that option line to the config file and rebooting worked for me! (Running Maya on Toshiba NB505) :D
User avatar
rainserpent
Level 1
Level 1
 
Posts: 22
Joined: Mon Jun 07, 2010 6:04 pm
Location: Minnesota, United States

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot] and 33 guests