Boot menu does not allow me to choose a OS

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Boot menu does not allow me to choose a OS

Postby ex-spectator on Mon Jan 21, 2008 4:40 pm

I am new to Linux and switched recently after many months of never quite getting around to it. A friend passed a copy of the Linux mint 4.0 live CD to try out on recommendation that it would be the easiest for a not particularly tech-savvy person to get his head around and use. Thinking i would probably won't end up installing it fully for a couple of months or so till i had got used to it i ended up installing it to my computer within 3 days. I have two drives in my computer one 40 GB with windows XP and most of my files on and another which is 160GB which contained my music collection and videos. I created a partition on the second drive onto which i installed Linux. Everything was working great, i passed my music into Amarok and all the other applications are working great and so on.

Unfortunately (or not, depending on your opinion) i can no longer boot windows.

when i turn my computer on a Linux mint menu appears which includes the a timer for around 8 seconds (can't really remember but isn't important) and the options for booting Linux mint, Linux mint in graphics safe mode(?) , other operating systems and windows XP, Linux mint is highlighted so boots once the timer runs out . The problem lies in that but i can't choose any of the other options, i have tried using the arrow keys and more or less every keyboard button but i can't seem to do anything else but boot Linux.

I'm assuming there might be something blatantly obvious that i am missing, any help would be appreciated and thanks in advance.

(i also have an ipod related problem which i'm not sure to disclose in the same topic or create a new one)

(i also apologize in advance for the misuse of any words or incorrect phrasing relating to Linux which might grate many a Forum-ite over how silly i may be seeming)

(i also apologize for the amount of extra lines i have added in brackets after my main text)

(sorry)
And The Same
User avatar
ex-spectator
Level 1
Level 1
 
Posts: 3
Joined: Mon Jan 21, 2008 4:06 pm

Linux Mint is funded by ads and donations.
 

Re: Boot menu does not allow me to choose a OS

Postby m5ernel on Mon Jan 21, 2008 5:00 pm

Welcome to the forum! :D
You must add some lines into your Grub loader. Actually it is not very hard for I could do it and I am not very good with Linux. Try this:
1. open the Terminal and enter
Code: Select all
sudo gedit /boot/grub/menu.lst

this will open the loader list file.
2. scroll down towards the end. You must have sth. like this:
Code: Select all
title      Linux Mint, kernel 2.6.22-14-generic
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.22-14-generic root=/dev/sda1 ro quiet splash
initrd      /boot/initrd.img-2.6.22-14-generic
boot

title      Linux Mint, kernel 2.6.22-14-generic (recovery mode)
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.22-14-generic root=/dev/sda1 ro single
initrd      /boot/initrd.img-2.6.22-14-generic
boot

title      Linux Mint, kernel memtest86+
root      (hd0,0)
kernel      /boot/memtest86+.bin
boot

3. add windows menu, whereever within the upper section so it will look sth like:
Code: Select all
title      Linux Mint, kernel 2.6.22-14-generic
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.22-14-generic root=/dev/sda1 ro quiet splash
initrd      /boot/initrd.img-2.6.22-14-generic
boot

title      Windows
root      (hd0,0)
makeactive
chainloader   +1

title      Linux Mint, kernel 2.6.22-14-generic (recovery mode)
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.22-14-generic root=/dev/sda1 ro single
initrd      /boot/initrd.img-2.6.22-14-generic
boot

title      Linux Mint, kernel memtest86+
root      (hd0,0)
kernel      /boot/memtest86+.bin
boot

4. save and reboot to try it.

That should do the trick.
m5ernel
Level 1
Level 1
 
Posts: 14
Joined: Thu Jan 03, 2008 10:39 am

Re: Boot menu does not allow me to choose a OS

Postby ex-spectator on Mon Jan 21, 2008 5:47 pm

Unfortunately this does not solve my problem as when i tried your instructions all that happen was that another "windows" option appeared on my boot menu as well as the options before but i cannot choose it and only Linux mint is highlighted and nothing i do seems to let me choose the option despite it being there. Is there something i am not doing?
And The Same
User avatar
ex-spectator
Level 1
Level 1
 
Posts: 3
Joined: Mon Jan 21, 2008 4:06 pm

Re: Boot menu does not allow me to choose a OS

Postby merlwiz79 on Mon Jan 21, 2008 7:14 pm

ex-spectator wrote:Unfortunately this does not solve my problem as when i tried your instructions all that happen was that another "windows" option appeared on my boot menu as well as the options before but i cannot choose it and only Linux mint is highlighted and nothing i do seems to let me choose the option despite it being there. Is there something i am not doing?

Try editing to say this.
Code: Select all
title      Microsoft Windows XP Professional
root      (hd1,0)
savedefault
map      (hd0) (hd1)
map      (hd1) (hd0)
chainloader   +1
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Boot menu does not allow me to choose a OS

Postby ex-spectator on Tue Jan 22, 2008 1:40 pm

Once again the boot menu will not let me do anything with it, i added the code and restarted my computer but no matter what i pressed i still could not select windows, or any other options, when i pressed F1 nothing happened then either, its almost as if the menu was completely ignoring the signals my keyboard is sending and in fact my keyboard acts as if it was "off" (num lock light not lighting when i press num lock until Linux boots) yet before GRUB loads i have a choice between pressing F2 for settings and F11 for boot menu ( which gives me a list of 4 options, which one boots from floppy disk, one loads GRUB one does not do anything and gives me an error message and a fourth which boots from CD. Could it be something do with my keyboard not sending messages to the computer to tell it to select down or something?

if you would like any more details on what exactly I'm doing or anything else , do ask.
And The Same
User avatar
ex-spectator
Level 1
Level 1
 
Posts: 3
Joined: Mon Jan 21, 2008 4:06 pm

Re: Boot menu does not allow me to choose a OS

Postby McLovin on Wed Jan 23, 2008 10:25 am

Are you using a wireless, or usb keyboard by any chance? It sounds like your keyboard is not being recognized. Try plugging in a PS/2 (standard) keyboard, and see if it works.
User avatar
McLovin
Level 5
Level 5
 
Posts: 788
Joined: Thu Aug 23, 2007 6:53 pm


Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot] and 22 guests