Hello, new to linux and need some guidance

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Re: Hello, new to linux and need some guidance

Postby elajas82 on Sun Jan 27, 2008 5:31 pm

Ok, i'm back.
I managed to install windows and then i installed mint. Now i have same problem i had last time: when i boot up only windows is there, no linux. I think i figured it out. Like i said i have 3 hdd in my pc but i didn't mention, that 2 of them are sata2 and one is my old ide drive. When i installed mint and made partitions, the ide drive was listed as first, then my 80gb sata2 and then the last 160gb sata2.
When the installation finished, i rebooted my PC. For my suprise: no linux boot ... only windows. I tried several times: still no linux. Then i manually booted from my 80gb hdd and guess what: linux mint boot screen.

It seems, that my pc is first looking boot records from that ide drive. Even in my pc bios this ide drive is first and then the sata drives (there is nothing i can do about that ... i have tried). I did change the settings, that the 80GB is first to search for os but it only finds windows ...

Is there any solution for that .... i mean the linux is working, so is the windows but i haveto manually boot to use mint.

I also made a screenshot while i was installing if that helps:

mypc.jpg
mypc.jpg (40.45 KiB) Viewed 287 times


this is made before i started to select the partitions, also some parts of this screen are in estonian, but in general i think you understand.

So is there any solution or do i haveto get used to manual boot?

Thank You
User avatar
elajas82
Level 1
Level 1
 
Posts: 16
Joined: Sun Jan 27, 2008 8:26 am
Location: Estonia

Linux Mint is funded by ads and donations.
 

Re: Hello, new to linux and need some guidance

Postby deadguy on Sun Jan 27, 2008 11:26 pm

hmm, sot sure what's going on here...

did mint put grub on the mbr?

I have read about other people having grub issues when using
both ide and sata drives.(I've always had either sata or ide but not both on one machine, so I'm unfamiliar with this problem)

you can check out this from the wiki: http://www.linuxmint.com/wiki/index.php ... _your_grub
User avatar
deadguy
Level 5
Level 5
 
Posts: 710
Joined: Wed Aug 15, 2007 9:41 pm
Location: Illinois USA

Re: Hello, new to linux and need some guidance

Postby elajas82 on Mon Jan 28, 2008 12:10 am

Right now the mint and windows are working, the only thing is if i wanto use use mint, i haveto boot manually and i can live with that (only 2 keystrokes when i boot :)). I'm not going to mess with any system files for now ... i'm planning to replace my two 160 GB hdd-s with one splitted 500GB sata2 hdd soon ... i hope it will fix this problem :D

Anway, thanks for all your help, the mint is working great: all my hardware works (i havent tested my canon printer yet tho), compiz has made my desktop an a eyecandy and for almost every program i used and needed in windows, there is an alternate in linux so i think things are looking good :)

Thank You
User avatar
elajas82
Level 1
Level 1
 
Posts: 16
Joined: Sun Jan 27, 2008 8:26 am
Location: Estonia

Previous

Return to Newbie Questions

Who is online

Users browsing this forum: Spiceman and 19 guests