wireless and sound not working

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

wireless and sound not working

Postby jfort2 on Sat Feb 09, 2008 4:42 pm

Help! New to Mint. I have Mint loaded on my Gateway laptop and the onboard sound and onboard wireless card are not working?
jfort2
Level 1
Level 1
 
Posts: 4
Joined: Sat Feb 09, 2008 3:10 pm

Linux Mint is funded by ads and donations.
 

Re: wireless and sound not working

Postby Husse on Sat Feb 09, 2008 6:42 pm

Which model?
Which wifi and which sound
For sound - you may need to have the modem turned on (switch on the bottom sometimes)
for wifi - check the wiki
http://www.linuxmint.com/wiki/index.php/MintWifi
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: wireless and sound not working

Postby MagnusB on Sat Feb 09, 2008 9:32 pm

You need to up the flux in order to capacitate the incoming candela... Or post the output of
Code: Select all
lspci

If you have a Broadcom wifi card look check out ndiswrapper or bcm43xx-fwcutter.
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: wireless and sound not working

Postby jfort2 on Thu Mar 27, 2008 2:59 pm

Got my wifi to work but my sound is not working. I have Mint loaded on a gateway laptop. Here is the output of
lspci
00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)
02:07.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev a9)
02:07.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev a9)
02:07.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 01)
02:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:09.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
jfort2
Level 1
Level 1
 
Posts: 4
Joined: Sat Feb 09, 2008 3:10 pm

Re: wireless and sound not working

Postby MagnusB on Thu Mar 27, 2008 3:33 pm

what happens if you run:
Code: Select all
alsamixer

in a terminal? There should be no [MM] below the bars (means they are muted)
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: wireless and sound not working

Postby Husse on Thu Mar 27, 2008 5:32 pm

I believe this is a case where you have to enable the modem to get sound...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: wireless and sound not working

Postby jfort2 on Sat Mar 29, 2008 6:02 pm

ran alsamixer and no mm under the bars. How do I enable the modem?
jfort2
Level 1
Level 1
 
Posts: 4
Joined: Sat Feb 09, 2008 3:10 pm

Re: wireless and sound not working

Postby Husse on Sun Mar 30, 2008 5:56 pm

How do I enable the modem

Unfortunately hard to say - many laptops has a switch on the bottom (or on a side)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: wireless and sound not working

Postby jfort2 on Fri Apr 18, 2008 11:53 am

I enabled the modem and the sound still doesn't work.
jfort2
Level 1
Level 1
 
Posts: 4
Joined: Sat Feb 09, 2008 3:10 pm

Re: wireless and sound not working

Postby Husse on Fri Apr 18, 2008 6:06 pm

This might work
Code: Select all
sudo aptitude install linux-backports-modules-generic

I've seen it mentioned as a separate solution but also as follows
sudo gedit /etc/modprobe.d/alsa-base
Enter the following line at the bottom:
options snd-hda-intel model=acer

Now you don't have an acer but a gateway so change acer to gateway
Can't guarantee it works, but it should not break your system on the other hand
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: ClutchDisc and 21 guests