SPDIF not working

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

SPDIF not working

Postby crackedsaint on Sun Feb 17, 2008 2:48 pm

An lspci command gives me this:

Code: Select all
04:07.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)


After some Googling, it seems like a common issue. I am able to use the green output but only the left ear bub works (right is dead). This is for my HTPC so I have to use the SPDIF output to my receiver.

I was thinking perhaps a dpkg reconfig option for the sound card drivers might work...? If so, what's the command?

Is there anything else I need to provide you guys?

Thanks!
crackedsaint
Level 1
Level 1
 
Posts: 3
Joined: Sun Feb 17, 2008 2:31 pm

Linux Mint is funded by ads and donations.
 

Re: SPDIF not working

Postby Husse on Sun Feb 17, 2008 3:36 pm

Try
sudo dpkg-reconfigure alsa-base
sudo dpkg-reconfigure alsa-utils
sudo dpkg-reconfigure libasound2

That is if you use alsa :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: SPDIF not working

Postby crackedsaint on Sun Feb 17, 2008 3:54 pm

Heh. I installed that package but there is nothing to reconfigure

I'm not familiar with drivers in Linux but pretty darn sure that's the culprit.
crackedsaint
Level 1
Level 1
 
Posts: 3
Joined: Sun Feb 17, 2008 2:31 pm

Re: SPDIF not working

Postby Husse on Sun Feb 17, 2008 5:08 pm

Well you reconfigure by these commands - and it affects the driver
dpkg-reconfigure is done for different "parts" of Mint in different ways....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: SPDIF not working

Postby crackedsaint on Sun Feb 17, 2008 7:07 pm

Well when I try to reconfigure those, nothing happens. It just goes back to the prompt.
crackedsaint
Level 1
Level 1
 
Posts: 3
Joined: Sun Feb 17, 2008 2:31 pm


Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot], Reorx, tuxpenguin8 and 40 guests