Resolution is gonna make me cry! solved

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Resolution is gonna make me cry! solved

Postby Andy Mack on Wed Feb 27, 2008 4:23 pm

I'm frustrated at hell with this laptop resolution thing.

4.0 Daryna
Dell Vostro 1500
nVidia 8600m GT
3GB Ram

Under nvidia-settings it's 1280x800 60hz, under Administration Screens and Graphics its 1280x800 50hz and under Prefs Screen Resolution 1280x800 53hz!

What can I do to sort this? I've been trying to sort this for 3 days and being newish to linux i've messed up loads of times.

Every window or dialog thats opened seems to fill the screen and I know that aint right cause it worked and looked good under Xubuntu, I know thats Xfce but I can tell the difference.

Under XP 1280x800 60hz is what is reported if thats any help.

Please help me someone.

Andy
Andy Mack
Level 3
Level 3
 
Posts: 118
Joined: Thu Feb 14, 2008 8:11 pm

Linux Mint is funded by ads and donations.
 

Re: Resolution is gonna make me cry!

Postby Husse on Wed Feb 27, 2008 5:08 pm

It seems it is not resolution but refresh rate that is your problem
If you don't intend to use two monitors you disable that and the refresh rates are good. I did it on my system
You have to edit xorg.conf
Code: Select all
gksudo gedit /etc/X11/xorg.conf

Add
Code: Select all
Option       "DynamicTwinView" "False"

to Section "Device" as the last line
To get it working restart X (ctrl+backspace)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Resolution is gonna make me cry!

Postby Andy Mack on Wed Feb 27, 2008 6:15 pm

I entered that under Screen 0 and above ENDSECTION in the Device section but when I restarted X it messed up everything, the bottom of the screen was at the top, top left was bottom right and top right was at bottom left lol

I'm in XP at the moment I'll post my xorg.conf cause i've no idea what to do or what went wrong.


# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "Files"
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection


Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "Failsafe Device"
Boardname "vesa"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 0
EndSection

Section "Monitor"
Identifier "Failsafe Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1280x800"
Horizsync 31.5-50.0
Vertrefresh 56.0 - 65.0
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Failsafe Device"
Monitor "Failsafe Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Modes "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
Inputdevice "Synaptics Touchpad"
EndSection
Section "device" #
Identifier "device1"
Boardname "vesa"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 1
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection
Section "monitor" #
Identifier "monitor1"
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection
Andy Mack
Level 3
Level 3
 
Posts: 118
Joined: Thu Feb 14, 2008 8:11 pm

Re: Resolution is gonna make me cry!

Postby Husse on Wed Feb 27, 2008 7:21 pm

Ouch - your xorg.conf is crap :shock:
I've seen this before and it's the result of some fallback mechanism if everything goes absolutely wrong
I assumed you had a reasonably correct xorg.conf
However my advice is the correct solution to get better refresh rate
Somewhere in the forum there is a solution to this, but I can't expect you to find it, not to hard though
viewtopic.php?f=18&t=6958&hilit=Failsafe+Monitor
And as it tells you in that topic and in your topic
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

And sudo dpkg-reconfigure -phigh xserver-xorg gives you decent settings back.
Now you have to install the nvidia driver again, but first back up your now working xorg.conf
First when everything works add the Twinview false line
If you can't log in to a normal x session you can start in "Recovery mode" - and now you are root - take care so you don't mess up.
You can run dpkg-reconfigure -phigh xserver-xorg in "Recovery mode" (no sudo - you are root already)
When you are done reboot - nothing else
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Resolution is gonna make me cry!

Postby Andy Mack on Wed Feb 27, 2008 8:53 pm

Worked a treat, thanks, now showing 60hz on everything though I dont know if the sceen is any better or not lol.

Does it matter that under nvidia-settings that X Server Display Configuration it says "unable to load page"?

Thanks again
Andy
Andy Mack
Level 3
Level 3
 
Posts: 118
Joined: Thu Feb 14, 2008 8:11 pm

Re: Resolution is gonna make me cry!

Postby Husse on Thu Feb 28, 2008 7:11 am

nvidia settings is a bit special
Take look in the howto section There's a sticky there by me on how to make nvidia settings persistent
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Newbie Questions

Who is online

Users browsing this forum: BlackVeils, nightmare and 38 guests