dpkg was interrupted solved

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

dpkg was interrupted solved

Postby orduek on Fri Feb 29, 2008 4:50 am

what happend?
When i opened the Synaptec manager it gave me that error:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

I checked these forums and tried everything.
sudo dpkg --configure -a
and got:
Setting up initramfs-tools (0.85eubuntu20) ...
update-initramfs: deferring update (trigger activated)

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.24.2
Cannot find /lib/modules/2.6.24.2
update-initramfs: failed for /boot/initrd.img-2.6.24.2
dpkg: subprocess post-installation script returned error exit status 1

then did sudo apt-get update and got:
Get:1 http://archive.canonical.com gutsy Release.gpg [191B]
Ign http://archive.canonical.com gutsy/partner Translation-en_US
Hit http://archive.canonical.com gutsy Release
Ign http://ftp.osuosl.org gutsy/ Release.gpg
Ign http://ftp.osuosl.org gutsy/ Translation-en_US
Ign http://cafelinux.org tinwoodman Release.gpg
Hit http://archive.canonical.com gutsy/partner Packages
Ign http://ftp.osuosl.org gutsy/ Release
Ign http://cafelinux.org tinwoodman/main Translation-en_US
Ign http://ftp.osuosl.org gutsy/ Packages
Hit http://ftp.osuosl.org gutsy/ Packages
Ign http://cafelinux.org tinwoodman/contrib Translation-en_US
Get:2 http://packages.medibuntu.org gutsy Release.gpg [189B]
Ign http://packages.medibuntu.org gutsy/free Translation-en_US
Get:3 http://archive.ubuntu.com gutsy Release.gpg [191B]
Ign http://archive.ubuntu.com gutsy/main Translation-en_US
Get:4 http://security.ubuntu.com gutsy-security Release.gpg [191B]
Ign http://security.ubuntu.com gutsy-security/main Translation-en_US
Ign http://security.ubuntu.com gutsy-security/restricted Translation-en_US
Hit http://cafelinux.org tinwoodman Release
Ign http://www.linuxmint.com daryna Release.gpg
Ign http://www.linuxmint.com daryna/main Translation-en_US
Ign http://www.linuxmint.com daryna/upstream Translation-en_US
Ign http://cafelinux.org tinwoodman/main Packages
Ign http://packages.medibuntu.org gutsy/non-free Translation-en_US
Hit http://packages.medibuntu.org gutsy Release
Ign http://archive.ubuntu.com gutsy/restricted Translation-en_US
Ign http://archive.ubuntu.com gutsy/universe Translation-en_US
Ign http://archive.ubuntu.com gutsy/multiverse Translation-en_US
Get:5 http://archive.ubuntu.com gutsy-updates Release.gpg [191B]
Ign http://archive.ubuntu.com gutsy-updates/main Translation-en_US
Ign http://archive.ubuntu.com gutsy-updates/restricted Translation-en_US
Ign http://www.linuxmint.com daryna/import Translation-en_US
Ign http://www.linuxmint.com romeo Release.gpg
Ign http://www.linuxmint.com romeo/daryna Translation-en_US
Hit http://www.linuxmint.com daryna Release
Ign http://cafelinux.org tinwoodman/contrib Packages
Ign http://packages.medibuntu.org gutsy/free Packages
Hit http://cafelinux.org tinwoodman/main Packages
Ign http://archive.ubuntu.com gutsy-updates/universe Translation-en_US
Ign http://archive.ubuntu.com gutsy-updates/multiverse Translation-en_US
Hit http://archive.ubuntu.com gutsy Release
Hit http://www.linuxmint.com romeo Release
Hit http://cafelinux.org tinwoodman/contrib Packages
Get:6 http://wine.budgetdedicated.com gutsy Release.gpg [191B]
Ign http://wine.budgetdedicated.com gutsy/main Translation-en_US
Hit http://archive.ubuntu.com gutsy-updates Release
Ign http://www.linuxmint.com daryna/main Packages
Ign http://www.linuxmint.com daryna/upstream Packages
Ign http://www.linuxmint.com daryna/import Packages
Hit http://wine.budgetdedicated.com gutsy Release
Hit http://archive.ubuntu.com gutsy/main Packages
Hit http://archive.ubuntu.com gutsy/restricted Packages
Hit http://archive.ubuntu.com gutsy/universe Packages
Ign http://www.linuxmint.com romeo/daryna Packages
Hit http://archive.ubuntu.com gutsy/multiverse Packages
Hit http://archive.ubuntu.com gutsy-updates/main Packages
Hit http://archive.ubuntu.com gutsy-updates/restricted Packages
Hit http://archive.ubuntu.com gutsy-updates/universe Packages
Hit http://archive.ubuntu.com gutsy-updates/multiverse Packages
Hit http://www.linuxmint.com daryna/main Packages
Hit http://www.linuxmint.com daryna/upstream Packages
Ign http://packages.medibuntu.org gutsy/non-free Packages
Hit http://www.linuxmint.com daryna/import Packages
Hit http://packages.medibuntu.org gutsy/free Packages
Hit http://www.linuxmint.com romeo/daryna Packages
Hit http://packages.medibuntu.org gutsy/non-free Packages
Ign http://wine.budgetdedicated.com gutsy/main Packages
Hit http://wine.budgetdedicated.com gutsy/main Sources
Ign http://security.ubuntu.com gutsy-security/universe Translation-en_US
Ign http://security.ubuntu.com gutsy-security/multiverse Translation-en_US
Hit http://security.ubuntu.com gutsy-security Release
Hit http://security.ubuntu.com gutsy-security/main Packages
Hit http://security.ubuntu.com gutsy-security/restricted Packages
Hit http://security.ubuntu.com gutsy-security/universe Packages
Hit http://security.ubuntu.com gutsy-security/multiverse Packages
Hit http://wine.budgetdedicated.com gutsy/main Packages
Fetched 6B in 11s (1B/s)
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

and ran sudo apt-get upgrade and got:
sudo apt-get upgrade
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

anyone??
orduek
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2008 2:16 pm

Linux Mint is funded by ads and donations.
 

Re: dpkg was interrupted

Postby Husse on Fri Feb 29, 2008 7:08 am

I can see two possible errors
update-initramfs: Generating /boot/initrd.img-2.6.24.2

This is not the kernel version Mint is using. Mint has 2.6.22-14
Also the different repos mentioned indicates that you have a very non standard sources.list which can cause all sorts of problems
The standard one (with Romeo enabled) below
Code: Select all
## -----------------------                                   
## LINUX MINT REPOSITORIES
## -----------------------

## +++ Daryna (Linux Mint 4.0) +++
deb http://www.linuxmint.com/repository daryna main upstream import
## deb http://www.linuxmint.com/repository daryna community
## deb http://www.linuxmint.com/repository daryna backport

## +++ Romeo (Linux Mint Unstable) +++
deb http://www.linuxmint.com/repository romeo daryna

## +++ Source Repositories +++
## deb-src http://www.linuxmint.com/repository daryna main upstream import
## deb-src http://www.linuxmint.com/repository daryna community
## deb-src http://www.linuxmint.com/repository daryna backport
deb-src http://www.linuxmint.com/repository romeo daryna

## -------------------
## UBUNTU REPOSITORIES
## -------------------

## +++ Gutsy (Ubuntu 7.10) +++
deb http://archive.ubuntu.com/ubuntu gutsy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu gutsy-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu gutsy-security main restricted universe multiverse

## +++ Backports & Proposed (Ubuntu Unstable) +++
#deb http://archive.ubuntu.com/ubuntu gutsy-backports main restricted universe multiverse
#deb http://archive.ubuntu.com/ubuntu gutsy-proposed main restricted universe multiverse

## +++ Source Repositories +++
#deb-src http://archive.ubuntu.com/ubuntu gutsy main restricted universe multiverse
#deb-src http://archive.ubuntu.com/ubuntu gutsy-updates main restricted universe multiverse
#deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted universe multiverse
#deb-src http://archive.ubuntu.com/ubuntu gutsy-backports main restricted universe multiverse

## ------------------
## OTHER REPOSITORIES
## ------------------

## +++ Canonical +++
deb http://archive.canonical.com/ubuntu gutsy partner

## +++ Medibuntu +++
deb http://packages.medibuntu.org/ gutsy free non-free
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: dpkg was interrupted

Postby orduek on Fri Feb 29, 2008 10:25 am

OK.
I changed the sources.list (copy and pasted what you wrote).
How can I change back the header image?
orduek
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2008 2:16 pm

Re: dpkg was interrupted

Postby orduek on Fri Feb 29, 2008 10:36 am

found a solution.
If anyone intersted its here:
http://ubuntuforums.org/showthread.php? ... light=dpkg

Thank you Husse for your time and patience.
orduek
Level 1
Level 1
 
Posts: 30
Joined: Thu Jan 10, 2008 2:16 pm


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 21 guests