Mint Menu and Windows button?

Questions about applications and software
Forum rules
Before you post please read this

Mint Menu and Windows button?

Postby Terw on Wed Jul 16, 2008 9:16 am

Hello
Is there any way to attach the windows button (super L) to show the mint menu? Really would like a keyboard shortcut for it :/
Terw
Level 1
Level 1
 
Posts: 11
Joined: Wed May 07, 2008 4:16 pm

Linux Mint is funded by ads and donations.
 

Re: Mint Menu and Windows button?

Postby lakehousetech on Thu Jul 17, 2008 9:36 am

If you go to system:preferences:keyboard you can choose your specific keyboard under the 'layouts' tab. Once you choose the correct keyboard select 'layout options' at the bottom right of the window. Under 'Alt/Win behavior' change the selection from 'default' to 'add the standard behavior to menu key'. Close the window, and then go to: system:preferences:keyboard shortcuts. Where it says "show the panel menu" click and press the windows key on your keyboard. It should enter the 'Super L' text into the shortcut column. Then you should be good to go. Hope this helps!
User avatar
lakehousetech
Level 4
Level 4
 
Posts: 454
Joined: Wed Nov 07, 2007 3:34 pm
Location: Toronto, ON

Re: Mint Menu and Windows button?

Postby mikemaccana on Wed Oct 08, 2008 10:33 am

The instructions above do not activate the Mint menu in the panel.

Instead, they only make a second Gnome menu appear where the cursor is (ie, the middle of the screen) when you click the Windows key.
The MintMenu is not activated at all.

Is there a working fix for this?
mikemaccana
 

Re: Mint Menu and Windows button?

Postby belovedmonster on Wed Oct 08, 2008 10:48 am

Whatever the fix is, I think it should be included in Mint 6 by default. Stuff like this can really make the difference for Windows switchers and its not like it will get in the way of old school Linux users either.
User avatar
belovedmonster
Level 5
Level 5
 
Posts: 642
Joined: Thu Dec 21, 2006 12:34 pm

Re: Mint Menu and Windows button?

Postby Death Dream on Wed Oct 08, 2008 3:26 pm

belovedmonster wrote:Whatever the fix is, I think it should be included in Mint 6 by default. Stuff like this can really make the difference for Windows switchers and its not like it will get in the way of old school Linux users either.


Then where will the super key go? The Super key is a pretty big part of shotcuts for most linux users. Given I would love to have my windows key open the start menu but as I use linux more and more I am using the super key more often.

~Death Dream~
User avatar
Death Dream
Level 3
Level 3
 
Posts: 112
Joined: Fri Sep 26, 2008 9:23 am

Re: Mint Menu and Windows button?

Postby timh on Fri Oct 10, 2008 7:58 pm

mikemaccana wrote:The instructions above do not activate the Mint menu in the panel.

Instead, they only make a second Gnome menu appear where the cursor is (ie, the middle of the screen) when you click the Windows key.
The MintMenu is not activated at all.
Is there a working fix for this?

This menu that appear is the same as the MintMenu. With the keyboard [←↓↑→] you can use it real fast :)
and it is allways in the foreground for easy use.
I like it :D ... and sorry for my “not so nice” English
LMDE2 UP7
Image
Image Image
User avatar
timh
Level 3
Level 3
 
Posts: 133
Joined: Thu Oct 25, 2007 2:36 pm
Location: Spain

Re: Mint Menu and Windows button?

Postby venkat on Fri Nov 07, 2008 3:14 pm

I tried this and am also only getting the Gnome Menu - not Mint Menu.
venkat
 

Re: Mint Menu and Windows button?

Postby Peekie on Fri May 08, 2009 2:52 pm

In Mint 7 RC1 this feature is implemented :o
Pressing the Windows key will open Mint menu just like clicking the Menu button.
Great work Clem and the rest of the Mint-team!
Peekie
Level 1
Level 1
 
Posts: 4
Joined: Fri May 08, 2009 2:50 pm
Location: Rotterdam, the Netherlands

Re: Mint Menu and Windows button?

Postby cerebellum on Fri Jul 03, 2009 2:52 am

I am using the final release of Linux Mint 7 and I can't seem to launch the menu using the windows key.. anything that I should set?
cerebellum
Level 1
Level 1
 
Posts: 18
Joined: Mon Apr 27, 2009 4:04 am

Re: Mint Menu and Windows button?

Postby timh on Sun Jul 05, 2009 3:57 pm

cerebellum wrote:I am using the final release of Linux Mint 7 and I can't seem to launch the menu using the windows key.. anything that I should set?


right click on the menu and preferences. On the first tab look for shortcut
there should be: Super_L
LMDE2 UP7
Image
Image Image
User avatar
timh
Level 3
Level 3
 
Posts: 133
Joined: Thu Oct 25, 2007 2:36 pm
Location: Spain

Re: Mint Menu and Windows button?

Postby emorrp1 on Sun Jul 12, 2009 2:10 pm

This was one of the changes made to the RC: the default key is now ctrl+Super
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: Mint Menu and Windows button?

Postby digitor on Fri Sep 04, 2009 3:48 am

Hi, I am a newbie, but I think I have followed the instructions and it doesn't seem to want to play.
I have confirmed that when I press the windows key the keyboard shortcuts detect "Super L", but despite typing in:
super
Super
Super L
Super l
super L
super l
Super_L
Super_l
super_L
super_l

it still refuses to work. Rather frustrating - anyone got ideas?
digitor
Level 1
Level 1
 
Posts: 1
Joined: Fri Sep 04, 2009 3:37 am

Re: Mint Menu and Windows button?

Postby emorrp1 on Sat Sep 05, 2009 7:20 pm

see viewtopic.php?f=55&t=31550 you have to logout and login to load the changes
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: Mint Menu and Windows button?

Postby clem on Tue Sep 08, 2009 4:39 am

Hi,

Just a little note to say that this was implemented in Mint 7. In the RC, it was simply Super_L (left Windows key), but since Gnome-Do also uses that key and it's also a common key used for combo shortcuts, for the stable release of Mint 7 it was changed to CTRL+Super_L. You can change this by going in the Preferences for mintMenu. Make sure to restart mintMenu after that (either remove/add it to the panel again, or logout).

Clem.
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5553
Joined: Wed Nov 15, 2006 8:34 am

Re: Mint Menu and Windows button?

Postby buddhaflow on Fri Oct 23, 2009 7:50 am

The question I have is this. Why can't I bind combinations that involve the Super key? I am migrating over from CrunchBang (well, using both of them), and my favorite feature of that is being able to bind Super+W to firefox, Super+F to the home folder, etc. I just find it much more clunky to use ctrl+shift+w. Is there any workaround for this?
buddhaflow
Level 1
Level 1
 
Posts: 9
Joined: Fri Oct 23, 2009 7:44 am

Re: Mint Menu and Windows button?

Postby mDuo13 on Sat Nov 07, 2009 9:40 pm

buddhaflow wrote:The question I have is this. Why can't I bind combinations that involve the Super key? I am migrating over from CrunchBang (well, using both of them), and my favorite feature of that is being able to bind Super+W to firefox, Super+F to the home folder, etc. I just find it much more clunky to use ctrl+shift+w. Is there any workaround for this?


I was having a similar issue to that - Preferences > Keyboard Shortcuts would not (and still won't) let me bind things using Super as a modifier - it would just detect the button as Super_L (or Super_R) regardless of what other buttons I pressed. I tried disabling the Ctrl+Super shortcut for the MintMenu (as I don't care to use it) and it didn't take effect... until I restarted X (Ctrl+Alt+Backspace). After that, the Firefox shortcut I made in the "Commands" plugin of Compiz Config Settings Manager also worked. So the Gnome "Keyboard Shortcuts" thing still won't let me set shorcuts including Super, but Compiz will so it's all good.

For anyone with problems like mine, hopefully this is useful information?
mDuo13
Level 1
Level 1
 
Posts: 9
Joined: Sat Nov 07, 2009 9:25 pm

Re: Mint Menu and Windows button?

Postby Uncle Spellbinder on Fri Nov 27, 2009 8:11 pm

clem wrote:...You can change this by going in the Preferences for mintMenu. Make sure to restart mintMenu after that (either remove/add it to the panel again, or logout).


Forgive me for hijacking the thread here, but where exactly can I find Preferences for mintMenu?
Computer Specs: HP Pavilion - Intel Core i5 - 3.10GHz - 8 GB memory - nVidia GeForce GT 520 1 GB
User avatar
Uncle Spellbinder
Level 2
Level 2
 
Posts: 87
Joined: Thu Nov 26, 2009 10:47 am

Re: Mint Menu and Windows button?

Postby Uncle Spellbinder on Sat Nov 28, 2009 1:14 am

Uncle Spellbinder wrote:...where exactly can I find Preferences for mintMenu?


Nevermind. I'm really out of it today. Must be the turkey. Right click the icon. :oops:
Computer Specs: HP Pavilion - Intel Core i5 - 3.10GHz - 8 GB memory - nVidia GeForce GT 520 1 GB
User avatar
Uncle Spellbinder
Level 2
Level 2
 
Posts: 87
Joined: Thu Nov 26, 2009 10:47 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 24 guests