midi support by default

Write suggestions and new ideas in here
More ideas here http://community.linuxmint.com/idea/welcome
Forum rules
No support questions here please.
Do not post ideas for application developers. Please use GitHub for Cinnamon and Nemo ideas.

midi support by default

Postby yddet12 on Wed Jan 27, 2010 6:09 pm

Since Linux Mint aims to support popular multimedia codecs out of the box, wouldn't it be nice if it included TiMidity and libgsttimidity.so by default?
yddet12
Level 1
Level 1
 
Posts: 4
Joined: Sun Jan 24, 2010 10:58 am

Linux Mint is funded by ads and donations.
 

Re: midi support by default

Postby BozoDel on Thu Aug 02, 2012 10:36 am

I have a guess about this, somebody please tell me if I'm right

TiMidity (or any other similar program) is not set up as default because there is no complete open source soundfont out there.

And why bother with making an open source soundfont when there are much more relevant issues to be fixed?

Is this the problem? Cause if it is, I might be interested in trying to improve the soundfonts (though not immediately and having no previous experience).
BozoDel
Level 1
Level 1
 
Posts: 23
Joined: Sun Apr 01, 2012 3:08 pm

Re: midi support by default

Postby Mozenrath on Fri Nov 02, 2012 12:16 pm

I agree that midi should be supported by default, but as long as there are other usability issues, nobody is going to bother making a FOSS soundfont. Though honestly, I don't really know what it takes to make a soundfont.

Anyone who needs midi can easily install Qsynth.
Mozenrath
Level 4
Level 4
 
Posts: 212
Joined: Thu Jun 17, 2010 12:41 am


Return to Suggestions & New Ideas

Who is online

Users browsing this forum: No registered users and 8 guests