Howto: Remove Fortune messages in the Terminal

Write tutorials and howtos in here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

Re: Howto: Remove Fortune messages in the Terminal

Postby vincent on Wed Jun 09, 2010 6:43 pm

clem wrote:- open a terminal
- type "gksu gedit /etc/bash.bashrc"
- in the end of the file, remove the line /usr/games/fortune
- save the file.

Clem


Knowledge, I'm going to quote Clem's post above to make my point clear.
Code: Select all
gksudo gedit /etc/bash.bashrc


Is typing the above command in a terminal all that difficult to do? This will give you the privileges needed to edit the file (that's the purpose of [gk]sudo).
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Linux Mint is funded by ads and donations.
 

Re: Howto: Remove Fortune messages in the Terminal

Postby Knowledge on Wed Jun 09, 2010 9:08 pm

vincent wrote:
clem wrote:- open a terminal
- type "gksu gedit /etc/bash.bashrc"
- in the end of the file, remove the line /usr/games/fortune
- save the file.

Clem


Knowledge, I'm going to quote Clem's post above to make my point clear.
Code: Select all
gksudo gedit /etc/bash.bashrc


Is typing the above command in a terminal all that difficult to do? This will give you the privileges needed to edit the file (that's the purpose of [gk]sudo).


GOD I WISH I WASN'T A NOOB! i forgot i uninstalled gedit a couple of days ago....smh haha! so i just replace gedit with gvim and used gvim try and do it...but nope it didn't work i didn't give me the privledges so i guess gedit can do somethings that vim can't do although i like vim more...haha thanks for being patient with my noob-ish-ness haha!

all guru's were once noobs you know?
OS: Windows 7 Ultimate x64/ Linux Mint 9 x64
CPU: Intel(R) Pentium(R) Dual T3200 @ 2.00GHz
RAM: 2GB
Graphics Card: Mobile Intel(R) 4 Series Express Chipset Family
Audio: Realtek High Definition Audio
DVD/CD Drive: HL-DT-ST DVDRAM GSA-T50N
Knowledge
Level 1
Level 1
 
Posts: 49
Joined: Fri Apr 23, 2010 5:10 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby vincent on Wed Jun 09, 2010 9:13 pm

All right...well, if you don't have gedit (you can re-install it, you know), let's use nano instead, which I know works fairly well off the bat.
Code: Select all
sudo nano /etc/bash.bashrc


Same thing, only keep in mind that in nano, CTRL + O is to save the file and CTRL + X is to exit nano.
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: Howto: Remove Fortune messages in the Terminal

Postby Knowledge on Wed Jun 09, 2010 9:41 pm

vincent wrote:All right...well, if you don't have gedit (you can re-install it, you know), let's use nano instead, which I know works fairly well off the bat.
Code: Select all
sudo nano /etc/bash.bashrc


Same thing, only keep in mind that in nano, CTRL + O is to save the file and CTRL + X is to exit nano.

thanks but i already did re-installed and did this remove fortune thing already...but thanks though
OS: Windows 7 Ultimate x64/ Linux Mint 9 x64
CPU: Intel(R) Pentium(R) Dual T3200 @ 2.00GHz
RAM: 2GB
Graphics Card: Mobile Intel(R) 4 Series Express Chipset Family
Audio: Realtek High Definition Audio
DVD/CD Drive: HL-DT-ST DVDRAM GSA-T50N
Knowledge
Level 1
Level 1
 
Posts: 49
Joined: Fri Apr 23, 2010 5:10 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby vincent on Wed Jun 09, 2010 11:38 pm

Whew, glad you managed to get it done at last! :)
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: Howto: Remove Fortune messages in the Terminal

Postby Knowledge on Thu Jun 10, 2010 4:13 pm

vincent wrote:Whew, glad you managed to get it done at last! :)

haha thanks for dealing with my noob-ness :)

i learned a lot from trying to do this....like basic terminal commands and such. this was a really good experience though overall! thanks again
OS: Windows 7 Ultimate x64/ Linux Mint 9 x64
CPU: Intel(R) Pentium(R) Dual T3200 @ 2.00GHz
RAM: 2GB
Graphics Card: Mobile Intel(R) 4 Series Express Chipset Family
Audio: Realtek High Definition Audio
DVD/CD Drive: HL-DT-ST DVDRAM GSA-T50N
Knowledge
Level 1
Level 1
 
Posts: 49
Joined: Fri Apr 23, 2010 5:10 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby trampintransit on Tue Jun 15, 2010 12:30 pm

clem wrote:- open a terminal
- type "gksu gedit /etc/bash.bashrc"
- in the end of the file, remove the line /usr/games/fortune
- save the file.

Clem


i only have ... '/usr/bin/mint-fortune' at the end of the file, do i remove that?
trampintransit
Level 1
Level 1
 
Posts: 39
Joined: Sun Feb 07, 2010 3:31 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby vincent on Tue Jun 15, 2010 2:30 pm

Yes, remove that, or append the # symbol in front of it. Save the file and then re-open gnome-terminal.
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: Howto: Remove Fortune messages in the Terminal

Postby Brad on Thu Jun 17, 2010 3:18 pm

You monsters!Who'd want to remove those fortune messages?Their the best!
Brad
Level 2
Level 2
 
Posts: 80
Joined: Fri Apr 09, 2010 7:33 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby Brad on Sat Jun 26, 2010 3:29 pm

why would you ever want to do that?
Brad
Level 2
Level 2
 
Posts: 80
Joined: Fri Apr 09, 2010 7:33 pm

Re:

Postby zackattack_11843 on Sun Jun 27, 2010 3:40 pm

mumbo719 wrote:While you have the terminal open remove the fortune program.

Code: Select all
sudo apt-get remove fortune

any way to make the background black again like it was
zackattack_11843
Level 1
Level 1
 
Posts: 31
Joined: Sun Dec 20, 2009 4:56 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby zackattack_11843 on Sun Jun 27, 2010 3:54 pm

Okay I'm sorry for what i did i tried to remove the little cartoons just to make the terminal look more ... official i guess?
but now all my appearances are messed up
i had it where it was black now everything is white and a lot of my icons completely changed
i typed this into the terminal

sudo apt-get remove fortune

i tried replacing "remove" with "install" but nothing
can somebody please help me to get things back to the way they were
i promise i won't ever disrespect the ways of linux again
thank you
zackattack_11843
Level 1
Level 1
 
Posts: 31
Joined: Sun Dec 20, 2009 4:56 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby vincent on Sun Jun 27, 2010 9:04 pm

Removing the fortunes wasn't the problem, it's that you removed a whole slew of other dependencies...

Code: Select all
vincent@vincent-laptop ~ $ sudo apt-get remove fortune
[sudo] password for vincent:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting fortune-mod instead of fortune
The following packages will be REMOVED:
  fortune-mod fortunes-husse fortunes-min mint-artwork-common
  mint-artwork-gnome mintsystem
0 upgraded, 0 newly installed, 6 to remove and 1 not upgraded.
After this operation, 13.1MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.


I'd think you'd want to re-install mint-artwork-common, mint-artwork-gnome, and mintsystem, but I believe they'll use the fortunes packages as dependencies:
Code: Select all
vincent@vincent-laptop ~ $ apt depends mintsystem
mintsystem
Depends: <mint-info>
mint-info-x64
Depends: cowsay
Depends: <fortune>
fortune-mod
Depends: mint-common
Depends: fortunes-husse


So, to fix this and get rid of fortunes as well, type the following commands in a terminal:
Code: Select all
sudo apt-get install fortune-mod fortunes-husse fortunes-min mint-artwork-common mint-artwork-gnome mintsystem
gksudo gedit /etc/bash.bashrc


And remove/comment out the line at the bottom, i.e. /usr/bin/mint-fortune. Save, and exit Gedit.

Open a new terminal. Your fortunes should no longer be there.
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: Howto: Remove Fortune messages in the Terminal

Postby gychang on Sat Jul 03, 2010 3:25 pm

much improved after "sudo apt-get remove fortune" on my LM9 but now when I open the terminal I get this before the prompt.

"bash: /usr/bin/mint-fortune: No such file or directory"!, have to clear each time to get clean prompt. Any help out there?

gychang
--
cruising the desert
--
User avatar
gychang
Level 3
Level 3
 
Posts: 143
Joined: Tue Dec 09, 2008 12:24 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby vincent on Sat Jul 03, 2010 5:01 pm

gychang wrote:much improved after "sudo apt-get remove fortune" on my LM9 but now when I open the terminal I get this before the prompt.

"bash: /usr/bin/mint-fortune: No such file or directory"!, have to clear each time to get clean prompt. Any help out there?

gychang


Open a terminal and type the following:
Code: Select all
gksudo gedit /etc/bash.bashrc

in the end of the file, comment out/remove the line /usr/bin/mint-fortune, and then save the file. Open a new terminal and you should no longer see that line.
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: Howto: Remove Fortune messages in the Terminal

Postby richiclway on Fri Aug 06, 2010 12:53 pm

Found this in bash.bashsrc:

if [ ! -f ~/.disable-mint-fortunes ]; then
/usr/bin/mint-fortune
fi

so perhaps create a file called ~/.disable-mint-fortunes
richiclway
Level 1
Level 1
 
Posts: 2
Joined: Fri Aug 06, 2010 8:01 am

Re: Howto: Remove Fortune messages in the Terminal

Postby cologne on Thu Aug 19, 2010 1:19 pm

richiclway wrote:so perhaps create a file called ~/.disable-mint-fortunes

I also found this built-in solution, when I wanted to comment out the line /usr/bin/mint-fortune (as it reads in latest editions). The howtos don´t consider this new content of the config file, at least not yet.

I tried it out, created an empty file with this name and it works!

Generally I appreciate customizing through config files of the user instead of modifying system files. I think I will mention this method in the community website.
cologne
Level 1
Level 1
 
Posts: 2
Joined: Tue Apr 20, 2010 5:30 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby kai3345 on Sat Aug 21, 2010 8:29 pm

[Deleted]
Last edited by kai3345 on Wed Jun 12, 2013 6:25 pm, edited 1 time in total.
kai3345
Level 1
Level 1
 
Posts: 8
Joined: Mon Jun 07, 2010 7:03 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby telic on Fri Nov 05, 2010 2:18 pm

Why on Earth is this sophomoric preference (still) a default for Mint users? Should it caution me to think twice about entrusting my enterprise environment to a collegiate OS mindset?

:roll:
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Re: Howto: Remove Fortune messages in the Terminal

Postby tdockery97 on Fri Nov 05, 2010 5:31 pm

telic wrote:Why on Earth is this sophomoric preference (still) a default for Mint users? Should it caution me to think twice about entrusting my enterprise environment to a collegiate OS mindset?

:roll:

You might want to open up Package Manager and install a sense of humor. :D
Image

HP Pavilion 17 Notebook, 8GB DDR3, 2.5GHZ A10-APU, Radeon HD 8650G
Registered Linux User #520972
User avatar
tdockery97
Level 13
Level 13
 
Posts: 4869
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Tutorials / Howtos

Who is online

Users browsing this forum: No registered users and 14 guests