Skype or Camera problem?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Skype or Camera problem?

Postby kbkatz1 on Sat Jul 17, 2010 6:27 pm

I have Skype installed with a Micro Innovations CM10401 webcam. I cannot get the camera to work with Skype. Skype calls my webcam "Generic Digital camera (/dev/video0), while in the Terminal it is recognized as "Bus 004 Device 002: ID 04fc:0561 Sunplus Technology Co., Ltd Flexcam 100". In the video setup in Skype nothing happens when I click the "test" button. I have found a driver "gspcav1-200071224.tar.gz" that says it is compatible with the Flexcam 100 but I do not know how to install or set this up.

Any ideas?
LMDE
LM12 "Lisa"
ClearOS Server
User avatar
kbkatz1
Level 3
Level 3
 
Posts: 130
Joined: Tue Jun 15, 2010 4:28 pm
Location: U.S.A

Linux Mint is funded by ads and donations.
 

Re: Skype or Camera problem?

Postby JasonLG on Sat Jul 17, 2010 6:46 pm

kbkatz1 wrote:I have Skype installed with a Micro Innovations CM10401 webcam. I cannot get the camera to work with Skype. Skype calls my webcam "Generic Digital camera (/dev/video0), while in the Terminal it is recognized as "Bus 004 Device 002: ID 04fc:0561 Sunplus Technology Co., Ltd Flexcam 100". In the video setup in Skype nothing happens when I click the "test" button. I have found a driver "gspcav1-200071224.tar.gz" that says it is compatible with the Flexcam 100 but I do not know how to install or set this up.

Any ideas?


Extract the archive and look for the instructions.
"I see" said the blind man to the deaf man who stuck his wooden leg out the window to check the weather.
JasonLG
Level 7
Level 7
 
Posts: 1624
Joined: Thu May 20, 2010 9:15 pm
Location: Polk City, Iowa USA

Re: Skype or Camera problem?

Postby kbkatz1 on Fri Jul 23, 2010 6:56 pm

The READ ME file is not much help. This download is for many different webcam versions, so this leads me back to square one, where to start? Any ideas?
LMDE
LM12 "Lisa"
ClearOS Server
User avatar
kbkatz1
Level 3
Level 3
 
Posts: 130
Joined: Tue Jun 15, 2010 4:28 pm
Location: U.S.A

Re: Skype or Camera problem?

Postby JasonLG on Sun Jul 25, 2010 10:33 am

kbkatz1 wrote:The READ ME file is not much help. This download is for many different webcam versions, so this leads me back to square one, where to start? Any ideas?


I downloaded the drivers and the READ_AND_INSTALL file provides instructions in the "Compiling it" and "Trying a v4l app" sections. Follow the instructions. If you are unable to understand the instructions I would suggest buying a Linux compatable UVC Webcam. http://www.ideasonboard.org/uvc/
"I see" said the blind man to the deaf man who stuck his wooden leg out the window to check the weather.
JasonLG
Level 7
Level 7
 
Posts: 1624
Joined: Thu May 20, 2010 9:15 pm
Location: Polk City, Iowa USA

SOLVED: Re: Skype or Camera problem?

Postby kbkatz1 on Wed Aug 04, 2010 6:47 pm

Easiest Fix: Installed "Video4Linux Control Panel (V4L2)", opened it up, go to Preview, Configure Preview, Change Application to use to Skype. Now to Launch Skype use V4L2 and "start preview". Works great.
LMDE
LM12 "Lisa"
ClearOS Server
User avatar
kbkatz1
Level 3
Level 3
 
Posts: 130
Joined: Tue Jun 15, 2010 4:28 pm
Location: U.S.A

Re: Skype or Camera problem?

Postby Deut316 on Thu Aug 05, 2010 5:19 am

I had the same problem.

v4l worked for me..... just close skype and re open for changes to take place.
Deut316
Level 1
Level 1
 
Posts: 9
Joined: Wed Aug 04, 2010 2:05 am

Re: Skype or Camera problem?

Postby rykel98 on Tue Dec 13, 2011 9:16 pm

v4l.png
v4l.png (83.19 KiB) Viewed 2207 times
@kbkatz - You mentioned, "Easiest Fix: Installed "Video4Linux Control Panel (V4L2)", opened it up, go to Preview, Configure Preview, Change Application to use to Skype. Now to Launch Skype use V4L2 and "start preview". Works great."

As you can see from my screenshot, I cannot find the v4l control panel... where can I find it? (Using Linux Mint 12)

Also, does it have to be so difficult to get Skype - which is in the repository by default - to work properly?
rykel98
Level 1
Level 1
 
Posts: 45
Joined: Sun May 22, 2011 7:22 am

Re: SOLVED: Re: Skype or Camera problem?

Postby rykel98 on Tue Dec 13, 2011 9:43 pm

kbkatz1 wrote:Easiest Fix: Installed "Video4Linux Control Panel (V4L2)", opened it up, go to Preview, Configure Preview, Change Application to use to Skype. Now to Launch Skype use V4L2 and "start preview". Works great.


Hi, I found the control panel you mentioned... simply search for "v4l2ucp" instead of "v4l", but as you can see from the screenshot, this does NOT work for Skype in Linux Mint 12... the video is BLACK.
rykel98
Level 1
Level 1
 
Posts: 45
Joined: Sun May 22, 2011 7:22 am

Re: Skype or Camera problem?

Postby rykel98 on Tue Jan 03, 2012 11:25 pm

This *might* work~

1. Edit Skype binary -
sudo gedit /usr/local/bin/skype

2. Add the following lines in the blank text -
#!/bin/bash
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype

3. Make it executable -
sudo chmod a+x /usr/local/bin/skype
rykel98
Level 1
Level 1
 
Posts: 45
Joined: Sun May 22, 2011 7:22 am

Re: Skype or Camera problem?

Postby skelms on Sat May 18, 2013 7:20 am

rykel98 wrote:This *might* work~

1. Edit Skype binary -
sudo gedit /usr/local/bin/skype

2. Add the following lines in the blank text -
#!/bin/bash
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype

3. Make it executable -
sudo chmod a+x /usr/local/bin/skype


Thank you so much, video works now in skype....is there a like or thanks button that I missed somewhere?
nvidia Geforce GTX550Ti
Dual booting: Linux Mint 17 cin 64bit, and Windows 7

Tablet Nexus 7: rooted, cynogenmod
skelms
Level 1
Level 1
 
Posts: 5
Joined: Sat May 18, 2013 7:17 am

Re: Skype or Camera problem?

Postby GriGri on Fri Jun 21, 2013 12:45 am

To: rykel98
Your instructions left me with real questions as to how to follow along.
As a long time Linux User - but not a programmer - I did not feel confident that I was doing what you said to do.
But what I did do WORKED. Problem (upside down video in skype) is fixed.
Thank you . Thank you. Thank you.
I've been trawling forums for half a day, in my stumbling ignorance and you've done for me in three lines, what others couldn't in page long disertations.

And thank you LM for a forum well enough organised that I could find my issue area.
A grateful noob, GriGri
GriGri
Level 1
Level 1
 
Posts: 4
Joined: Fri Jun 21, 2013 12:29 am

Re: Skype or Camera problem?

Postby Gutknecht on Tue Dec 31, 2013 9:28 pm

I'm running Linux Mint 13 64-bit Cinnamon. The solution does not work for my ASUS UL30A. My video on Skype is still upsidedown. I know I fixed it once before, but I don't remember how I did it. But I did locate the libv4. When I try to preload it I get the following:

LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so /usr/local/bin/skype
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.

I have verified the path and it is correct. Any help would be welcomed! Thanks. Rick
Gutknecht
Level 1
Level 1
 
Posts: 36
Joined: Mon Jul 27, 2009 7:32 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 43 guests