HOWTO: Improve Font Rendering in LMDE

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Re: HOWTO: Improve Font Rendering in LMDE

Postby randomizer on Fri Sep 24, 2010 9:21 am

Does this affect Open Office as well? I could deal with Firefox and other applications using the ~/.fonts.conf I posted in another thread, but Open Office refused to comply. Only changes in the Appearance dialog had any affect on Open Office for me, and there's not enough granular control with that.
User avatar
randomizer
Level 5
Level 5
 
Posts: 871
Joined: Mon May 03, 2010 7:15 am

Linux Mint is funded by ads and donations.
 

Re: HOWTO: Improve Font Rendering in LMDE

Postby anamnesis on Fri Sep 24, 2010 9:37 am

Just copied a sample out off my ooo. I'm happy with that. Font is Times New Roman/12pt.

LöY RSC @ ¹²³¼½ kloü ß LÖÄ sdh09765
anamnesis
Level 2
Level 2
 
Posts: 65
Joined: Sat Sep 18, 2010 12:01 pm
Location: Cornwall, GB

Re: HOWTO: Improve Font Rendering in LMDE

Postby randomizer on Fri Sep 24, 2010 9:49 am

ikey wrote:The gconftool calls in the script do what the Appearance dialog would be doing.
I tried mixing this approach with ~/.fonts.conf.. but the fonts ended up spaced
out and distorted with really bad colour-bleeding on thin fonts


Good show, I will have to try this out for sure. I could not type up a lengthy document with the font rendering Open Office was giving me. It was truly appalling.
User avatar
randomizer
Level 5
Level 5
 
Posts: 871
Joined: Mon May 03, 2010 7:15 am

Re: HOWTO: Improve Font Rendering in LMDE

Postby pappfer on Fri Sep 24, 2010 10:28 am

I tried the script but I have the same problem as some other posted: I can't open the appearances menu. The error is the following:
Code: Select all
/usr/share/themes/Shiki-Wise/gtk-2.0/gtkrc:126: Murrine configuration option "gradients" is no longer supported and will be ignored.
/usr/share/themes/Shiki-Wise/gtk-2.0/gtkrc:126: Murrine configuration option "gradients" is no longer supported and will be ignored.
The program 'gnome-appearance-properties' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 594 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


When I used the fix (gconftool-2 --unset "/desktop/gnome/font_rendering/dpi") the appearances menu worked but I had really huge fonts).

Any advices?
pappfer
Level 2
Level 2
 
Posts: 73
Joined: Tue Jan 19, 2010 8:35 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby kmb42vt on Fri Sep 24, 2010 10:40 am

pappfer wrote:I tried the script but I have the same problem as some other posted: I can't open the appearances menu. The error is the following:
Code: Select all
/usr/share/themes/Shiki-Wise/gtk-2.0/gtkrc:126: Murrine configuration option "gradients" is no longer supported and will be ignored.
/usr/share/themes/Shiki-Wise/gtk-2.0/gtkrc:126: Murrine configuration option "gradients" is no longer supported and will be ignored.
The program 'gnome-appearance-properties' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 594 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


When I used the fix (gconftool-2 --unset "/desktop/gnome/font_rendering/dpi") the appearances menu worked but I had really huge fonts).

Any advices?


Did you run the fix for this that Ikey posted along with the script (first post on this thread)? If you missed it, here it is. Just run it in terminal:

Code: Select all
gconftool-2 --unset "/desktop/gnome/font_rendering/dpi


Hope it works for you. If you've already done this maybe Ikey can give you some further help.

BTW, the first two lines of error code you posted occurs every time I update anything that even remotely involves gradients, Murrine, GTK2 and Shikiwise including doing the initial updating on a fresh LMDE load so I don't believe those first two lines matter at all.
Last edited by kmb42vt on Fri Sep 24, 2010 10:46 am, edited 1 time in total.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)
User avatar
kmb42vt
Level 5
Level 5
 
Posts: 932
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont

Re: HOWTO: Improve Font Rendering in LMDE

Postby pappfer on Fri Sep 24, 2010 10:45 am

Yes, as you can read it in the end of my post I also tried that and it fixed the problem, although it made the fonts huge.
pappfer
Level 2
Level 2
 
Posts: 73
Joined: Tue Jan 19, 2010 8:35 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby kmb42vt on Fri Sep 24, 2010 10:55 am

pappfer wrote:Yes, as you can read it in the end of my post I also tried that and it fixed the problem, although it made the fonts huge.


Oops, sorry about that. My eyes must have been crossed or something. :oops: Now I know this is a stupid question but if the fix brought back the access to Appearances, does it show your font size set to 10 and DPI set to 96 as it should be? I know this sounds obvious but redundancy checks sometime pay off.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)
User avatar
kmb42vt
Level 5
Level 5
 
Posts: 932
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont

Re: HOWTO: Improve Font Rendering in LMDE

Postby pappfer on Fri Sep 24, 2010 11:04 am

Everything is 10px but the DPI was set to 128. I changed it to 96 and it all looks fine now. Thanks! :)
pappfer
Level 2
Level 2
 
Posts: 73
Joined: Tue Jan 19, 2010 8:35 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby kmb42vt on Fri Sep 24, 2010 11:08 am

pappfer wrote:Everything is 10px but the DPI was set to 128. I changed it to 96 and it all looks fine now. Thanks! :)


No problem at all. Here's to redundancy checks. :D
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)
User avatar
kmb42vt
Level 5
Level 5
 
Posts: 932
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont

Re: HOWTO: Improve Font Rendering in LMDE

Postby dogbert176 on Sat Sep 25, 2010 8:07 am

hello,

When I tried to execute the script fixfonts.sh with "./fixfonts.sh", it gave me a series of errors:
"rule 14-31: command not found ("opdracht niet gevonden")
./fixfonts.sh: regel 14: --set: opdracht niet gevonden
./fixfonts.sh: regel 15: --set: opdracht niet gevonden
./fixfonts.sh: regel 17: --set: opdracht niet gevonden
./fixfonts.sh: regel 18: --set: opdracht niet gevonden
Setting default fonts..
./fixfonts.sh: regel 28: --set: opdracht niet gevonden
./fixfonts.sh: regel 29: --set: opdracht niet gevonden
./fixfonts.sh: regel 30: --set: opdracht niet gevonden
./fixfonts.sh: regel 31: --set: opdracht niet gevonden


Anyone who knows what could be the problem?
dogbert176
Level 1
Level 1
 
Posts: 14
Joined: Wed May 13, 2009 1:06 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby randomizer on Sat Sep 25, 2010 8:54 pm

Did you run "chmod +x ./fixfonts.sh" first?
User avatar
randomizer
Level 5
Level 5
 
Posts: 871
Joined: Mon May 03, 2010 7:15 am

Re: HOWTO: Improve Font Rendering in LMDE

Postby dogbert176 on Sun Sep 26, 2010 4:16 am

I have a script "fixfonts.sh" in my home directory.
In a terminal, I entered the 2 commands in Ikey's first post:

* chmod +x ./fixfonts.sh
* ./fixfonts.sh

The first command did nothing, the second gave me the errors "rule xxx: command not found".
So I think I followed instructions, but no result.

:roll:
dogbert176
Level 1
Level 1
 
Posts: 14
Joined: Wed May 13, 2009 1:06 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby randomizer on Sun Sep 26, 2010 6:27 am

Odd. you could also try "sh ./fixfonts.sh"
User avatar
randomizer
Level 5
Level 5
 
Posts: 871
Joined: Mon May 03, 2010 7:15 am

Re: HOWTO: Improve Font Rendering in LMDE

Postby dogbert176 on Sun Sep 26, 2010 9:45 am

Nevermind ....
I copied Ikey's script again in a new file, executed the commands and everything is working now.

My fault, obviously :oops:
dogbert176
Level 1
Level 1
 
Posts: 14
Joined: Wed May 13, 2009 1:06 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby craigevil on Sun Oct 03, 2010 12:07 pm

No need to use a script to fix fonts.

Enable Smooth Fonts in Debian. - Linux Forums
http://www.linuxforums.org/forum/debian ... ebian.html
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: HOWTO: Improve Font Rendering in LMDE

Postby off220 on Mon Oct 04, 2010 10:28 pm

great, but it would be even greater if someone who knows would add the improvement for KDE fonts too. It would be awesome to have one script that makes fonts in all DE look the same.
Happy LMDE user.
off220
Level 1
Level 1
 
Posts: 43
Joined: Wed Sep 15, 2010 1:46 am

Re: HOWTO: Improve Font Rendering in LMDE

Postby mfdemicco on Mon Oct 04, 2010 10:54 pm

anamnesis wrote:Beautiful or at least very satisfying fonts here: LCD 1440x900@60hz
Appearance -> fonts -> details -> lcd subpixel "slight" /Resolution 96dpi. That it. No scripts, no screwing.
hth
anamnesis


The appearance control panel is broken. The settings don't take (at least for me. Maybe it needs to run as root). Every time I go into to it, the buttons show a "-" instead of a ".". Hence the need for this script and/or the .fonts.config file in your home folder.
mfdemicco
Level 1
Level 1
 
Posts: 36
Joined: Tue Mar 10, 2009 6:07 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby randomizer on Tue Oct 05, 2010 5:52 am

mfdemicco wrote:The appearance control panel is broken. The settings don't take (at least for me. Maybe it needs to run as root). Every time I go into to it, the buttons show a "-" instead of a ".".

This is normal, but rather unintuitive behaviour. Any time the settings in the Appearance->Fonts->Details dialog are altered so that they do not equal any of the presets on the Appearance->Fonts dialog, those presets have the hyphen in the place of a normal radio button. There's no real indication that this is what is meant to happen though, and having them all show this icon doesn't really tell the user any meaningful information.
User avatar
randomizer
Level 5
Level 5
 
Posts: 871
Joined: Mon May 03, 2010 7:15 am

Re: HOWTO: Improve Font Rendering in LMDE

Postby randomizer on Fri Oct 08, 2010 2:19 am

I don't seem to be needing this now. Maybe I have some leftover configuration from Lucid but I wiped that and installed LMDE and the fonts look far better than they ever did before, if not the same as on Lucid. Running the script doesn't make any difference now, except for enabling subpixel rendering, but I changed it so that it uses greyscale instead. Windows does subpixel rendering pretty good, but colour fringing has always been a noticeable issue for me in Linux.
User avatar
randomizer
Level 5
Level 5
 
Posts: 871
Joined: Mon May 03, 2010 7:15 am

Re: HOWTO: Improve Font Rendering in LMDE

Postby Kazmirzak on Fri Oct 08, 2010 8:55 pm

"If you look at what the script does, it sets the resolution to 96dpi and sets LCD to slight already."

funny enough, I did a clean install of LMDE and applied all updates - and the settings above were already active, and my fonts look good as they should.
Kazmirzak
Level 1
Level 1
 
Posts: 14
Joined: Wed May 19, 2010 3:35 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot] and 3 guests