Camera not detected.

Questions about hardware and drivers
Forum rules

Camera not detected.

Postby newfie on Tue Sep 21, 2010 8:32 pm

Hey guys, I'm having an issue with my "Canon PowerShot SX120 IS" camera on LMDE. When I had Ubuntu, Mint 9 and Sabayon, the camera would instantly be detected and mount.

If I were to use Ubuntu, I'd plug the camera in via USB port and turn it on. That would bring up a window asking me to import to F-Spot. On LMDE, I plug it in but when I turn it on, the camera just turns on as normal.

It's not a big issue yet, but in time it will be required. I really don't want to need to dual boot/virtualize/get rid of LMDE. I love this distro :)
User avatar
Level 2
Level 2
Posts: 92
Joined: Fri Nov 20, 2009 2:47 pm

Linux Mint is funded by ads and donations.

Re: Camera not detected.

Postby jaybird_62613 on Sat Oct 09, 2010 1:17 pm

I'm having the same issues with my camera. Have you found a solution yet?

I solved my problem. I simply added myself to the plugdev group. :D
Level 1
Level 1
Posts: 6
Joined: Sat Oct 09, 2010 1:15 pm

Re: Camera not detected.

Postby Berkah on Sat Mar 10, 2012 6:23 am

didn't work with mine on LMDE :?
User avatar
Level 2
Level 2
Posts: 69
Joined: Thu Dec 10, 2009 6:04 am

Re: Camera not detected.

Postby mingle on Wed Sep 26, 2012 5:27 am

Same with me and my Canon IXUS 400...

Plug-in, switch-on (in playback mode), but LM doesn't react at all...

Any clues?

User avatar
Level 2
Level 2
Posts: 50
Joined: Thu May 24, 2012 9:58 pm

Re: Camera not detected.

Postby Flemur on Wed Sep 26, 2012 9:58 am

I had this problem on an Arch install; here's what I learned ( not much!):
- sometimes pcmanfm would "see" sd cards when thunar didn't; neither saw the camera. Perhaps try both.
- when nothing saw the camera, check out gphoto:
# gphoto2 --list-ports
# gphoto2 --auto-detect # shows USB address that needs to be e.g. "chmod o+w /dev/bus/usb/001/003"
# gphoto2 --summary
# gphoto2 --list-files
# gphoto2 --get-all-files

So I used these two:

$ gphoto2 --list-files (show all files on the camera (in all directories).
$ gphoto2 --get-all-files (copy all the files to current directory)

It's primitive but might work if nothing else does.
Mint 17.3 Xfce/fluxbox/pulse-less - Xubuntu 15.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
User avatar
Level 8
Level 8
Posts: 2389
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 2 guests