If your scanner doesn't work

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Re: If your scanner doesn't work

Postby cato40 on Thu Jun 17, 2010 11:34 pm

Hi All :
I thought that I had success with the latest forum entry for my Brother DCp-115C Multifunction.But, I get the following error:
Error during CMS conversion could not open scanner ICM profile.
Hope this helps, nearly there.
cato40 :|
cato40
Level 3
Level 3
 
Posts: 177
Joined: Tue Feb 26, 2008 6:49 pm

Linux Mint is funded by ads and donations.
 

Re: If your scanner doesn't work

Postby cato40 on Mon Jun 21, 2010 6:33 am

SOLVED!!!!!!!!!!!!!!!!!!
i Thought that I would not be able to scan any documents, but I was able to locate my trial document in my Home file, as a jpeg. file.
So thanks to every one who participated in helping me. It does work, Thanks, Mint.
cato40 :D
cato40
Level 3
Level 3
 
Posts: 177
Joined: Tue Feb 26, 2008 6:49 pm

Re: If your scanner doesn't work

Postby jabot on Sun Sep 19, 2010 4:11 am

Hi all,
just thought I'd share this fix with anyone who needs to get an Epson scanner working, (Mint 9 and i.i.r.c. also on Mint 7).
I do a lot of film photography and consequent scanning of negatives and slides, so I really needed to get my scanner up and running on Mint 9 now that I have dumped XP. Unfortunately though my V200 scanner isn't supported in Sane, Xsane or anywhere else, so I needed to find an answer elsewhere. By good luck I remembered seeing something about Avasys here in the forums and tried their website :

http://avasys.jp/eng/linux_driver/

It's not the most intuitive of sites to work in, but I finally located and downloaded a .deb file that seemed to be recommended for my V200; I installed it and BINGO !!
My scanner works fine with the gui provided with the program and an old Perfection 1200 I have works with it too. I can now scan docs, photos, negatives and slides - Result
It still won't work with Sane though !
I hope this info helps someone ....
jabot
Level 1
Level 1
 
Posts: 5
Joined: Thu Jul 30, 2009 12:06 pm

Re: If your scanner doesn't work-- Brother DCP-7040

Postby donvin on Tue Sep 21, 2010 1:49 am

Do I have to go back to Ubuntu where it works fine????

The printer of this multifunction works well after following the instructions on the Brother site for Ubuntu. I followed the Brother instructions for adding the scanner driver. The command to check for its being loaded says it is installed.

I've added the line "ATTRS{idVendor}=="04f9", ENV{libsane_matched}=="yes"" to both 40-llibsane.rules under both /lib/udev/rules.d and /lib32/udev/rules.d. The equivalent in Ubuntu (really Studio) allows the scanner to scan.

In Mint 9 neither Xsane nor Simple Scan find a scanner. What am I doing wrong?
Thanks for any help.

Don
donvin
Level 1
Level 1
 
Posts: 3
Joined: Tue Sep 21, 2010 12:41 am

Re: If your scanner doesn't work-- Brother DCP-7040

Postby donvin on Wed Sep 22, 2010 1:05 am

Solved. After several hours of work, I found I hadn't installed the driver in the correct directory. Someday I'll learn.... Why do the various versions of Linux put standard files in different directories???
Now i can keep using Mint, thank goodness.
donvin
Level 1
Level 1
 
Posts: 3
Joined: Tue Sep 21, 2010 12:41 am

Re: If your scanner doesn't work

Postby arslanshah on Thu Oct 14, 2010 2:29 pm

This is great solution of to solve the scanner problem. I am facing this problem. After joining this, I am able to solve my scanner problem. I suggest to other people com to this discussion and solve their problem. Thanks
arslanshah
Level 1
Level 1
 
Posts: 2
Joined: Thu Oct 14, 2010 2:22 pm

Re: If your scanner doesn't work

Postby cupofcalculus on Sun Oct 17, 2010 11:03 pm

jabot wrote:Hi all,
just thought I'd share this fix with anyone who needs to get an Epson scanner working, (Mint 9 and i.i.r.c. also on Mint 7).
I do a lot of film photography and consequent scanning of negatives and slides, so I really needed to get my scanner up and running on Mint 9 now that I have dumped XP. Unfortunately though my V200 scanner isn't supported in Sane, Xsane or anywhere else, so I needed to find an answer elsewhere. By good luck I remembered seeing something about Avasys here in the forums and tried their website :

http://avasys.jp/eng/linux_driver/

It's not the most intuitive of sites to work in, but I finally located and downloaded a .deb file that seemed to be recommended for my V200; I installed it and BINGO !!
My scanner works fine with the gui provided with the program and an old Perfection 1200 I have works with it too. I can now scan docs, photos, negatives and slides - Result
It still won't work with Sane though !
I hope this info helps someone ....



I have an Epson Stylus NX420 All-in-one Printer, and I've downloaded and installed the driver. The printer works fine now, but I'm having trouble getting the scanner to work. The link provided by jabot is for Epson Scanners, but not for All-in-ones.

I'm brand new to Linux and I've been doing my best to read and research before posting. Could someone help walk me through this, or provide a link to a site that can? I really appreciate it. Thanks. :)
cupofcalculus
Level 1
Level 1
 
Posts: 6
Joined: Sun Oct 03, 2010 4:48 pm

Epson NX420 scanner driver from Epson

Postby pdc_2 on Mon Oct 18, 2010 12:07 am

http://www.avasys.jp/lx-bin2/linux_e/spc/DL1.do is the Epson site

as I see it, you download Image lite from the above page

clicking on NX420 gives this

http://avasys.jp/eng/linux_driver/downl ... kjet/escp/

which is the printer driver?
pdc_2
Level 6
Level 6
 
Posts: 1177
Joined: Mon May 11, 2009 1:21 am

Re: Epson NX420 scanner driver from Epson

Postby cupofcalculus on Mon Oct 18, 2010 12:30 am

pdc_2 wrote:http://www.avasys.jp/lx-bin2/linux_e/spc/DL1.do is the Epson site

as I see it, you download Image lite from the above page

clicking on NX420 gives this

http://avasys.jp/eng/linux_driver/downl ... kjet/escp/

which is the printer driver?


See if you can access this webpage.
http://www.avasys.jp/lx-bin2/linux_e/spc/DL2.do
cupofcalculus
Level 1
Level 1
 
Posts: 6
Joined: Sun Oct 03, 2010 4:48 pm

Re: If your scanner doesn't work

Postby cupofcalculus on Mon Oct 18, 2010 12:35 am

After downloading the printer driver, scanner driver, data package, and core package, I tried to use XSane Image Scanner and said

Failed to open device `epkowa:usb:002:003':
Access to resource has been denied.

Seems to be the closest I've been to getting it to work. :(
cupofcalculus
Level 1
Level 1
 
Posts: 6
Joined: Sun Oct 03, 2010 4:48 pm

Re: If your scanner doesn't work

Postby sylvainsjc on Mon Oct 18, 2010 2:12 am

cupofcalculus wrote:After downloading the printer driver, scanner driver, data package, and core package, I tried to use XSane Image Scanner and said

Failed to open device `epkowa:usb:002:003':
Access to resource has been denied.

Seems to be the closest I've been to getting it to work. :(


With your printer ON and connected, can you give the return of this commands in the terminal :

Code: Select all
uname -a
sane-config --version
sane-find-scanner
scanimage -V
scanimage -L
User avatar
sylvainsjc
Level 1
Level 1
 
Posts: 30
Joined: Sat Jan 03, 2009 6:51 am
Location: FRANCE - ISERE (38)

Re: If your scanner doesn't work

Postby cupofcalculus on Mon Oct 18, 2010 11:40 am

sylvainsjc wrote:
With your printer ON and connected, can you give the return of this commands in the terminal :

Code: Select all
uname -a
sane-config --version
sane-find-scanner
scanimage -V
scanimage -L



uname -a
Linux HAL-9000 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 x86_64 GNU/Linux

sane-config --version
The program 'sane-config' is currently not installed. You can install it by typing: sudo apt-get install libsane-dev

So I ran "sudo apt-get install libsane-dev" and now I get

1.0.20

sane-find-scanner
No SCSI scanners found. If you expected something different, make sure that you have loaded a kernel SCSI driver for your SCSI adapter
found USB scanner (vendor=0x04b8, product=0x0864) at libsub:002:003
Your USB scanner was (probably) detected. It may or may not be supported by SANE. Try scanimage -L and read the backend's manpage.

scanimage -V
scanimage (sane-backends) 1.0.20; backend version 1.0.20

scanimage -L
device `epkowa:usb:002:003' is a Epson (unknown model) flatbed scanner
cupofcalculus
Level 1
Level 1
 
Posts: 6
Joined: Sun Oct 03, 2010 4:48 pm

Re: If your scanner doesn't work

Postby goltoof on Tue Oct 19, 2010 2:20 pm

cupofcalculus wrote:
sylvainsjc wrote:So I ran "sudo apt-get install libsane-dev" and now I get...


I'm in the exact same spot as you now. When I hit Scan on the printer I get "Communication Error. Check the connection."

The printer works fine.

Using NX420
goltoof
Level 1
Level 1
 
Posts: 1
Joined: Tue Oct 19, 2010 2:10 pm

Re: If your scanner doesn't work

Postby cupofcalculus on Tue Oct 19, 2010 3:12 pm

I have the installation disc, if that's any help.
cupofcalculus
Level 1
Level 1
 
Posts: 6
Joined: Sun Oct 03, 2010 4:48 pm

Re: If your scanner doesn't work

Postby cupofcalculus on Thu Oct 21, 2010 5:07 pm

Well, I got my Epson Stylus NX420 scanner working. Not to my complete satisfaction, but it works. Here's what I did.

First, I opened up the terminal and typed: sudo apt-get install libsane-dev

Then I downloaded the file http://launchpadlibrarian.net/14664165/45-libsane.rules and pasted it in etc/udev/rules.d/ and then edited it by adding the line

# Epson Stylus NX420
SYSFS(idVendor)=="0x04b8", SYSFS(idProduct)=="0x0864", MODE="664", GROUP="scanner"

I tried pressing the button "Scan" on the NX420 itself, and the machine still said "Communication error. Check the connection". So I rebooted. Once I logged back in, and pressed the Scan button on the machine, it again said error. :(

However, when I opened up XSane Image Scanner, and I clicked the scan button on the screen, it worked! I don't know if a reboot is mandatory, but before you do, try using the XSane interface to scan before rebooting.

It'd be nice if I could press the button on the scanner itself and make it work. Any ideas?

And thanks for this thread. It helped! :)
cupofcalculus
Level 1
Level 1
 
Posts: 6
Joined: Sun Oct 03, 2010 4:48 pm

Re: If your scanner doesn't work

Postby sylvainsjc on Fri Oct 22, 2010 12:31 am

@cupofcalculus

You use 64 bits LinuxMint version

I never succeded to make the scanner work on a 64 bits system with 32 bits proprietary drivers (my experience with Lexmark)

Can you test with a 32 bits LinuxMint version ?
User avatar
sylvainsjc
Level 1
Level 1
 
Posts: 30
Joined: Sat Jan 03, 2009 6:51 am
Location: FRANCE - ISERE (38)

HP Photosmart B110 series

Postby skottyrg on Sat Nov 06, 2010 5:23 pm

Hi, i just bought a new HP Photosmart B110 series, It prints just fine, but I can't get it to scan. Any idea of how to do this?
thanks in advance!

Skotty
skottyrg
Level 1
Level 1
 
Posts: 13
Joined: Sat Dec 12, 2009 12:19 am

Re: If your scanner doesn't work

Postby Larsman on Fri Jan 07, 2011 5:43 pm

Epson RX580 all-in-one is scanning and printing now.
Get the epson and iscan deb's from Avasys (mine is i386, they also have 64), get the lenny deb from Ubuntu- do a Google search for it to make it an easier search:
Printer:
1. epson-inkjet-printer-escpr_1.0.1-1lsb3.2_i386.deb
Scanner:
1. iscan-data_1.6.0-0_all.deb (#3 won't install without this one)
2. libltdl3_1.5.26-4+lenny1_i386.deb (#3 won't install without this one)
3. iscan_2.26.1-3_i386.deb

I have Linux Mint, but it's pretty much Ubuntu.
Larsman
Level 1
Level 1
 
Posts: 1
Joined: Fri Jan 07, 2011 5:27 pm

Re: If your scanner doesn't work

Postby freusen on Sat Jan 08, 2011 1:27 pm

I have a Canon MX870 and it worked fine (printing and scanning) in LMDE-201009, now I installed a fresh copy of LMDE-201101 and the Canon MX870 works fine printing but not scanning. I installed the latest version of scangear, but I cann't get it working. Has any of you an idea or is it a bug?
freusen
Level 1
Level 1
 
Posts: 3
Joined: Sat Jan 08, 2011 7:07 am

Re: If your scanner doesn't work

Postby willie42 on Sat Jan 08, 2011 1:51 pm

Might want to make a new thread
Comptia A+ Certified Technician
Comptia Network + Certified Technician
You can not have Success without Failures.
User avatar
willie42
Level 7
Level 7
 
Posts: 1977
Joined: Tue Jun 22, 2010 7:52 pm
Location: Oak Ridge, TN USA

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Hardware Support

Who is online

Users browsing this forum: Google Adsense [Bot], hanspb and 11 guests